none
SQL server login issue

    Question

  • I'm trying to login to the SQL server from home but it throws up an error every time but I don’t have this trouble when I'm at university. Please see below for details.

    TITLE: Connect to Server

    ------------------------------

    Cannot connect to SQL-SERVER.

    ------------------------------

    ADDITIONAL INFORMATION:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 53)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=53&LinkId=20476

    Regards

                Graham Moody

    Email: mg326@greenwich.ac.uk

    Saturday, December 21, 2013 9:03 AM

Answers

  • Hi,                                                                                                                             

    As Balmukund said, more information is required to troubleshoot the issue. The error message indicates that the client could not connect to the target SQL Server. You can follow the link below to troubleshoot the general Connectivity issue:

    SQL Server 2005 Connectivity Issue Troubleshoot - Part I

    Troubleshoot Connectivity Issue in SQL Server 2005 - Part II

    Also, make sure that SQL server port is not blocked by firewall. Make sure that SQL Server Browser Service and TCP/IP is enabled in SQL Server Configuration Manager.

    You can check the SQL Server ErrorLOG for more details.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Monday, December 23, 2013 3:26 AM
    Moderator

All replies

  • if you have installed SQL Express then you need to mention computername\sqlexpress while connecting,

    also make sure client protocols are enabled, refer below article to enable TCP/IP.

    http://msdn.microsoft.com/en-us/library/bb909712(v=vs.90).aspx


    Regards,
    Praveen D'sa
    MCITP - Database Administrator - 2008
    sqlerrors

    Saturday, December 21, 2013 9:36 AM
  • First you need to identify if you have SQL installed. if yes, what's the name..

    Follow http://sqlserver-help.com/2011/06/19/help-whats-my-sql-server-name/

    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other users find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog | Team Blog | @Twitter
    Author: SQL Server 2012 AlwaysOn - Paperback, Kindle

    Saturday, December 21, 2013 10:26 AM
    Moderator
  • As Balmukund suggests, you firstly need to confirm that you are accessing a local installation of SQL Server - or are you attempting to access a SQL Server on the university network. Once you've established this we can narrow in on the issue.

    Regards, Matt Bowler MCITP, My Blog

    Sunday, December 22, 2013 9:54 PM
  • Hi,                                                                                                                             

    As Balmukund said, more information is required to troubleshoot the issue. The error message indicates that the client could not connect to the target SQL Server. You can follow the link below to troubleshoot the general Connectivity issue:

    SQL Server 2005 Connectivity Issue Troubleshoot - Part I

    Troubleshoot Connectivity Issue in SQL Server 2005 - Part II

    Also, make sure that SQL server port is not blocked by firewall. Make sure that SQL Server Browser Service and TCP/IP is enabled in SQL Server Configuration Manager.

    You can check the SQL Server ErrorLOG for more details.

    Thanks.


    Tracy Cai
    TechNet Community Support

    Monday, December 23, 2013 3:26 AM
    Moderator