none
How to avoid prompting User a Login Window when accessing to Report Viewer through URL Access from .net/C# application?

    Question

  • Here are the steps of scenario:
     
    1. After logging in on Login page https: //myComputerName, the user will be redirected to the following Report web form  application (C#).

    2. click [ Review Report ] button, it will prompt the User a Login Window to access Report Viewer through a URL.

    3. Then, it will prompt a User Login Window.  ( How to prevent the Login Window from prompting? )

    After entering the valid Username and password which are created on the Report Manager ( Report Server ),
    then the requested report will be displayed.

    The Login window only prompts for the first time access to Report Viewer as long as the browser is open.


    Everything is configured and developed on my PC including:

    1. IIS Manager ( version 7.5 )

    2. Windows 7 Professional

    3. Microsoft Visual Studio Express 2012 for Web
        ( to build the Report web form  application along with the URL to Report Viewer )

    4. SQL Server 2012 - MS SQL Server Management Studio ( Express version )

    5. SQL Server 2012 Reporting Services Configuration Manager

    - The .net (C#) website is developed on my PC. 
    - In IIS, https:// binding is enabled by a Self-Signed Certificate.
    - The SSRS Report is developed using Visual Studio 2010 Shell ( Express Version ), no Report Viewer control on it.

    I do not want to use Report Viewer control on Report Definition file (.rdl) because the report style/format only looks right with I.E browser.

    Also, I do not want to change I.E Security option by adding the report website link to Local Intranet because it's limited to I.E. browser only.

    Users are not internal users, and they should be free to use different browsers such as Firefox, Google Chrome, Safari, Opera, etc.

    I don't know where to fix the problem, should it be:
       1. Report Server's .config file which is on my PC.
    or 2. web.config ( The one for .net application or the one for Report Server )
    or 3. IIS 7.5
    or 4. Report Manager
    or what else?

    Please write me back with simple and straight solution to avoid prompting user a Login Window.

    Thank you so much.



    • Edited by itseeker Thursday, August 01, 2013 6:20 AM
    Thursday, August 01, 2013 3:20 AM

All replies

  • Hi Itseeker,

    In your scenario, the user need to input user name and password again when he want to view the reports which stored on Report Server, right? In this issue, please ensure that the users have the corresponding permission to access to Report Server, you can refer to the link below to check the settings:
    Grant User Access to a Report Server (Report Manager)

    Besides in Reporting Services, you use a Web browser to view reports and run Report Manager. Not all report functionality is supported by all browsers. Such as, when need to provide username and password when access to Report Manager using Firefox. Internet Explorer is a recommend web browser to view report by Microsoft. So in your scenario, please suggest your users login Report Manager using IE.

    Hope this helps.

    Regards,


    Charlie Liao
    TechNet Community Support

    Wednesday, August 07, 2013 7:38 AM
  • Thanks Charlie for responding to the issue. 

    I did add different Users (eg. CompanyName/RprtUserName ) with different permission roles such as Browser and Content Manager on Report Manager for Report Viewer.  I've mentioned that in the above forum.

    The Users are User account added on Control Panel ..User Accounts, for examples: CompanyName/RprtUserName   ( Standard  account Type )

    CompanyName/RprtUserMgr ( Administrator account Type )

    FYI, external users have their own logins (eg.adminUserAA) and passwords to log on the admin web site first. Then they will be redirected to a webpage with a link to Report Viewer.  After clicking the link, they will be prompted Login Window.  They need to enter the User Account RprtUserName and password to get Report Viewer.  As long as the browser is open, the Login Window will not prompt again.

    Same situation happening to I.E., and other popular browsers.

    Currently, I set Windows Authentication on IIS 7.5, and the related Web.config files, and even put the following codes:

        <system.web>          
          <authentication mode="Windows" />
          <identity impersonate="true" password="pwd" userName="CompanyName\RprtUserName" />      
          <authorization>
            <allow users="*" />
          </authorization>
        </system.web>

    Is it about credential problem, or what? I have no idea. Could you and anyone please help me out?

    Thanks so much in advance.


    Wednesday, August 07, 2013 10:36 AM