none
EXchange 2k7 EXBPA Performance Baseline not running for 2 hours

    Question

  • I have exchang 2007 in a CCR cluster, with exchange 2003 also in the organization.  I'm migrating to the exchange 2007 servers, that are also running windows server 2008.  When i run the exchange best practice analyzer and do a performance basline health check it runs for only 2minutes.  Not for sure where the logs are at for bpa, but it may be having issues cause of the 03 exchange....? 

    Any help would be much appreciated. 
    Thursday, October 29, 2009 5:41 PM

Answers

  • this is a bug in 07.  Opened a ticket with MS and they said they should have removed this option.  However they did not.
    • Marked as answer by Jeremy_FQ Monday, December 14, 2009 6:29 PM
    Monday, December 14, 2009 6:29 PM

All replies

  • I have exchang 2007 in a CCR cluster, with exchange 2003 also in the organization.  I'm migrating to the exchange 2007 servers, that are also running windows server 2008.  When i run the exchange best practice analyzer and do a performance basline health check it runs for only 2minutes.  Not for sure where the logs are at for bpa, but it may be having issues cause of the 03 exchange....? 

    Any help would be much appreciated. 
    • Merged by Frank.Wang Friday, October 30, 2009 2:30 AM same question
    Thursday, October 29, 2009 5:40 PM
  • I have exchang 2007 in a CCR cluster, with exchange 2003 also in the organization.  I'm migrating to the exchange 2007 servers, that are also running windows server 2008.  When i run the exchange best practice analyzer and do a performance basline health check it runs for only 2minutes.  Not for sure where the logs are at for bpa, but it may be having issues cause of the 03 exchange....? 

    Any help would be much appreciated.
    • Merged by Frank.Wang Friday, October 30, 2009 2:30 AM same question
    Thursday, October 29, 2009 5:42 PM
  • I have exchang 2007 in a CCR cluster, with exchange 2003 also in the organization.  I'm migrating to the exchange 2007 servers, that are also running windows server 2008.  When i run the exchange best practice analyzer and do a performance basline health check it runs for only 2minutes.  Not for sure where the logs are at for bpa, but it may be having issues cause of the 03 exchange....? 

    Any help would be much appreciated.
    • Merged by Frank.Wang Friday, October 30, 2009 2:29 AM same question
    Thursday, October 29, 2009 5:43 PM
  • THe logs are typically located at:
    \Documents and Settings\<user>\Application Data\Microsoft\ExBPA

    Or select the Save Dialog box and you'll see where the other reports are .

    Open the latest .txt log file in that directory and you'll see what happened.

    Thursday, October 29, 2009 5:54 PM
  • thanks found the logs.  On windows 2008 they are under User/Appdata/Roaming/Microsoft/EXBPA

    Now i'll go through these and find the error i'm getting and post it here . 

    Thursday, October 29, 2009 6:52 PM
  • this is what i'm seeing in the logs

    Processing === Exchange Server: FQLXEX07.corp.freightquote.local ===
    14:32:09.228: Error (Invalid parameter ) on WMI search SELECT __RELPATH, Type FROM MSCluster_Resource WHERE Name='File Share Witness (\\\\fqlxexhub02\\MNS_FSW_FQLXEX07)' on scope root\MSCluster on server FQLXEX07.corp.freightquote.local, skipping object.
    14:32:21.009: Error (Not supported ) on WMI search SELECT __RELPATH, Active, DriverName, DriverVersion, FirmwareVersion, HardwareVersion, HBAStatus, Manufacturer, Model, ModelDescription, NodeWWN, NumberOfPorts, OptionROMVersion, UniqueAdapterId FROM MSFC_FCAdapterHBAAttributes on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    14:32:21.040: Error (Not supported ) on WMI search SELECT __RELPATH, Statistics.DumpedFrames, Statistics.ErrorFrames, Statistics.InvalidCRCCount, Statistics.InvalidTxWordCount, Statistics.LinkFailureCount, Statistics.LossOfSignalCount, Statistics.LossOfSyncCount, Statistics.PrimitiveSeqProtocolErrCount, Statistics.SecondsSinceLastReset, Statistics.TxFrames FROM MSFC_FibrePortHBAStatistics on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    14:32:21.056: Error (Not supported ) on WMI search SELECT __RELPATH, Attributes.NumberOfDiscoveredPorts, Attributes.PortMaxFrameSize, Attributes.PortSpeed, Attributes.PortState, Attributes.PortSupportedSpeed, Attributes.PortType, Attributes.PortWWN FROM MSFC_FibrePortHBAAttributes on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    Thursday, October 29, 2009 7:39 PM
  • Processing === Exchange Server: FQLXEX07.corp.freightquote.local ===
    14:32:09.228: Error (Invalid parameter ) on WMI search SELECT __RELPATH, Type FROM MSCluster_Resource WHERE Name='File Share Witness (\\\\fqlxexhub02\\MNS_FSW_FQLXEX07)' on scope root\MSCluster on server FQLXEX07.corp.freightquote.local, skipping object.
    14:32:21.009: Error (Not supported ) on WMI search SELECT __RELPATH, Active, DriverName, DriverVersion, FirmwareVersion, HardwareVersion, HBAStatus, Manufacturer, Model, ModelDescription, NodeWWN, NumberOfPorts, OptionROMVersion, UniqueAdapterId FROM MSFC_FCAdapterHBAAttributes on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    14:32:21.040: Error (Not supported ) on WMI search SELECT __RELPATH, Statistics.DumpedFrames, Statistics.ErrorFrames, Statistics.InvalidCRCCount, Statistics.InvalidTxWordCount, Statistics.LinkFailureCount, Statistics.LossOfSignalCount, Statistics.LossOfSyncCount, Statistics.PrimitiveSeqProtocolErrCount, Statistics.SecondsSinceLastReset, Statistics.TxFrames FROM MSFC_FibrePortHBAStatistics on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    14:32:21.056: Error (Not supported ) on WMI search SELECT __RELPATH, Attributes.NumberOfDiscoveredPorts, Attributes.PortMaxFrameSize, Attributes.PortSpeed, Attributes.PortState, Attributes.PortSupportedSpeed, Attributes.PortType, Attributes.PortWWN FROM MSFC_FibrePortHBAAttributes on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    14:32:22.978: Exchange server "FQLXEXMB01.corp.freightquote.local" was not found. Please make sure you have typed it correctly.
    14:32:23.040: Exchange server "FQLXEXMB01.corp.freightquote.local" was not found. Please make sure you have typed it correctly.
    Thursday, October 29, 2009 7:40 PM
  • Hi,

    I thought that Exbpa will create a log in %appdata%microsoft\exbpa but I am nog 100% sure maybe you can post the piece of logging here. Is anything logged in the event log ?

    Regards,

    Johan
    blog: www.johanveldhuis.nl
    Thursday, October 29, 2009 9:33 PM
  • nothing in the event log.  Just what i found in the exbpa logs from above.  Some WMI errors

    Processing === Exchange Server: FQLXEX07.corp.freightquote.local ===
    14:32:09.228: Error (Invalid parameter ) on WMI search SELECT __RELPATH, Type FROM MSCluster_Resource WHERE Name='File Share Witness (\\\\fqlxexhub02\\MNS_FSW_FQLXEX07)' on scope root\MSCluster on server FQLXEX07.corp.freightquote.local, skipping object.

    14:32:21.009: Error (Not supported ) on WMI search SELECT __RELPATH, Active, DriverName, DriverVersion, FirmwareVersion, HardwareVersion, HBAStatus, Manufacturer, Model, ModelDescription, NodeWWN, NumberOfPorts, OptionROMVersion, UniqueAdapterId FROM MSFC_FCAdapterHBAAttributes on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.

    14:32:21.040: Error (Not supported ) on WMI search SELECT __RELPATH, Statistics.DumpedFrames, Statistics.ErrorFrames, Statistics.InvalidCRCCount, Statistics.InvalidTxWordCount, Statistics.LinkFailureCount, Statistics.LossOfSignalCount, Statistics.LossOfSyncCount, Statistics.PrimitiveSeqProtocolErrCount, Statistics.SecondsSinceLastReset, Statistics.TxFrames FROM MSFC_FibrePortHBAStatistics on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.

    14:32:21.056: Error (Not supported ) on WMI search SELECT __RELPATH, Attributes.NumberOfDiscoveredPorts, Attributes.PortMaxFrameSize, Attributes.PortSpeed, Attributes.PortState, Attributes.PortSupportedSpeed, Attributes.PortType, Attributes.PortWWN FROM MSFC_FibrePortHBAAttributes on scope root\WMI on server FQLXEXMB01.corp.freightquote.local, skipping object.
    Friday, October 30, 2009 1:32 PM
  • I just ran the connectivity test and got this error

    09:55:09.164: Starting Collecting Data phase.
    09:55:09.695: Processing Exchange Organization...
    09:55:09.805: Processing === Exchange Server: FQLXEX07.corp.freightquote.local ===
    09:55:18.180: Error (Invalid namespace ) on WMI search SELECT * FROM Exchange_DSAccessDC on scope root\MicrosoftExchangeV2 on server FQLXEX07.corp.freightquote.local, skipping object.
    09:55:18.243: Completed Collecting Data phase.
    09:55:18.539: Starting Postprocessing Rules phase.
    09:55:18.602: Completed Postprocessing Rules phase.


    Coudl this be a problem? 
    Friday, October 30, 2009 2:59 PM
  • this is a bug in 07.  Opened a ticket with MS and they said they should have removed this option.  However they did not.
    • Marked as answer by Jeremy_FQ Monday, December 14, 2009 6:29 PM
    Monday, December 14, 2009 6:29 PM
  • did you ever figure out the problem with this or how to resolve it? I'm running into the same issue right now in a CCR environment. Thanks
    Thursday, August 26, 2010 7:10 PM
  • I have the same problem... Anybody fixed it?
    Wednesday, December 21, 2011 10:56 PM