none
URL shortcuts not working for RDS Users

    Question

  • Hi

    We have a Windows Server 2008 R2 running RDS for about 30 people.

    The Terminal Server is pretty locked down via Group Policy and I use the loopback processing to disable the GPO for Admins.

    A weird thing is happening and I cannot figure what setting to change in the GP.

    Users can create new shortcuts on their desktop fine (either by manually creating the shortcut or by dragging and dropping from IE) but the Internet shortcuts will not open. When they click on one of the shortcuts, an IE window appears but does not load any page. At that point, they can manually type in any new site in the adress bar and it works fine.

    If I move the shortcuts from the desktop to their shared network folder, they work fine. It's just like the computer is locked to disallow any IE shortcuts executing from the desktop. Shortcuts for the Office applications work fine from the desktop.

    The only shortcuts that work from the dekstop are the IE shortcuts that we given to them from the default user when they created their profile.

    If it matters, we are redirecting desktops to a file share for each user. I've checked the permissions on that desktop folder and all users are given Read and Read and Execute permissions.

    For administrators, all desktop shortcuts work as they should.

    Thanks for your help

    Sunday, October 06, 2013 8:06 AM

Answers

  • Hi,

    Try this command, may this helpful to resolve the issue.

    Open command prompt as administrator, run below command:

    1.  To Enable IE on Windows Server 2008 R2 version -- run the following command
         dism /online /Enable-Feature /FeatureName:Internet-Explorer-Optional-amd64

    2.  To Disable IE on Windows Server 2008 R2 version -- run the following command
         dism /online /Disable-Feature /FeatureName:Internet-Explorer-Optional-amd64

    You need to restart the server after executing these commands.

    Refer “How to re-install Internet Explorer 8 on Windows 2008 R2” article and also this thread.

    Hope This Helps!
    Thanks.

    Wednesday, October 09, 2013 9:38 AM

All replies

  • Try to add your file share to the trusted sites in GPO or local PC.
    Monday, October 07, 2013 7:50 AM
  • Hi,
     
    As per understanding, I think that you are trying to find a way for IE shortcut works in RDS Session.
     
    Here providing you some suggestion.
     
    Suggestion 1:
    Launch Internet Explorer (No Add-ons), then double click the URL Shortcut.
    For this, please click the Start Button, All Programs, Accessories, System Tools, and then click Internet Explorer (No Add-ons).
     
    Suggestion 2:
    Reset the Internet Explorer by “How to reset Internet Explorer settings
    Note: the following steps will remove all of installed add-ons and reset IE to default settings. You need to reinstall the add-ons after resetting.
     
    Suggestion 3:
    Here providing another you another way, to manage shortcut with GP. Follow beneath path,
     
    Computer Configuration or User Configuration \Preferences \Windows Settings \Shortcuts
     
    Refer “Configure a Shortcut Item” for more information.
     
    Hope This Helps!
    Thanks.
    Monday, October 07, 2013 1:30 PM
  • Hi,

    Thanks a lot for your help but how can I do that as "Internet Explorer Maintenance" no more available ?

    Thx a lot

    Wednesday, October 09, 2013 5:27 AM
  • Hi,

    Thanks for your help, but I would like a way to solve through GPO/GPP

    URL shortcuts has already been deployed by GPO, but matter is that IE doesn't load web page when RDS Users open it

    Thanx

    Wednesday, October 09, 2013 6:13 AM
  • Hi,

    Try this command, may this helpful to resolve the issue.

    Open command prompt as administrator, run below command:

    1.  To Enable IE on Windows Server 2008 R2 version -- run the following command
         dism /online /Enable-Feature /FeatureName:Internet-Explorer-Optional-amd64

    2.  To Disable IE on Windows Server 2008 R2 version -- run the following command
         dism /online /Disable-Feature /FeatureName:Internet-Explorer-Optional-amd64

    You need to restart the server after executing these commands.

    Refer “How to re-install Internet Explorer 8 on Windows 2008 R2” article and also this thread.

    Hope This Helps!
    Thanks.

    Wednesday, October 09, 2013 9:38 AM