none
tuning up IIS 8.5 on Publishing server

    Question

  • Hi,

    I would like to follow the tuning advice below and cannot find applicationhost.config in the location provided.

    I am using server 2012, so IIS is 8.5. 

    Thanks.

    *****************************************************************

    http://www.ingmarverheij.com/microsoft-app-v-5-0-streaming-via-http/

    IIS  uses an algorithm to determine if files should be cached, by default IIS only caches files that are requested twice within ten seconds. As with the MaxCachedFileSizeInMB parameter this makes sense for websites, but not when caching virtual application packages. The following two parameters can be configured in the <serverRuntime> section of the file %windir%\system32\inetsrv\config\applicationHost.config (see Microsoft)

    • frequentHitThreshold: How many times should the same file be requested, before it’s cached
    • frequentHitTimePeriod: Time interval in which the same file should be requested {frequentHitThreshold} times, in order to be cached.

    I’ve replaced the default value in applicationHost.config

    <textarea class="crayon-plain print-no" data-settings="dblclick" readonly="readonly" style="line-height:15px !important;font-size:12px !important;opacity:0;-moz-tab-size:4;-o-tab-size:4;-webkit-tab-size:4;tab-size:4;" wrap="soft"><serverRuntime /></textarea>
    1
    <serverRuntime />

    with

    <textarea class="crayon-plain print-no" data-settings="dblclick" readonly="readonly" style="line-height:15px !important;font-size:12px !important;opacity:0;-moz-tab-size:4;-o-tab-size:4;-webkit-tab-size:4;tab-size:4;" wrap="soft"><serverRuntime frequentHitTimePeriod="00:00:01" frequentHitThreshold="1" /></textarea>
    1
    <serverRuntime frequentHitTimePeriod="00:00:01" frequentHitThreshold="1" />

    As a result files are cached when it is downloaded once within a time period of one second, effectively always.


    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

    Tuesday, July 01, 2014 3:57 PM

Answers

  • If you have added the correct features for IIS it should be there

    Also, what is driving your decision to use HTTP or HTTPS? Since the release of hotfix 4, it has been noted that performance is best with SMB. Even SMB v2. 


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon


    • Edited by RorymonMVP Tuesday, July 01, 2014 4:55 PM
    • Marked as answer by pob579 Wednesday, July 02, 2014 2:10 PM
    Tuesday, July 01, 2014 4:53 PM
  • 1.) You need to deploy: http://www.microsoft.com/en-us/download/details.aspx?id=41186 for the GUI. It was removed from 5.0 SP2. Deploy via the Management Server.

    Restarting the client should refresh the client. Otherwise do it manually via Powershell.

    Set-ExecutionPolicy RemoteSigned

    When prompted, enter: Y

    import-module appvclient

    Sync-AppVPublishingServer

    When prompted enter: 1

    If you have issues, check out the Event Viewer logs for App-V.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    • Marked as answer by pob579 Tuesday, July 01, 2014 6:24 PM
    Tuesday, July 01, 2014 6:14 PM

All replies

  • If you have added the correct features for IIS it should be there

    Also, what is driving your decision to use HTTP or HTTPS? Since the release of hotfix 4, it has been noted that performance is best with SMB. Even SMB v2. 


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon


    • Edited by RorymonMVP Tuesday, July 01, 2014 4:55 PM
    • Marked as answer by pob579 Wednesday, July 02, 2014 2:10 PM
    Tuesday, July 01, 2014 4:53 PM
  • Rory,

    first thanks for taking time to answer...

    I decided to try HTTP after reading this http://www.ingmarverheij.com/microsoft-app-v-5-0-streaming-via-http/

    As for the features of IIS, I run the script taken from on of the blogs...

    Finally, I will rely on your statement:

    "Since the release of hotfix 4, it has been noted that performance is best with SMB. Even SMB v2."

    To not start a new post (I take a lot of space on forum :)) I want to ask you couple of simple :) questions.

    1. I installed App-V client on Windows 8.1 from APP-V SP2 and applied hotfix 5.

    For some reason I cannot find any shortcut to App-V client in Apps or on task bar.

    MS App-V Client Streaming UX is running (task manager). The shortcut didn't appear before applying hotfix5 too.

    How to start the client?


    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

    Tuesday, July 01, 2014 5:25 PM
  • 1.) You need to deploy: http://www.microsoft.com/en-us/download/details.aspx?id=41186 for the GUI. It was removed from 5.0 SP2. Deploy via the Management Server.

    Restarting the client should refresh the client. Otherwise do it manually via Powershell.

    Set-ExecutionPolicy RemoteSigned

    When prompted, enter: Y

    import-module appvclient

    Sync-AppVPublishingServer

    When prompted enter: 1

    If you have issues, check out the Event Viewer logs for App-V.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    • Marked as answer by pob579 Tuesday, July 01, 2014 6:24 PM
    Tuesday, July 01, 2014 6:14 PM
  • Thanks!

    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis

    Tuesday, July 01, 2014 6:24 PM