none
Web Part menu is not being displayed

    Question

  • Hi,

    I am new to Sharepoint and i am now having a trouble with web part menu verbs. When I click on the web part menu in IE 8, i don't see any verbs (Close, Edit, Minimize) instead i get a error "error on page" on the bottom of the web page. And when i click on that error, I Could see a message something like "Javascript error: Object Expected line 234 " etc.. I am using Sharepoint Designer 2010 to implement a web page. 

    I have selected all web part advanced properties and still not getting succeded. Any help would be greatly appreciated.

    Thank you,

    Baluk

    Wednesday, August 11, 2010 3:29 PM

Answers

  • Hi,

    Problem was solved :). Its a Core.js file which should be included in the master page. As I am using my Custom Master page, I forgot to include it in the page.

    Thank you,

    Baluk

    • Marked as answer by Baluk Thursday, August 12, 2010 7:42 AM
    Thursday, August 12, 2010 7:41 AM

All replies

  • It looks like you are missing something in your page, what exactly is the error that you get on the page? for instance you could be missing a semicolon or something. What is the code on line 234?
    Treasa
    Wednesday, August 11, 2010 6:29 PM
  • Hi,

     

    Thank you for the response. I get the error "Object expected on line 185 default.aspx " and on the line 185 i have a code

    <td align="left" class="ms-wpTdSpace">&#160;</td><td title="Bildvisning - Visar en specifik bild." id="WebPartTitleWPQ2" class="ms-WPHeaderTd"><h3 style="text-align:justify;" class="ms-standardheader ms-WPTitle"><nobr><span>Bildvisning</span><span id="WebPartCaptionWPQ2"></span></nobr></h3></td><td align="right" class="ms-WPHeaderTdMenu" onclick="OpenWebPartMenu(&#39;MSOMenu_WebPartMenu&#39;, this, &#39;WebPartWPQ2&#39;,&#39;False&#39;); TrapMenuClick(event); return false;"><span style="display:none;"></span><div class="ms-WPMenuDiv" onmouseout="this.className='ms-WPMenuDiv'" onmouseover="this.className='ms-WPMenuDivHover'"><a onclick="OpenWebPartMenuFromLink(&#39;MSOMenu_WebPartMenu&#39;, this, &#39;WebPartWPQ2&#39;,&#39;False&#39;); return false;" id="WebPartWPQ2_MenuLink" onkeydown="WebPartMenuKeyboardClick(document.getElementById('WebPartWPQ2_MenuLink'), 13, 40, event)" href="#" title="Bildvisning Web Part Menu" class="ms-wpselectlink" onblur="UpdateWebPartMenuFocus(this, 'ms-wpselectlink', 'ms-WPEditText');" onfocus="UpdateWebPartMenuFocus(this, 'ms-wpselectlinkfocus', 'ms-WPEditTextVisible');" menuid="MSOMenu_WebPartMenu"><img class="ms-WPHeaderMenuImg" src="/_layouts/images/wpmenuarrow.png" alt="Bildvisning Web Part Menu" style="border-width:0px;" /></a></div></td><td class="ms-WPHeaderTdSelection"><span class="ms-WPHeaderTdSelSpan"><input type="checkbox" id="SelectionCbxWebPartWPQ2" class="ms-WPHeaderCbxHidden" title="Select or deselect Bildvisning Web Part" onblur="this.className='ms-WPHeaderCbxHidden'" onfocus="this.className='ms-WPHeaderCbxVisible'" onkeyup="WpCbxKeyHandler(event);" onmouseup="WpCbxSelect(event); return false;" onclick="TrapMenuClick(event); return false;" /></span></td><td align="left" class="ms-wpTdSpace">&#160;</td>
    					</tr>
    
    

    This code is about the Image  Webpart control. It has javascript handling fucntions like if mouse hover onto the menu etc.. I don't think if there is any syntax error since it is auto generated code from drag and drop. I hope you will understand the code and figure out something. 

    Thank you,

    Baluk 

    Wednesday, August 11, 2010 10:09 PM
  • Hi,

    Problem was solved :). Its a Core.js file which should be included in the master page. As I am using my Custom Master page, I forgot to include it in the page.

    Thank you,

    Baluk

    • Marked as answer by Baluk Thursday, August 12, 2010 7:42 AM
    Thursday, August 12, 2010 7:41 AM