none
Office web apps in sharepoint slow to open first time

    General discussion

  • We have recently installed Sharepoint 2010 with Office web apps.  It all work fine apart from the first document opened each day is slow.  Any document opened after that is much quicker.

    Is there a way to change this?

    Cheers

    Rich980

    Friday, August 05, 2011 10:44 AM

All replies

  • Hello Rich,

    How long will it take to open the document at the first time?


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, August 09, 2011 9:49 AM
    Moderator
  • Hi Max,

     

    It takes between 20-30 seconds to open the first time after that it takes around 5 seconds to open any other documents.

     

    Regards

     

    Rich980
    Wednesday, August 10, 2011 7:33 AM
  • Hello Rich,

    Based on the various configuration on the server side, we consider 20-30 seconds to open at the first time is acceptable. There might be some warm up needed.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Wednesday, August 10, 2011 7:46 AM
    Moderator
  • Thanks for the reply.

     

    Is there a way to schedule or force the warm up before people start to use the apps?

     

    Regards

     

    Rich980

    Thursday, August 18, 2011 8:51 AM
  • Hi,

    we have the same problem on a Sharepoint Foundation, but the slowness appears almost every time the document is opened.

    The client pressures considering this 20 seconds waiting "unacceptable" (and honestly i'm quite with him).

    I can't think that there is not a solution to this.

    Thanks


    • Edited by Tlenl Sunday, October 23, 2011 10:23 AM
    Friday, October 21, 2011 9:12 PM
  • Hi,

    we have the same problem on a Sharepoint Foundation, but the slowness appears almost every time the document is opened.

    The client pressures considering this 20 seconds waiting "unacceptable" (and honestly i'm quite with him).

    I can't think that there is not a solution to this.

    Thanks



    Hi,

    same here, but I experience slowness only with excel documents. I can understand it's warm-up issue first time, but subsequent openings of excel

    documents are also slow (if more that few minutes have passed between openings). Sometimes after reboot it's back to normal, after another reboot it's slow again, can't make any sense out of it...

    Edit:

    After letting Sharepoint server access internet directly, issue has gone. It seems it's related to server unable to access CRL.


    Friday, November 11, 2011 9:18 AM
  • Hi Davor,

    you mean Certificate Revocation List?

    And in this case it would be some kind of Root Revocation List wich needs internet?

    That's a quite interesting story, i'm going to test it.

    Anyone on MS-Tech side can give an opinion on this?

    Thank you

     

    Friday, December 09, 2011 7:08 PM