none
Different USMT settings per task sequence...

    Question

  • Does anyone have a working technique to apply different USMT settings per task sequence? I'm in a situation where I need some task sequences to do hard link migrations and some I need to capture USMT.MIG to a network share.
    Friday, November 08, 2013 4:04 PM

All replies

  • Hi,

    Have a look at this link: Using Custom XML and Config Files with USMT and ConfigMgr

    Im confident this will also work in MDT, so you can create a 'Hardlink Task Sequence' and a 'MIG Task Sequence'. Another approach is that you configure this step twice and let it depend on a WMI Query, or Task Sequence Variable.

    But as you can see in the image that they target a very specific XML:

    Good luck and keep us posted!


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Friday, November 08, 2013 6:31 PM
  • This looks compelling (wow you have a lot less stuff in your task sequence than I do). I'll take a look and get back. However what I was really looking for was something customsettings.ini based. Anyone aware of anything along that route?
    Friday, November 08, 2013 9:36 PM
  • You can set the priority in your customsettings.ini based on TaskSequenceID, so for exameple:

    Priority: TaskSequenceID, Default

    [TSID1]

    ClientXML1

    [TSID2]

    ClientXML2

    Something like that :)

    By the way, it's not my Task Sequence, I was referencing an image derived from the blog I provided as a link.


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Friday, November 08, 2013 9:42 PM
  • You can set the priority in your customsettings.ini based on TaskSequenceID, so for exameple:

    Priority: TaskSequenceID, Default

    [TSID1]

    ClientXML1

    [TSID2]

    ClientXML2

    Something like that :)

    By the way, it's not my Task Sequence, I was referencing an image derived from the blog I provided as a link.


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Well (actually) I was doing this already but it does not seem to work without editing "DeployWiz_SelectTS.vbs". Even then when I do have it edited it does not seem to work very well. I'll just keep experimenting...
    Monday, November 11, 2013 4:36 PM