none
Cloud Service Site Url DNS not resolving

    Question

  • I have a site published to Azure Cloud Services that is running, and accessible via VIP.  I cannot access the site via Site Url, even after flushing my local dns, or trying on different devices.  In my browser's debugger, I see that DNS resolution fails in the first step of the web request.  

    I am relying on the site url for CNAME records - I cannot use the VIP.  

    What would be causing this?  What can I do about it?

    Also - if I run whatsmydns.net to query CNAMEs against the cloudapp.net address, I get nothing, but A records are resolving to the VIP.  


    • Edited by deliveryguy Tuesday, December 31, 2013 10:41 PM
    Tuesday, December 31, 2013 9:50 PM

All replies

  • Hello,

    Did your make sure your CNAME is valid? I suggest you could use some DNS tool to query it and check it.

    If your dns name is valid, I suggest you could follow tutorial (http://www.windowsazure.com/en-us/develop/net/common-tasks/custom-dns/ ) to step by step.

    Please try it.

    Any question, please let me know.

    Thanks.

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, January 01, 2014 3:55 AM
  • Will - I'm not using custom DNS for the URL that Azure is providing.  I don't need to set anything up with custom DNS.  This is an out-of-the-box deployment with a failing Site URL, not a failing DNS configuration (on my end, anyways).  Does that make sense to you?
    Wednesday, January 01, 2014 3:06 PM
  • hello,

    Did you success try to use  "******.cloudservice.com" to access you website? At the same time, Please check your project is in production environment nor staging environment. I want to know which site URL was not accessed.

    Any result, please let me know.

    Regards,

    Will


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 03, 2014 7:58 AM