none
Applications hang intermittently on windoes server 2008R2 enterprise

    Question

  • My server which has worked fine since 2010 started to exhibit this behavior in April about 2 days after the monthly updates from Microsoft:  after a while an application (just about any) will hang when doing any of the following: printing (waiting for the select printer window to open), opening or saving files (waiting for the open/save window to open), trying to access the favorites list in IE, right clicking a file in a windows explorer window (waiting for the drop down menu to appear).  After a delay of anywhere from 20 minutes to 2 hours the window will open, after which that application will work fine until it is closed and reopened, then the waiting game begins again.  After this starts the only way to stop it is to either update group policy and restart, or boot into AD restore mode, then back into normal mode.  Then the system works fine for a anywhere from a few days to a few hours (there is still a slight delay of about 5 seconds) after which it starts happening again. I am guessing that all of the above operations have something in common.  Any ideas what it is and how to stop it?
    Wednesday, September 18, 2013 3:36 AM

Answers

  • This could be in chain . An app could hog the resources and any app which is the state of "running" or any newly launched app tries to execute will fail due to the Primary App which is consuming CPU resources / Memory.

    as first troubleshooting can you

    a) exhibit the behavior in safe mode and safe mode with networking ? ( this will avoid any 3rd party drivers to load )

    b) For testing , please do disable startup apps and validate the behavior

    c) run process explorer and observe which application is consuming the resources ( note down the PID and name of the PID )

    if possible paste the process explorer results.

    Wednesday, September 18, 2013 1:00 PM
  • Ok - This might not sound interesting (But try it ) I solved similar issue with this - 

    1. Remove the computer from the network - Then try opening those applications .. Any problem? if yes move to next step . 

    2. Increase your virtual memory on the PCs  (With Network  still disabled) - Try the apps again. 

    3. User "Resource Monitor " to check CPU/Memory usage before /after you lunch the application.

    if possible post the screen shot of resource monitor here before/after application lunch lets have a look.. 

    Regards

    MassonTech..


    Wednesday, September 18, 2013 2:00 PM

All replies

  • Is this problem happening on the server? or user in your domain.., is this server a DC? 

    Please check event viewer if there are any suspicious events .

    Also see http://msdn.microsoft.com/en-us/library/windows/desktop/dd744765(v=vs.85).aspx

    Regards

    MassonTech

    Wednesday, September 18, 2013 11:06 AM
  • Hi ,
    Is this a Microsoft app or custom app ?

    If its a 3rd party app , it would be difficult to debug for 2 reasons
    a) THis forum doesn't support troubleshooting 3rd party apps
    b) Microsoft doesn't have the source file and corresponding pdb file for 3rd party app

    Generic Troubleshooting includes.

    a) getting right pattern: you need to get the right pattern by understand different scenarios to exhibit the problem

    b) you can configure perfmon ( add disk , memory , cpu and network) as counters and run the perfmon before the hang occurs and analyze the perfmon dump

    c) ADPlus dump : an excellent way to debug the hang application - provided you have the pdb file information.

    http://support.microsoft.com/kb/286350/en-us

    Wednesday, September 18, 2013 12:16 PM
  • Its a DC and RD gateway server on a small domain (2 servers and maybe 8 PCs) Once it starts it affect everyone, whether on a RD session or the console.  Once the window opens in an application (e.g Office) the first time there is no delay subsequently in that application until it is closed, however at the same time if you open a different app (e.g Acrobat) that app will hang the first time you print or save something.  I don't see anything in event viewer that would explain it
    Wednesday, September 18, 2013 12:40 PM
  • It happens with all apps... it seems to be when the app interacts with Windows... waiting for the printer list or directory listing.  When it happens to MS Word which does not use the standard select printer window, the Word window grays out (Not Responding) and the printer menu line says "waiting for list of printers" or something like that
    Wednesday, September 18, 2013 12:45 PM
  • This could be in chain . An app could hog the resources and any app which is the state of "running" or any newly launched app tries to execute will fail due to the Primary App which is consuming CPU resources / Memory.

    as first troubleshooting can you

    a) exhibit the behavior in safe mode and safe mode with networking ? ( this will avoid any 3rd party drivers to load )

    b) For testing , please do disable startup apps and validate the behavior

    c) run process explorer and observe which application is consuming the resources ( note down the PID and name of the PID )

    if possible paste the process explorer results.

    Wednesday, September 18, 2013 1:00 PM
  • Ok - This might not sound interesting (But try it ) I solved similar issue with this - 

    1. Remove the computer from the network - Then try opening those applications .. Any problem? if yes move to next step . 

    2. Increase your virtual memory on the PCs  (With Network  still disabled) - Try the apps again. 

    3. User "Resource Monitor " to check CPU/Memory usage before /after you lunch the application.

    if possible post the screen shot of resource monitor here before/after application lunch lets have a look.. 

    Regards

    MassonTech..


    Wednesday, September 18, 2013 2:00 PM