none
MDT 2012U1 / ConfigMgr 2012 SP1 - OS Installing to D:

    Question

  • Hello,

    My environment

    Configuration Manager 2012 SP1
    Integrated MDT 2012 U1
    1 Site Server with all roles (DP, SUP, MP, etc)
    Reference Windows 7 X64 Pro image

    Deployed using MDT integrated task sequence in ConfigMgr 2012 SP1

    The reference image did use C: for the OSDisk

    I'm attempting to deploy my reference image to virtual machines using VMware. The image does get pushed down however it installs the OS to D:

    DiskPart on the deployed image shows the following:
    Volume 0 E:     DVD-ROM
    Volume 1      BDEDrive 
    Volume 2      OSDisk


    I have edited my task sequence to OSDPreserveDriveLetter=True

    BDEDrive is checked "do not assign a drive letter to this partition" under PreInstall -> Format Disk

    I've also added the property DoNotCreateExtraPartition=YES to my customsettings.ini

    Here is my customsettings.ini

    [Settings]
    Priority=Default 
    Properties= OSDMigrateConfigFiles,OSDMigrateMode 


    [Default] 
    SLShare=\\SERVER\logs$ 
    DoCapture=NO 
    ComputerBackupLocation=NONE 
    BDEInstallSuppress=YES
    DoNotCreateExtraPartition=YES
    MachineObjectOU=OU=Workstations,DC=DOMAIN,DC=NET
    OSDMigrateMode=Advanced 
    OSDMigrateAdditionalCaptureOptions=/ue:*\* /ui:DOMAIN\* 
    OSDMigrateConfigFiles=Miguser.xml,Migapp.xml


    Am I missing something obvious? 


    Monday, September 16, 2013 6:37 PM

Answers

All replies

  • MDT 2012 U1 FAQ http://www.deploymentresearch.com/Research/tabid/62/EntryId/76/Uber-tips-for-the-MDT-2012-Update-1-Task-Sequence-template-for-SCCM-2012-SP1.aspx

    Remove the "Set Variable for Drive Letter" step in the task sequence "OSDPreserveDriveLetter"


    Keith Garner - keithga.wordpress.com

    Monday, September 16, 2013 10:58 PM
    Moderator
  • Keith,

    Thanks for the reply. It was that link you provided that got me to set OSDPreserveDriveLetter=True

    Unless I'm missing something, I don't see in that article where it suggests removing the "Set Variable for Drive Letter" step. Is this something you tried on your own with positive results?

    Thanks again.

    Monday, September 16, 2013 11:49 PM
  • I tried removing the Set Variable for Drive Letter step altogether. Same result, OS installs to D:

    BDEDrive Partition is present in diskpart but not assigned a drive letter.


    • Edited by Chris_King23 Tuesday, September 17, 2013 10:20 PM
    Tuesday, September 17, 2013 10:15 PM
  • I played with turning BDEDrive "do not assign a drive letter to this partition" on and off. Result is the same,OS installs to D: and BDEDrive is present in diskpart but not assigned a drive letter.

    Tuesday, September 17, 2013 10:18 PM
  • Interesting...

    When BDEDrive is checked to not assign a drive letter to this partition. I get the following diskpart errors in the smsts.log

    When BDEDrive "not assign drive letter to this partition is left unchecked. The smsts.log shows no diskpart errors.

    Tuesday, September 17, 2013 10:26 PM
  • Sigh, you shamed me in to writing the full explanation (it's long):

    http://keithga.wordpress.com/2013/09/17/osdpreservedriveletter/

    Specifically, where did you get your Windows 7 "reference" image, is this the unmodified install.wim bits from Microsoft, or did you apply the image to a VM, and capture using SCCM or MDT?

    -k


    Keith Garner - keithga.wordpress.com

    • Marked as answer by Chris_King23 Wednesday, September 18, 2013 4:41 PM
    Tuesday, September 17, 2013 11:52 PM
    Moderator
  • Keith

    Thanks for the blog post. Very much appreciated and helpful in understanding the OSDPreserveDriveLetter variable.

    I created the the reference image in SCCM by applying the image to a VM and capturing it.

    I'm following the advice from your post and rebuilding the reference image in MDT, will report back with finding:

    "Don’t use SCCM to capture images. MDT is the recommended best practice for image creation. SCCM should then be used to deploy the captured images. Then remove the OSDPreserveDriveLetter step from the task sequence, or set it to “True” (same thing)."

    Thanks again.

     


    • Edited by Chris_King23 Wednesday, September 18, 2013 4:20 AM
    Wednesday, September 18, 2013 4:19 AM
  • Keith,

    I built a reference image in Standalone MDT 2012 U1 last night and deployed it via integrated MDT in SCCM this morning. I set the OSDPreserveDriveLetter=True

    The OSDisk is C: 

    When creating the deploy task sequence the first thing I noticed was that the standalone MDT built reference image package did not ask for image (1-1 or 2-2) 

    SCCM build and capture

    MDT Standalone build and capture

    Again, I appreciate the blog post, it led me to the solution. I was "almost" starting to consider not using MDT at all in favor of SCCM Create task sequence.

    Wednesday, September 18, 2013 4:49 PM