none
.NET Framework 2.0 and 3.5 feature install fails on Windows Server 2012 RC

    Question

  • Using Windows Server 2012 RC from the VHD, and selecting the .NET Frameork 3.5 Feature, gives error message "The source files could not be found". Downloading the install packages from the Internet, and attempting the install directly, gives error messages "Install from roles and features". Please advise
    Monday, June 04, 2012 8:17 AM

Answers

  • Hi,

    Do you have access to internet with this machine ?

    Using dism.exe should solve your problem if you have the ISO :

    dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /LimitAcces

    Regards,


    Monday, June 04, 2012 8:26 AM

All replies

  • Hi,

    Do you have access to internet with this machine ?

    Using dism.exe should solve your problem if you have the ISO :

    dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /LimitAcces

    Regards,


    Monday, June 04, 2012 8:26 AM
  • Do have Internet access from the machine, but I don't get prompted for userid/password (it is an authenticated proxy)

    Don't have the ISO. Downloaded the VHD rather than the ISO; don't really want to download another couple of GB

    Monday, June 04, 2012 10:14 AM
  • Negotiated an un-authenticated proxy and dism worked for me. Thanks for your help

    Monday, June 04, 2012 11:05 AM
  • I had to run it without limitacces.

    dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs

    Edit: I realized the right command was "dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /LimitAccess"


    Saturday, June 16, 2012 1:01 PM
  • Hi,

    If you have Windows Server 2012 iso file or DVD, you can install .net framework 3.5 on Windows Server 2012 easly.

    1. You have to insert Windows Server 2012 DVD or iso to D drive. 

    2. Open Add Roles and Features Wizard

    3. Select .NET Framework 3.5 Features and then click next,

    4. Select Specify an alternate source path link in the Confirm installation selections screen.

    5. Path: D:\Sources\SxS and then click OK.

    6. Finally click Install button.

    • Proposed as answer by 2ndO Friday, July 06, 2012 11:50 AM
    Thursday, June 28, 2012 6:38 AM
  • Hi BertanD,

    your suggestion worked for me. Thanks.

    Monday, July 16, 2012 9:45 AM
  • Thanks BertanD, works for me.
    Thursday, August 09, 2012 7:37 AM
  • Hello,

    Do you have access to internet with this machine ?

    Using dism.exe should solve your problem if you have ISO or the dvd in the machine :

    step1

    dism.exe /online/enable-feature/featurename:NetFX3/Source:D:\sources\sxs/LimitAccess

    D:\ = drive or cd with the cabs maybe you have another leather

    step 2

    dism.exe /online/enable-feature/featurename:NetFX3 /all

    after these steps i join to the domain

    i did it in thease way

    regards

    Thursday, September 13, 2012 10:01 PM
  • Thank you very much, your solution of mounting the OS .iso was very helpful.
    • Proposed as answer by miark Thursday, April 18, 2013 2:22 PM
    Sunday, September 16, 2012 8:37 PM
  • mount the iso or put the dvd on the drive

    just do this start screen type cmd then right button click bellow appears run as administrator

    type

    dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /all

    d: is my drive change to suit yours

    it works fine

    • Proposed as answer by Crouchie1998 Friday, July 19, 2013 2:53 PM
    Tuesday, September 18, 2012 9:43 AM
  • Your steps was helpful and worked for me.. Thanks a  lot!
    Monday, September 24, 2012 2:10 PM
  • Thank you so very much, BertanD.  I am very grateful for your kindness and collegiality in sharing your expertise.  You saved me - and also must have saved others - much time, effort and frustration.  Your solution functioned flawlessly.

    Hats off and a bow to you.  You have my admiration and gratitude.  Thanks again.

    Monday, October 15, 2012 1:23 AM
  • Thanks BertanD.
    • Edited by Kerberos79 Friday, October 19, 2012 9:14 AM
    Friday, October 19, 2012 9:13 AM
  • Thanks for your valuable tips . I have successfully added the .net framework 3.5 roles on the existing setup.

    Regards,

    Mahalingamoorthy M


    Thanks, Mahalingamoorthy Marimuthu

    Wednesday, October 24, 2012 11:11 AM
  • Wednesday, October 24, 2012 12:12 PM
  • Thanks! BertanD. This worked great for me

    ***

    Hi,

    If you have Windows Server 2012 iso file or DVD, you can install .net framework 3.5 on Windows Server 2012 easly.

    1. You have to insert Windows Server 2012 DVD or iso to D drive.

    2. Open Add Roles and Features Wizard

    3. Select .NET Framework 3.5 Features and then click next,

    4. Select Specify an alternate source path link in the Confirm installation selections screen.

    5. Path: D:\Sources\SxS and then click OK.

    6. Finally click Install button.

    ***

    • Proposed as answer by Mr. Thomas Thursday, May 02, 2013 1:12 PM
    Saturday, November 10, 2012 10:00 PM
  • Use the /all option if one of the parent features is not activated.

    The operation is complete but NetFx3 feature was not enabled.
    A required parent feature may not be enabled. You can use the /enable-feature /all option to automatically enable each parent feature from the following list. If the parent feature(s) are already enabled, refer to the log file for further diagnostics.

    dism.exe /online /enable-feature /all /featurename:NetFX3 /Source:D:\sources\sxs /LimitAccess

    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384

    Image Version: 6.2.9200.16384

    Enabling feature(s)
    [==========================100.0%==========================]

     

     



    blog: http://www.tomvangaever.be


    Tuesday, November 13, 2012 1:25 PM
  • Thank you BertanD !!!

    Thursday, December 20, 2012 8:58 AM
  • Hi,

    If you have Windows Server 2012 iso file or DVD, you can install .net framework 3.5 on Windows Server 2012 easly.

    1. You have to insert Windows Server 2012 DVD or iso to D drive. 

    2. Open Add Roles and Features Wizard

    3. Select .NET Framework 3.5 Features and then click next,

    4. Select Specify an alternate source path link in the Confirm installation selections screen.

    5. Path: D:\Sources\SxS and then click OK.

    6. Finally click Install button.

    Its very help full

    Sunday, February 03, 2013 5:03 AM
  • @ Windows Server 2012 it worked with the /all option and without the /LimitAccess:

    dism.exe /online /enable-feature /all /featurename:NetFX3 /Source:D:\sources\sxs

    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384

    Image Version: 6.2.9200.16384

    Enabling feature(s)
    [==========================100.0%==========================]
    The operation completed successfully.

    Friday, February 22, 2013 3:02 PM
  • This works better when you put the command in correctly - it needs spaces - "dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /LimitAccess"

    When you add the spaces it works - don't forget to use an elevated powershell prompt (right-click the powershell icon and choose run as administrator).

    I didn't need the second step - if you need it, don't forget to add spaces again - "dism.exe /online /enable-feature /featurename:NetFX3 /all"

    Loose the quotes, of course.

    Thanks for the hint - works great!!

    • Proposed as answer by fearnodeer Friday, February 22, 2013 6:17 PM
    Friday, February 22, 2013 6:17 PM
  • Heh, this is a not_so_fun feature. It seems, that lot of stuff still requires 3.5, like Web server and SQL. I don´t use installation media, I have vmware templates, and some times in data centers this could be a problematic thing to do.

    Or you need to be aware of this, before creating the template and include 3.5 into the image.


    • Edited by yannara Tuesday, February 26, 2013 7:17 AM
    • Proposed as answer by Svenkle Thursday, June 26, 2014 10:00 AM
    Tuesday, February 26, 2013 7:00 AM
  • You might face difficulty for installing .Netframework 3.5 on Windows Server 2012, where the Server Manager fails and tells you that due to the unavailability of the required source file for .NetFramework 3.5 it cannot continue the installation.

    As a quick solution, you can use the below command for installing .Netframework 3.5, which requires you to amount the Windows Server 2012 installation media to the server.

    “C:\Windows\system32>dism.exe /enable-feature /all /featurename:NetFX3 /online /Source:d:\sources\sxs /LimitAccess


    Zahir Hussain Shah | MVP - Exchange Server | Solution Architect - Messaging | My blog: http://zahirshahblog.com ]If my answer fixes your problem, mark them as answer, so it will help others to find a solution]

    Wednesday, February 27, 2013 7:26 AM
  • That wordt fine thnx for the solution
    • Proposed as answer by Svenkle Thursday, June 26, 2014 10:01 AM
    Friday, March 15, 2013 10:59 AM
  • Wednesday, May 15, 2013 7:43 PM
  • This worked!  Thanks!
    Friday, June 07, 2013 12:54 PM
  • Thanks a lot BertranD, it worked for me too!
    Wednesday, June 26, 2013 1:30 PM
  • It works........ Thanks dear
    Monday, July 01, 2013 9:34 AM
  • Thanks for your command. It helped.
    Wednesday, July 03, 2013 6:43 AM
  • when I do as u write. it tells me: --------66.3%----------

    what can I do?

    Thursday, July 04, 2013 7:24 AM
  • Hi,...

    Enabling feature .Net Framework 3.5 and Framework 2.0
    first the tom vangaever method
    1.Open Run with administrator previledge,and type this at the command :
    dism.exe /online /enable-feature /all /featurename:NetFX3 /Source:D:\sources\sxs /LimitAccess
    2.and then, this message will be shown up :
    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384
    Image Version: 6.2.9200.16384
    Enabling feature(s)
    [==========================100.0%==========================]
    3.Check your enabling features in windows 2012.

    or you can try the Bertand D method :

    1. You have to insert Windows Server 2012 DVD or iso to D drive. 
    2. Open Add Roles and Features Wizard
    3. Select .NET Framework 3.5 Features and then click next,
    4. Select Specify an alternate source path link in the Confirm installation selections screen.
    5. Path: D:\Sources\SxS and then click OK.
    6. Finally click Install button.

    i already try both method,and it works just fine.

    Monday, July 08, 2013 3:26 AM
  • Thanks for posting BertanD works great
    Thursday, July 18, 2013 2:21 AM
  • This solution always fails for me but DEVAXATATOR's suggestion worked perfectly:

    dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /all


    Crouchie
    -------------
    Homepage
    -------------


    • Edited by Crouchie1998 Friday, July 19, 2013 2:56 PM Added solution that worked
    Friday, July 19, 2013 2:51 PM
  • Hi,

    If you have Windows Server 2012 iso file or DVD, you can install .net framework 3.5 on Windows Server 2012 easly.

    1. You have to insert Windows Server 2012 DVD or iso to D drive. 

    2. Open Add Roles and Features Wizard

    3. Select .NET Framework 3.5 Features and then click next,

    4. Select Specify an alternate source path link in the Confirm installation selections screen.

    5. Path: D:\Sources\SxS and then click OK.

    6. Finally click Install button.

    Thanks Bertan 

    yoyr suggestion wored foe me too.


    Tuesday, August 13, 2013 8:22 AM
  • Thank you, BertanD!
    Tuesday, August 27, 2013 7:20 AM
  • This worked for me.

    Thanks

    Friday, August 30, 2013 4:47 AM
  • Thanks BertanD
    Thursday, September 05, 2013 8:03 AM
  • Thanks Bertan!
    Wednesday, September 11, 2013 2:09 PM
  • Thanks BertanD ... your solution really helped ;) 
    Wednesday, September 11, 2013 9:44 PM
  • Thanks.  Your answer worked for me.
    Thursday, September 26, 2013 2:40 PM
  • Hi,

    If you have Windows Server 2012 iso file or DVD, you can install .net framework 3.5 on Windows Server 2012 easly.

    1. You have to insert Windows Server 2012 DVD or iso to D drive. 

    2. Open Add Roles and Features Wizard

    3. Select .NET Framework 3.5 Features and then click next,

    4. Select Specify an alternate source path link in the Confirm installation selections screen.

    5. Path: D:\Sources\SxS and then click OK.

    6. Finally click Install button.

    Particularly useful suggestion as the Intel Management environments required to install LAN drivers require .NET framework to be installed so you are in a catch 22 position
    Wednesday, October 09, 2013 7:37 PM
  • Fabulous, it's like working with windows NT4 all over again

    Wouldn't even detect that the CD was already in the drive

    Nothing like progress....."there's", "this is", take your pick

    Monday, October 14, 2013 2:16 PM
  • Ha, I'm only even in this mess as the Office 365 auto checker wanted .net 3.5SP1 OR GREATER , and I already have 4.5 on there.

    Apparently 4.5 is not so great

    Monday, October 14, 2013 2:18 PM
  • After downloading dotnetfx35, and trying every which way to get it to install (because this the way we did it in class)just using the 2012 windows install ISO was so easy. I guess since it will not install from add / remove features in Srv Mgr I just thought it was not in the 2012 windows package. Why include it but in the install medium, have a check box for it in add features and then not let it work. It’s Sooooooooooooooooo Microsoft. Insert media (Windows 2012) DVD/ISO and point to sources\SxS
    Tuesday, November 12, 2013 2:32 AM
  • After downloading dotnetfx35, and trying every which way to get it to install (because this the way we did it in class)just using the 2012 windows install ISO was so easy. I guess since it will not install from add / remove features in Srv Mgr I just thought it was not in the 2012 windows package. Why include it but in the install medium, have a check box for it in add features and then not let it work. It’s Sooooooooooooooooo Microsoft. Insert media (Windows 2012) DVD/ISO and point to sources\SxS
    Tuesday, November 12, 2013 2:33 AM
  • Thank you very much for your suggestion. It works like a charm!! :) You saved my life!

    Have a wonderful day!! :D

    Wednesday, November 13, 2013 7:12 PM
  • This method works........

    Thanks Sheldon

    Friday, November 15, 2013 2:40 PM
  • I used Group Policy to correct this issue.  Now all the servers in our infrastructure can install this feature via the normal feature installation GUI without the need for specifying an alternate source file location and essentially circumventing WSUS for packages which are not available through WSUS.

    Here are the steps for the local machine:

    1. Open the Group Policy editor (gpedit.msc)

    2. Goto Computer > Administrative Templates > System and open Specify settings for optional component installation and component repair.

    3. Select Enable to enable the policy and check Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS).

    And you're done!  To apply this setting to your entire AD infrastructure, open the Group Policy Management Editor and pin the new policy to the root of your AD.

    Hope this helps!

    Sean

    Monday, November 25, 2013 1:59 AM
  • I used Group Policy to correct this issue.  Now all the servers in our infrastructure can install this feature via the normal feature installation GUI without the need for specifying an alternate source file location and essentially circumventing WSUS for packages which are not available through WSUS.

    Here are the steps for the local machine:

    1. Open the Group Policy editor (gpedit.msc)

    2. Goto Computer > Administrative Templates > System and open Specify settings for optional component installation and component repair.

    3. Select Enable to enable the policy and check Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS).

    And you're done!  To apply this setting to your entire AD infrastructure, open the Group Policy Management Editor and pin the new policy to the root of your AD.

    Hope this helps!

    Sean

    Hi Sean, 

    Your solution worked for me. As I'm new to AD, I'm unsure of how to "pin the new policy to the root of your AD". Could you provide the steps? Thanks for your help!

    • Proposed as answer by Jiri Kvarda Thursday, August 07, 2014 10:41 AM
    Tuesday, November 26, 2013 3:58 AM
  • Note: Make sure that the Service "Windows Update" is not disabled. Otherwise the installation fails with error "0x800F0906".
    Monday, December 02, 2013 12:53 PM
  • you can use below workaround by specifying alternative source path,

    http://www.vmwareandme.com/2014/01/guide-windows-server-2012-do-you-need.html


    www.mytricks.in


    Thursday, January 02, 2014 9:51 AM
  • Perfect, thanks.
    Thursday, January 02, 2014 10:24 PM
  • ON 2012 R2 is: "dism.exe /online /enable-feature /all /featurename:NetFX3 /Source:D:\sources\sxs /LimitAccess"
    Wednesday, January 08, 2014 10:37 AM
  • This is stupid I shouldn't have to do this. You don't have to with 2008 r2.
    Saturday, January 25, 2014 11:55 PM
  • \Sources\SxS worked for me too! Thank you!
    Friday, January 31, 2014 5:41 PM
  • Hello

    1) Make sure that you have access to the windows server 2012 ISO, that you can browse till the source directory

    2) Capture the ISO in the D drive if possible (or any other drive just mention it in the PowerShell command below)

    3) Run the following PowerShell command 

    dism.exe /online /enable-feature /all /featurename:NetFX3 /Source:D:\sources\sxs

    4) wait until the message operation completed successfully show up then restart your machine

    Note: as you can see /all is set in bold, it is important to have it, as it would install any parent feature required by the NetFX3

    Thanks


    Monday, February 03, 2014 4:18 PM
  • This did the trick for me Thanks
    Tuesday, February 04, 2014 12:45 AM
  • hi...
    everybody this a real  solution


    http://windows.microsoft.com/tr-tr/windows-8/windows-update-error-0x800f081f

    thx

    Semih SOYKAL

    Semih

    Monday, March 03, 2014 4:13 PM
  •  i don't have iso file
    i recently downloaded a free licensed version of 3.5
    Tuesday, March 11, 2014 11:37 AM
  • Hi BertanD,

    Your tip is very helpful.

    Thanks a lot!

    Best Regards,

    Wednesday, March 12, 2014 1:16 PM
  • I had to type the whole feature name:

    dism.exe /online /enable-feature /featurename:NetFX3ServerFeatures /Source:D:\sources\sxs /LimitAcces


    Cheers, Matthew Kerfoot

    • Proposed as answer by wej68 Wednesday, March 19, 2014 8:35 PM
    Monday, March 17, 2014 2:23 PM
  • Hi everyone,

    I really need help, tried everything to install .net framework 3.5 on windows Server 2012 STD fully updated but no success.

    The server is virtual machine running on VMware ESxi 5.5

    What I've done already (tried on powershell or command line as admin and logged as domain admin) :

    - dism.exe /online /enable-feature /featurename:NetFX3ServerFeatures /Source:D:\sources\sxs /LimitAcces => works but it does not install the feature itself, it installs the parent feature only.

    - dism.exe /online /enable-feature /featurename:NetFX3 /Source:D:\sources\sxs /all  (or every look a like command) => It goes to 66% but fails after.

    - using the GUI with a alternate source (using UNC path or local drive using the ISO ) but failed with the usual error message

    - Tried copying the source files to an alternate location on a temp folder and tried with two different ISO files.

    I think I lollowed every KB possible on the internet but nothing worked. Trying to find something to avoid reinstalling the machine.

    If someone has an idea...DISM logs available if needed.

    Thanks in advance.




    Friday, May 16, 2014 1:58 PM
  • This is the simplest and most accurate solution.  This should be marked as the answer. 
    Monday, June 30, 2014 2:36 PM
  • I tried doing this but not able to finish the installation.

    Saturday, July 05, 2014 4:29 AM
  • You and me both. Have you gotten this resolved yet? My installation media doesn't have the sxs subdirectory either.
    Tuesday, July 15, 2014 2:44 PM
  • Nothing else helped me.

    This solution fixed my problem installing NetFX3.

    The server is part of domain with WSUS distribution of updates.

    Regards,

    Jiri Kvarda

    Thursday, August 07, 2014 10:44 AM
  • I used a Windows 8 CD that happened to be inserted into my 2012 server and it worked pointing it to the D:\sources\sxs folder.

    Bob Bailey

    Monday, August 11, 2014 11:37 PM
  • Please try uninstall any patch already installed on 3.5 first from view updates and then reboot, try the dism method. Works for me
    • Proposed as answer by rolly-n Sunday, September 14, 2014 6:52 AM
    Sunday, September 14, 2014 6:46 AM
  • Thanks rolly-n for posting this, it did the trick for me when none of the install methods would work (powershell, command line, GUI, local source, Internet source, etc).

    Apparently one of the MS updates was applied for the 3.5 .NET framework, even though the framework itself had not been installed yet.  I tracked down the KB from Windows Update > View update history, then located the same KB under Control Panel > Programs > Programs and Features > Installed Updates to actually remove it.  It is worth noting that only the prior location mentioned .NET 3.5 in the description, so I made a note of the KB number which was KB2966827 in my case.

    • Proposed as answer by EdisonY Monday, September 15, 2014 10:03 PM
    Monday, September 15, 2014 9:28 PM
  • Perfect, thanks , your answer worked for me.
    Monday, September 15, 2014 10:05 PM
  • Thanks rolly-n and EdisonY. After all the group policy settings, command line arguments, SXS folder copying, etc., KB2966827 bit me too :)
    Tuesday, September 16, 2014 3:25 PM
  • Wow! Thank you rolly-n and EdisonY!! That was it! I was pulling my hair out over this!! That's what we get for doing all of our Windows updates before configuring our server!
    Tuesday, September 16, 2014 10:02 PM
  • Thanks rolly-n for posting this, it did the trick for me when none of the install methods would work (powershell, command line, GUI, local source, Internet source, etc).

    Apparently one of the MS updates was applied for the 3.5 .NET framework, even though the framework itself had not been installed yet.  I tracked down the KB from Windows Update > View update history, then located the same KB under Control Panel > Programs > Programs and Features > Installed Updates to actually remove it.  It is worth noting that only the prior location mentioned .NET 3.5 in the description, so I made a note of the KB number which was KB2966827 in my case.


    Fantastic!  I have been fighting with this issue for several days now.  It was all because of KB2966827.  After finding your post and uninstalling it, everything works!!  Thanks for sharing.
    Thursday, September 18, 2014 2:35 PM
  • Unbelievable!  I have spent days on this reading everything I could possibly find and finally found this post.  I have tried everything including downloading a new iso image of Server 2012 and copying the sources folder and trying to install using the DSIM commands. It always failed.   I uninstalled the KB2966827 which is a security update for 3.5 .NET framework.  Then I ran the install from the Server Manager  "add Roles and Features" installing the 3.5 .NET Framework features and it worked!  I then reinstalled my SQL Server Express 2012 and it worked!   This update was released  August 12, 2014 so any attempts to install .NET 3.5 Framework on Server 2012 after this date will be affected by this.  The simple answer is to UNINSTALL This update then try enabling the feature via Server Manager.  You shouldn't have to try all the other things for a standard install if you do this first.

    • Proposed as answer by Rizzk Sunday, September 21, 2014 5:07 AM
    Friday, September 19, 2014 3:53 PM
  • Rolly-n <== Rock Star.  This one was killing me, but your solution worked!!!
    • Proposed as answer by gregf90 Tuesday, September 23, 2014 4:58 AM
    Friday, September 19, 2014 4:26 PM
  • Thank you Rolly-n  & Andrew-Guam , After two days of fighting with it, removal of the KB as noted above  solved the issue and .net 3.5 isntalled with no further issues.  

    Sunday, September 21, 2014 1:36 AM
  • Actually these error messages are coming due to following 3 updates recently released by Microsoft for .NET Framework 3.5:

    • KB2966826
    • KB2966827
    • KB2966828
    Sunday, September 21, 2014 5:08 AM
  • This workaround has resolved the issue for me!

    Uninstalled ::

    Control Panel > Programs > Programs and Features > Installed Updates > Security Update KB2966827

    Running on vSphere (VMware) 5.1 Windows Server 2012 Foundations

    C:\Users\Administrator>dism /online /enable-feature /featurename:NetFX3 /all /So
    urce:d:\sources\sxs

    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384

    Image Version: 6.2.9200.16384

    Enabling feature(s)
    [==========================100.0%==========================]
    The operation completed successfully.

    Monday, September 22, 2014 12:28 AM
  • Many thanks in advance, worked for me without any issue.
    Wednesday, September 24, 2014 12:01 PM
  • My case is Azure VM, Windows Server 2012 Data Center create from gallery, same issue,  until remove the KB 2966827... spend half a day on it.

    Wednesday, September 24, 2014 4:28 PM
  • Thank you!!!! this also worked for me! although I didn't have the KB2966827, but the KB2966828. Uninstalled the KB2966828 and installed net 3.5 via Server Manager with no problems!
    Thursday, September 25, 2014 7:12 PM
  • Good workaround, thanks! KB2966827 was that bad
    Friday, September 26, 2014 12:48 PM
  • Thanks rolly-n for posting this, it did the trick for me when none of the install methods would work (powershell, command line, GUI, local source, Internet source, etc).

    Apparently one of the MS updates was applied for the 3.5 .NET framework, even though the framework itself had not been installed yet.  I tracked down the KB from Windows Update > View update history, then located the same KB under Control Panel > Programs > Programs and Features > Installed Updates to actually remove it.  It is worth noting that only the prior location mentioned .NET 3.5 in the description, so I made a note of the KB number which was KB2966827 in my case.

    Worked for us !!! Great Tip

    Thanks for sharing

    Friday, September 26, 2014 5:20 PM
  • I'm having this same issue.

    I've used the "dism.exe /online /enable-feature /featurename:NetFX3ServerFeatures /Source:D:\sources\sxs /LimitAccess" command in the past with great success.  I've also used the method of using the GUI and specifying an alternate source path with great success.

    Today, however is a different story. Nothing seems to work.

    I get to 66.4% and then I receive an error (see below)

    -------------

    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031

    Image Version: 6.3.9600.17031

    Enabling feature(s)
    [===========================66.4%======                    ]

    Error: 0x800f0906

    The source files could not be downloaded.
    Use the "source" option to specify the location of the files that are required to restore the feature. For more informat
    ion on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    -------------

    I have internet access from this machine, too.

    This is really frustrating.  What changed and is there a workaround?


    Freddy Thomas

    Monday, September 29, 2014 9:00 PM