none
WSp- en Español

    Question

  • Chicos

    Espero que puedan ayduarme, les comento: Estoy usando la siguiente solucion en Sharpeoint Foundation 2010:

    http://www.techsolutions.net/SharePointSolutions.aspx

    La de Ausencis y vacaciones

    ---

    Si tengo el sharepoint en Ingles funciona sin problemas, el problema lo tengo cuando tengo que instalarlo en un Sharepoint Foundation 2010 en Español, no me aparece para implementarla.

    Se les ocurre algo? Alguna ayuda? es posible implementarla? Conocen algun otro lado para conseguir esta solucion

    Saludos

    Thursday, March 22, 2012 6:28 PM

Answers

  • Chicos

    Gracias por su ayuda, FInalmente lo solucione, debugiamos la aplicación en Visual studio 2010.

    Cuando instala la Solucion crea una carpeta con los archivos necesarios.  CUando se tiene un Sharepoint en Ingles , el nombre de la carpeta es 1033 (id del idioma ingles), en cambio cuando se instala la solucion en un Sharepoint en Espanol, de forma predeterminada lo guarda en una carpeta con numero 3087 (ID del espanol, no estoy seguro del numero en estos momentos).

    En el codigo de la solucion se estan buscando los archivos con la carpeta 1033, la solucion fue cambiarle el nombre a la carpeta 3087 a 1033 y asi la instalo sin problemas :)

    Monday, April 02, 2012 3:03 AM

All replies

  • Hola,

    Se podría y lo que tienes que hacer es los siguiente:

    • Importar el WSP en Visual Studio de forma que se generen todos los elementos que forman parte de la plantilla: listas, instancias de listas, el Web Template, etc.
    • Coger cada uno de los archivos que se han importado e ir traduciéndolos.

    Como ves te puede dar bastante trabajo e igual te compensa crear desde cero tu propia solución.

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    Thursday, March 22, 2012 7:46 PM
  • Juan

    Gracias por la respuesta, el problema es que no se me visualiza como template cuando pongo crear nuevo sitio. Solamente traduciendola no se podria :(

    Thursday, March 22, 2012 7:51 PM
  • Hola Maxi,

    Vamos a ver, la solución que te doy es para que puedas crear sitios en base a esa plantilla con el idioma castellano y es traducir, pero no solo traducir, tienes que asegurarte que todos los esquemas van a estar bien y esto solo puedes hacer con Visual Studio.

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    Friday, March 23, 2012 8:00 AM
  • Creo que tienes limitadas las opciones:

    1. Hacerlo de 0 copiando las opciones del que existe en inglés (pereza...)

    2. Intenta instalar el Foundation Language pack en inglés al de español. Cambia a inglés y mira a ver si aparece? Puede ser que el WSP esté buscando la carpeta de región en inglés y no la encuentra. Quizá con el Lang Pack aparezca... vale intentarlo.

    3. Me parece que son plantillas, no soluciones. Intenta instalarla en Inglés. Luego ve a la galería de plantillas de sitio y exportala sin contenido a un STP. Luego importa a español a ver que tal.

    Carlos

    Sunday, April 01, 2012 4:20 PM
  • Chicos

    Gracias por su ayuda, FInalmente lo solucione, debugiamos la aplicación en Visual studio 2010.

    Cuando instala la Solucion crea una carpeta con los archivos necesarios.  CUando se tiene un Sharepoint en Ingles , el nombre de la carpeta es 1033 (id del idioma ingles), en cambio cuando se instala la solucion en un Sharepoint en Espanol, de forma predeterminada lo guarda en una carpeta con numero 3087 (ID del espanol, no estoy seguro del numero en estos momentos).

    En el codigo de la solucion se estan buscando los archivos con la carpeta 1033, la solucion fue cambiarle el nombre a la carpeta 3087 a 1033 y asi la instalo sin problemas :)

    Monday, April 02, 2012 3:03 AM