none
USMT Offline Migration

    Question

  • Hi.

    When using the USMT Offline mode of MDT (from an F12 PXE Boot) i'm getting the following error message...

    Has anyone any thoughts on what might be causing this? i've selected the option to move existing data...

    Thanks

    Rich

    Thursday, February 14, 2013 5:21 PM

All replies

  • what happens when you run your scanstate from inside winpe by hand?  Not sure what the CNAME loop is about, sounds like a DNS problem.  what happens when you run an nslookup on your server hosting the USMT share?
    Thursday, February 14, 2013 7:56 PM
  • In the past, ppl have reported drive encryption, using USMT5(ADK) or having USMT3 missing in some cases. 

    This post says using USMT4 solved it.

    Post back and let me know what OS you're moving from/to, pls.


    Blog: http://scriptimus.wordpress.com

    Thursday, February 14, 2013 9:15 PM
  • Hi It's Windows 7 to Windows 7, so all things being equal - it should just work, it's all out-of-box MDT and I've not 'fiddled' with any of the USMT scripts! It is however MDT 2012 using the ADK, I have tried removing the USMT5 fodder and replacing with USMT4 - no joy! (Created a test deployment share so not to alter the current environment!) As for DNS, I'll run nslookup tomorrow first thing from the server hosting the deployment share, not tried scanstate manually from inside WINPE - if I was a betting man I think it'll fail... Would be good to see what happens though. In the meantime, any other ideas would be gratefully received :) Cheers chaps for your help so far.
    Friday, February 15, 2013 12:36 AM
  • Hi,

    I've managed to get Offline USMT working using USMT4 rather than USMT5 - although it appears MDT 2012 Update 1 and the ADK is supposed to use USMT5 by design.

    Could someone please advise further why this fails when using USMT5? Ideally i'd like to use the current Microsoft solution to take advantage of the extra features held in USMT5.

    The only thing I've noticed that might be a factor in this - the disk partitions are configured as follows - Partition1 = System(WINPE drive letter c:), Partition2 = Recovery (WINPE drive letter d:), Partition3 = OSDisk (WINPE drive letter e:).... This is the only key change I've made to the task sequence.

    I had a look at BDD.log in the minint folder and the log stops when it identifies the recovery partition d: as a possible OS Partition.... this doesn't happen with USMT4 and the process continues after this step in the log. When using USMT4 the MININT folder is located on the recovery partition (which works) when using USMT5 the MININT folder is located on the OSDisk partition.

    Thanks and regards

    Richard

    Friday, February 15, 2013 11:07 AM
  • From what I've seen, unless you're migrating to Windows 8 then you should stay with AIK for the best compatibility.

    Also, read this resource for USMT 5 technical information.

    Offline Migration Reference


    Blog: http://scriptimus.wordpress.com

    Friday, February 15, 2013 11:49 AM
  • Hi

    I've just tested this with MDT 2012 Update 1 and the AIK and all works fine. Thanks for the help Andrew - that's great :)

    Looking at the documentation it does appear that this 'should' work with Windows 7, MDT and the ADK, can someone from Microsoft please confirm that this doesn't work? If it does work has anyone got any ideas where I'm going wrong? We're looking to have Windows 7 and Windows 8 clients in our environment and would like to use the same deployment share to deploy both Operating Systems so therefore really need to be able to use the ADK.

    Thanks

    Rich

    Friday, February 15, 2013 12:38 PM
  • Hi Andrew

    Actually, when I said it all works fine using USMT4 I was sadly mistaken, it does the USMT Offline phase and deploys the OS, when it restarts and finally gets to Windows it errors saying it can't find d:\minint\...vbs (can't remember which script it is...)

    My deployment isn't in a good place right now I don't think

    Thanks

    Richard

    Friday, February 15, 2013 4:15 PM
  • OK, let's drill down into your issue.

    Can you post your customsettings.ini less any passwords etc?

    You said that you're performing a windows 7 refresh to win 7. PXE booting WDS. is this right?


    Blog: http://scriptimus.wordpress.com

    Friday, February 15, 2013 9:00 PM
  • Thanks Andrew

    That's almost right, its actually a Windows 7 'NEWCOMPUTER' build with MDT2012 Update 1, when PXE booting from WDS and connecting to the deployment share I get prompted with the hta 'Move data and settings from a previous version of Windows' - from there I select 'Move data and settings' (see attached.)

    The deployment starts and fails at the task sequence stage 'Offline user state capture' with the error above.... Today I've done a little digging and it seems to be something related to the script 'ZTIUserstate.wsf' at the point where it sets the /targetwindows7 switch for scanstate. If I comment out that line then it does seem to get much further - although I've not let it run through to completion yet so not sure if I get any more problems along the way from that.... I've no idea what that line does, i backed up the file first so am back to the default configuration again.

    CustomSettings.ini looks like this...

    [Settings]
    Priority=Default

    [Default]
    SkipComputername=YES
    _SMSTSOrgName=Hewlett-Packard CDS Mentor Build
    PrepareWinRE=YES
    UserExit=Z-Userexit.vbs
    SkipBDDWelcome=YES
    OSInstall=Y
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipDeploymentType=NO
    SkipDomainMembership=YES
    JoinWorkgroup=WORKGROUP
    UserDataLocation=AUTO
    UDShare=\\buildserver\MentorDeployment$\UserData
    UDDir=%ComputerName%
    SkipComputerBackup=NO
    ComputerBackuplocation=AUTO
    BackupShare=\\buildserver\MentorDeployment$\ComputerBackup
    BackupDir=%ComputerName%
    SkipBuild=NO
    SkipPackageDisplay=NO
    SkipLocaleSelection=YES
    UILanguage=#GenerateUILanguage("%WDSServer%")#
    UserLocale=#GenerateUserLocale("%WDSServer%")#
    InputLocale=#GenerateKeyboardLocale("%WDSServer%")#
    KeyboardLocale=#GenerateKeyboardLocale("%WDSServer%")#
    SkipTimeZone=YES
    TimeZoneName=GMT Standard Time
    SkipApplications=YES
    SkipBitLocker=YES
    SkipCapture=YES
    DoCapture=NO
    SkipBitLockerDetails=YES
    SkipSummary=NO
    SkipFinalSummary=YES
    SkipAppsOnUpgrade=YES
    BitsPerPel=32
    VRefresh=60
    XResolution=1024
    YResolution=768
    HideShell=YES

    Thanks again for your time and help on this...

    Below is the hta I select... although I choose 'Move user data and settings'

    Friday, February 15, 2013 9:25 PM
  • There's nothing that sticks out there to me. 

    Your Properties=CustomProperty line is missing.

    Try adding these lines and let me know the test results, please.

    SkipUserData=YES
    USMTOfflineMigration=TRUE
    DoNotFormatAndPartition=YES

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Friday, February 15, 2013 10:35 PM
  • Thanks Andrew,

    I've tried that, we actually need to prompt the users with the page as not each build will require data to be backed up - so SkipUserData needs to be NO, the other 2 don't make any difference to the build i'm sorry to say - same problem!

    Just for interests sake I let a build continue with the line I mentioned earlier from ZTIUserState commented out, the build got further but then failed when it got into Windows ... Error was Error - can not find script file d:\minint\scripts\lticopyscript.wsf...

    Any other ideas?

    Thanks again

    Rich

    Friday, February 15, 2013 10:49 PM
  • I've have a look at this in my lab. My lab is 2008R2 WAIK/MDT 2012 U1. So I'm using USMT4. The XP to W7 offline migration is ok but for the windows 7, it wont allow me to select capture in the wizard.

    Looking on Technet here, USMT5 is capable of doing what you want. I wont have my ADK lab working for a couple weeks so I can't test it there, sorry.

    As a workaround you could try to force it not to use hardlinks by using UserDataLocation=NETWORK.

    Not sure what else to try here.


    Blog: http://scriptimus.wordpress.com

    Saturday, February 16, 2013 2:29 PM
  • Hey Andrew.

    I've disabled the step by removing the offline USMT stage on the task sequence just for my Windows 7 build, so still got the same functionality as before but using MDT 2012 Update 1

    If you do get chance to try it in your lab when you update it I'd be interested to hear how you get on if you would drop me a line...

    Thanks for all your help again Andrew. 

    Wednesday, February 20, 2013 10:20 AM
  • Hi all,

    I think USMT 5.0 is designed for Windows 8 by default and you need to "flip" the manifest sub folders to make Windows 7 USMT5 to work.

    For example, each USMT5 folder (x86 and x64) comes with ReplacementManifests (for W8) and ReplacementManifests7 (for Win7)

    To make it work for Windows 7, you need to rename existing one to ReplacementManifests8 and rename ReplacementManifests7 to ReplacementManifests.

    Another words, it seems to be impossible to make 1 USMT5 folder to work for both W7 and W8 via MDT...


    YPae

    Saturday, April 20, 2013 7:53 AM