none
unattend xml changes not take effect

    Question

  • Hello,

    I am trying to apply some settings to deployment image by changing xml.

    MDT is English version the images to Deploy are W7 French. LiteTouch WIM is on WDS server. So I do F12 to get a list of available MDT images.

    I want eliminate some manual entries in Depl. Wizard. For that I use unattend.xml because in image properties I cannot find the settings needed for change.

    1. On Language and other preferences screen I get:

    Language to install: Fr-Fr        (should be Fr-Fr, no other option)

    Time and currency: Fr-Fr        (should be French Canada, available)

    Keyboard layout:    Fr-Fr         (Canadian French, available)

    2. On Set the time zone screen I entered Time zone needed.

    These changes not take effect. Below you can see current XML and copy of original XML.

    What I am doing wrong?

    CURRENT XML:

    <SetupUILanguage>
            <UILanguage>fr-fr</UILanguage>
          </SetupUILanguage>
          <InputLocale>0c0c:00001009</InputLocale>
          <SystemLocale>fr-ca</SystemLocale>
          <UILanguage>fr-fr</UILanguage>
          <UserLocale>fr-ca</UserLocale>
      
       

            <JoinDomain></JoinDomain>
            <JoinWorkgroup>Workgroup</JoinWorkgroup>
           
         
      <TimeZone>Eastern Standard Time</TimeZone>

    Copy of original XML:   

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
      <settings pass="windowsPE">
        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
          <ImageInstall>
            <OSImage>
              <WillShowUI>OnError</WillShowUI>
              <InstallTo>
                <DiskID>0</DiskID>
                <PartitionID>1</PartitionID>
              </InstallTo>
              <InstallFrom>
                <Path>.\Operating Systems\FOR_Deployment_W7_64_FR_HP\CAPTURED_W7_64_FR_HP.wim</Path>
                <MetaData>
                  <Key>/image/index</Key>
                  <Value>1</Value>
                </MetaData>
              </InstallFrom>
            </OSImage>
          </ImageInstall>
          <UpgradeData>
            <Upgrade>false</Upgrade>
          </UpgradeData>
          <Display>
            <ColorDepth>16</ColorDepth>
            <HorizontalResolution>1024</HorizontalResolution>
            <RefreshRate>60</RefreshRate>
            <VerticalResolution>768</VerticalResolution>
          </Display>
          <ComplianceCheck>
            <DisplayReport>OnError</DisplayReport>
          </ComplianceCheck>
          <UserData>
            <AcceptEula>true</AcceptEula>
            <ProductKey>
              <Key></Key>
            </ProductKey>
          </UserData>
        </component>
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <SetupUILanguage>
            <UILanguage>en-US</UILanguage>
          </SetupUILanguage>
          <InputLocale>0409:00000409</InputLocale>
          <SystemLocale>en-US</SystemLocale>
          <UILanguage>en-US</UILanguage>
          <UserLocale>en-US</UserLocale>
        </component>
      </settings>
      <settings pass="generalize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
        </component>
      </settings>
      <settings pass="specialize">
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
          <Identification>
            <Credentials>
              <Username></Username>
              <Domain></Domain>
              <Password></Password>
            </Credentials>
            <JoinDomain></JoinDomain>
            <JoinWorkgroup></JoinWorkgroup>
            <MachineObjectOU></MachineObjectOU>
          </Identification>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
          <ComputerName></ComputerName>
          <ProductKey></ProductKey>
          <RegisteredOrganization>chal</RegisteredOrganization>
          <RegisteredOwner>Windows User</RegisteredOwner>
          <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
          <TimeZone>Pacific Standard Time</TimeZone>
        </component>
        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <Home_Page>about:blank</Home_Page>
          <IEWelcomeMsg>false</IEWelcomeMsg>
        </component>
        <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <RunSynchronous>
            <RunSynchronousCommand wcm:action="add">
              <Description>EnableAdmin</Description>
              <Order>1</Order>
              <Path>cmd /c net user Administrator /active:yes</Path>
            </RunSynchronousCommand>
            <RunSynchronousCommand wcm:action="add">
              <Description>UnfilterAdministratorToken</Description>
              <Order>2</Order>
              <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v FilterAdministratorToken /t REG_DWORD /d 0 /f</Path>
            </RunSynchronousCommand>
          </RunSynchronous>
        </component>
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <InputLocale>0409:00000409</InputLocale>
          <SystemLocale>en-US</SystemLocale>
          <UILanguage>en-US</UILanguage>
          <UserLocale>en-US</UserLocale>
        </component>
        <component name="Microsoft-Windows-TapiSetup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <TapiConfigured>0</TapiConfigured>
          <TapiUnattendLocation>
            <AreaCode>""</AreaCode>
            <CountryOrRegion>1</CountryOrRegion>
            <LongDistanceAccess>9</LongDistanceAccess>
            <OutsideAccess>9</OutsideAccess>
            <PulseOrToneDialing>1</PulseOrToneDialing>
            <DisableCallWaiting>""</DisableCallWaiting>
            <InternationalCarrierCode>""</InternationalCarrierCode>
            <LongDistanceCarrierCode>""</LongDistanceCarrierCode>
            <Name>Default</Name>
          </TapiUnattendLocation>
        </component>
        <component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <DisableSR>1</DisableSR>
        </component>
      </settings>
      <settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
          <UserAccounts>
            <AdministratorPassword>
              <Value></Value>
              <PlainText>true</PlainText>
            </AdministratorPassword>
            <LocalAccounts>
              <LocalAccount wcm:action="add">
                <Description>Temp account</Description>
                <DisplayName>Temp account</DisplayName>
                <Group>Users</Group>
                <Name>TempAccount</Name>
              </LocalAccount>
            </LocalAccounts>
          </UserAccounts>
          <AutoLogon>
            <Enabled>true</Enabled>
            <Username>Administrator</Username>
            <Domain>.</Domain>
            <Password>
              <Value></Value>
              <PlainText>true</PlainText>
            </Password>
            <LogonCount>999</LogonCount>
          </AutoLogon>
          <Display>
            <ColorDepth>32</ColorDepth>
            <HorizontalResolution>1024</HorizontalResolution>
            <RefreshRate>60</RefreshRate>
            <VerticalResolution>768</VerticalResolution>
          </Display>
          <FirstLogonCommands>
            <SynchronousCommand wcm:action="add">
              <CommandLine>cscript.exe C:\MININT\Scripts\LiteTouch.wsf /start</CommandLine>
              <Description>Lite Touch new OS</Description>
              <Order>1</Order>
            </SynchronousCommand>
            <SynchronousCommand wcm:action="add">
              <CommandLine>cscript.exe D:\MININT\Scripts\LiteTouch.wsf /start</CommandLine>
              <Description>Lite Touch new OS</Description>
              <Order>2</Order>
            </SynchronousCommand>
            <SynchronousCommand wcm:action="add">
              <CommandLine>cscript.exe E:\MININT\Scripts\LiteTouch.wsf /start</CommandLine>
              <Description>Lite Touch new OS</Description>
              <Order>3</Order>
            </SynchronousCommand>
            <SynchronousCommand wcm:action="add">
              <CommandLine>cscript.exe F:\MININT\Scripts\LiteTouch.wsf /start</CommandLine>
              <Description>Lite Touch new OS</Description>
              <Order>4</Order>
            </SynchronousCommand>
          </FirstLogonCommands>
          <OOBE>
            <HideEULAPage>true</HideEULAPage>
            <NetworkLocation>Work</NetworkLocation>
            <ProtectYourPC>1</ProtectYourPC>
            <SkipUserOOBE>true</SkipUserOOBE>
          </OOBE>
          <RegisteredOrganization>chal</RegisteredOrganization>
          <RegisteredOwner>Windows User</RegisteredOwner>
          <TimeZone></TimeZone>
        </component>
        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <InputLocale>0409:00000409</InputLocale>
          <SystemLocale>en-US</SystemLocale>
          <UILanguage>en-US</UILanguage>
          <UserLocale>en-US</UserLocale>
        </component>
      </settings>
      <settings pass="offlineServicing">
        <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <DriverPaths>
            <PathAndCredentials wcm:keyValue="1" wcm:action="add">
              <Path>\Drivers</Path>
            </PathAndCredentials>
          </DriverPaths>
        </component>
      </settings>
    </unattend>

    Tuesday, March 13, 2012 6:18 PM

Answers

  • Hi,

    Did you edit/create this answer file manually? I highly recommend that you use the Windows AIK which comes along with the Windows System Image Manager which is a GUI interface of creating/editting the xml answer file. It also has the validate feature which will recognize any errors that you might have.

    I highly recommend that you use this tool.

    • Marked as answer by pob579 Sunday, June 03, 2012 2:07 AM
    Saturday, June 02, 2012 3:40 PM

All replies

  • Hi,

    Did you edit/create this answer file manually? I highly recommend that you use the Windows AIK which comes along with the Windows System Image Manager which is a GUI interface of creating/editting the xml answer file. It also has the validate feature which will recognize any errors that you might have.

    I highly recommend that you use this tool.

    • Marked as answer by pob579 Sunday, June 03, 2012 2:07 AM
    Saturday, June 02, 2012 3:40 PM
  • Thanks for the reply. I will try your suggestion later when will return to the project.
    Sunday, June 03, 2012 2:09 AM