none
psexec to Windows 2008 R2 SP1

    Question

  • psexec hangs when connecting to Windows 2008 R2 with no error message.UAC is disabled on the target Windows 2008 R2 server and all UAC policies are also set to disabled. The -h option makes on difference, from Windows 7 / Windows 2003 the result is the same. The cmd window is started with a user account with local administrator access to the target Windows 2008 R2 server.

    Sample command:

    psexec \\Windows2008server -h cmd

    Windows Firewall is disabled and the AV has rules to allow this process.

    What change is required on Windows 2008 R2 for psexec to make a successful connection ?

    Tuesday, July 16, 2013 2:47 AM

Answers

All replies

  • PSexec uses TCP ports 139 and 445.

    Can you access the file share on the server remotely? Can you initiate PSExec from the server 2008 box to a remote machine?

    I would try to use other PStools to see if they work like PsFile.

    Lastly, disable 3rd party services using MSCONFIG and test.


    Regards, Vik Singh "If this thread answered your question, please click on "Mark as Answer"

    Tuesday, July 16, 2013 9:07 AM
  • Can you access the file share on the server remotely > Yes

    Can you initiate PSExec from the server 2008 box to a remote machine? > Yes

    Would you know a group policy via which psexec could be disabled on Windows 2008 ?

    Friday, July 19, 2013 8:18 AM
  • No, there is no group policy for that.

    Did you try the other suggestion I gave you? PSFile?

    I would try to use other PStools to see if they work like PsFile.


    Regards, Vik Singh "If this thread answered your question, please click on "Mark as Answer"

    Friday, July 19, 2013 8:27 AM
  • Did you try the other suggestion I gave you? PSFile > As  I mentioned yes I can access, but these servers donot have psexec issues, the Windows 2008 R2 servers with psexec issue, psfile also doesnot work,

    After eliminating all options either a GPO or a hotfix is causing this issue...

    Monday, July 29, 2013 7:10 AM
  • Hello,

    Please check if you have enabled applocker on windows 2008 R2 servers

    Please run only "psexec \\Windows2008server  cmd" against the problem server and see if that opens the command prompt on remote machine..

    If it still hangs then try adding this reg value by running the below command 

    REG ADD "HKCU\Software\Sysinternals\PsExec" /v "EulaAccepted" /t REG_DWORD /d 000

    This command will just add a dword value to accept end user license agreement for psexec.

    Please post your results, we can work together to fix this issue


    Sincerely, Asifkhan -- Please mark my post helpful if it was really helpful to you.

    Monday, July 29, 2013 6:42 PM
  • I finally fixed the issue by removing psexec, a new psexec connection to the same server then worked as expected.

    sc  \\server delete psexesvc

    On the Windows 2008 R2 server with issues, psexec was not able to start psexesvc from the C:\Windows\System32 directory with the error "File could not be found", any idea as to what will cause this and how removing and initiating a new connection fixes the issue.

    Wednesday, July 31, 2013 6:47 AM