none
Fully Unattended Windows 7 Ultimate Deployment w/ WDS failing at oobeSystem

    Question

  • The windows 7 unattended deployment w/ WDS goes perfectly until it gets to the OOBE pass and it always stops and asks me for 'Country or Region', 'Time and Currency', and 'Keyboard', and so on. 

    In my OOBESystem pass I have the following:

    <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>the password value edited out</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>Edited out</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Group>Administrators</Group>
                            <Name>admin</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
                <TimeZone>Eastern Standard Time</TimeZone>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>en-US</UserLocale>
                <InputLocale>en-US</InputLocale>
            </component>
        </settings>

    It seems to ignore everything in the oobeSystem section. Can someone please look over this? It validates just fine in WSIM. And the rest of the install (winPE, specialize, etc) goes smoothly. 

    Please assist. Thanks!

    Wednesday, September 18, 2013 2:46 PM

Answers

  • -Verify the network drivers.

    -Verify the Credentials in the JoinDomain value.

     

    Here is an example for x86 system:

     

    <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>domain.com</Domain>
                        <Username>domainjoin</Username>
                        <Password>XPW67328b1s!X</Password>
                    </Credentials>
                    <JoinDomain>domain.com</JoinDomain>
                </Identification>
            </component>

    If this doesn´t work try a unsecure join:

     

    http://technet.microsoft.com/en-us/library/cc765972(WS.10).aspx



    Kind regards,

    Tim
    MCITP, MCTS, MCSA
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.

    "If this thread answered your question, please click on "Mark as Answer"

    • Marked as answer by garg654 Thursday, September 19, 2013 3:15 PM
    Thursday, September 19, 2013 11:25 AM

All replies

  • Did you enable the built-in Administrator account elsewhere in your answer file? If not, remove the AdministratorPassword object.

    Verify that the image you are installing is 64bit Windows, not 32bit.

    Wednesday, September 18, 2013 3:05 PM
  • Thanks for the response. 

    There is no AdministratorPassword object set. And the image that I am installing is 64-bit Windows. But I am installing it in a KVM/qemu environment. I wonder if that can mess anything up. But the rest of the unattend file is being processed correctly and that is also set to processorArchitecture amd64. 

    Wednesday, September 18, 2013 3:27 PM
  • I added identical x86, and amd64 Microsoft-Windows-International-Core and Microsoft-Windows-Shell-Setup sections just to see if that was the problem, and it still stops at "Set up windows" screen. 

    It does not seem to want to do this. 

    Should I post my entire unattend.xml file that I am using w/ WDS? 

    Wednesday, September 18, 2013 5:33 PM
  • Since I'm using WDS, I was putting the unattend.xml file in Active Directory Prestaged Devices > Device Name > Properties > Client Unattend tab > Unattend File. 

    This is where the Oobe part did not work.

    So I took the OOBE section, and made a new file out of it, and put it in WDS > Servers > [servername] > Install Images > Windows 7 > Windows 7 Ultimate> Properties > 'Allow Image to install in unattended mode' Unattend File.

    And now it worked mostly. it just didn't join the domain. I'll keep experimenting. 

    Wednesday, September 18, 2013 6:56 PM
  • Hi,

    You can refer to this sample to check your own procedure:

    Unsecure join domain procedure

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/9851646d-d88b-4253-b5cf-00ae3049dc15/unsecure-join-domain-procedure

    if this issue persists, you can investigate the setupact.log in OOBE to check the error clue:

    Understanding Failures and Log Files

    http://technet.microsoft.com/en-us/library/ee851579(v=ws.10).aspx


    Alex Zhao
    TechNet Community Support

    Thursday, September 19, 2013 9:43 AM
    Moderator
  • -Verify the network drivers.

    -Verify the Credentials in the JoinDomain value.

     

    Here is an example for x86 system:

     

    <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>domain.com</Domain>
                        <Username>domainjoin</Username>
                        <Password>XPW67328b1s!X</Password>
                    </Credentials>
                    <JoinDomain>domain.com</JoinDomain>
                </Identification>
            </component>

    If this doesn´t work try a unsecure join:

     

    http://technet.microsoft.com/en-us/library/cc765972(WS.10).aspx



    Kind regards,

    Tim
    MCITP, MCTS, MCSA
    http://directoryadmin.blogspot.com

    This posting is provided 'AS IS' with no warranties or guarantees and confers no rights.

    "If this thread answered your question, please click on "Mark as Answer"

    • Marked as answer by garg654 Thursday, September 19, 2013 3:15 PM
    Thursday, September 19, 2013 11:25 AM