none
Migrating from SSRS 2008 to 2012: using System.TimeZoneInfo - can't find System.Core

    Question

  • I have a report is ssrs 2008 which uses this code:

    Shared Function FromUTC(ByVal d As Date, ByVal tz As String) As Date 

        Return (System.TimeZoneInfo.ConvertTimeBySystemTimeZoneId(d, System.TimeZoneInfo.Utc.Id, tz))

    End function

    and all ran fine.  Now when I run this report in SSRS 2012 I get the following error:

    Error while loading code module: ‘System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’. Details: Could not load file or assembly 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

    How can I resolve this?

    Tuesday, July 02, 2013 11:27 PM

All replies

  • Wednesday, July 03, 2013 3:14 AM
  • Thanks, but that didn't work for me.  it looks like that person had an issued between 3.5 and 4.0.  everything I have is 4.0.  I referenced the DLL in the report references:

    System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

    and I even copied the dll to:

    C:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer\bin

    The report runs find in the bids, but when I deploy to ssrs (on the same computer) I get that error.  I'm really stuck.  any other solutions?  I would think this is a common problem.

    Thank you.

    Wednesday, July 03, 2013 8:14 PM
  • Thanks, but that didn't work for me.  it looks like that person had an issued between 3.5 and 4.0.  everything I have is 4.0.  I referenced the DLL in the report references:

    System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

    and I even copied the dll to:

    C:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer\bin

    The report runs find in the bids, but when I deploy to ssrs (on the same computer) I get that error.  I'm really stuck.  any other solutions?  I would think this is a common problem.

    Thank you.

    Hi, I am also facing the same issue. Created a new Report in VS2012 and attached the asembly reference of System.Core, Version 4.0.0.0. While Deploying it is throwing an Error like "Error while loading code module: ‘System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’. Details: Could not load file or assembly 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified." Please let us know the solution for this. Thanks!!!
    Wednesday, October 23, 2013 1:11 PM
  • Still no solution yet.  Does anyone know how to resolve this?
    Thursday, January 30, 2014 2:30 AM