none
Explorer refresh - neue Ordner werden nicht sofort angezeigt

    Question

  • Hallo zusammen,

    ich habe mehrere W7 x64 in der Domäne, bei einem der PC's wird ein neuer Ordner, den der Benutzer auf einem Netzwerkshare anlegt (Share ist auf W2008 Server), erst nach einem manuellem refresh (F5) im Explorer angezeigt. Dies passiert bei unterschiedlichen Unterordnern des Shares, jedoch bis jetzt nur auf diesem einen Rechner. Er unterscheidet sich von den anderen W7-PC's nicht sonderlich (gleiche Hardware, gleiche Treiber, gleiches W7, leicht andere Applikationen).

    Man findet im Internet verschiedene Benutzer, die über ähnliche Probleme berichten, jedoch meistens bei neuen Orndnern auf Desktop oderin Bibliotheken.
    Gibt es für dieses Verhalten eine funktionierende Lösung?


    Viele Grüße Dirk
    Tuesday, August 03, 2010 8:02 AM

Answers

  • MSFT kann das Verhalten auf den Testsystemen nicht nachstellen. Ich habe es an 2 PC's und MVP Michael auch an mind. einem.

    MSFT vermutet, es hat etwas mit der OEM-Version von W7 oder XP zu tun. Da sie es nicht nachtellen konnten, macht es keinen Sinn, weiter nach der Ursache zu suchen, zumal die Supportzusage für XP (und daher kommt wohl das Problem) abgelaufen ist. Wir haben einvernehmlich den Call geschlossen.

     

    Workaround: Alle Verknüpfungen, die ursprünglich unter XP erstellt wurden, durch neue Verknüpfungen unter Windows 7 ersetzen.


    Viele Grüße Dirk
    • Marked as answer by -Dirk- Tuesday, August 30, 2011 1:00 PM
    Tuesday, August 30, 2011 12:59 PM

All replies

  • Hallo Dirk,

    könntest du bitte die unteren Reg Werte überprüfen?

    Key: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Value: NoRemoteRecursiveEvents
    Type: REG_DWORD
    Data:

    When you set the NoRemoteRecursiveEvents registry entry to 1, Change Notify requests are turned off for file and folder changes that occur in subfolders of a mapped network share. The server still sends a Change Notify event when a file or a folder is changed in the root and first folder level of the mapped network share. However, the server does not send a Change Notify event when a change is made at the level of the second subfolder or deeper in the mapped network share.


    Key: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    Value: NoRemoteChangeNotify
    Type: REG_DWORD
    Data:

    This value will disable a client's Windows Explorer's directory notifications that post NTNotifyDirectoryChange server message blocks (SMBs) to the server. Directory notifications allow the server to notify the client computer when information changes in files and folders that are located on shared folders on the server.

    Gruß,
    Andrei

    Wednesday, August 04, 2010 10:40 AM
    Moderator
  • Hallo Andrei,

    weder der Eintrag "NoRemoteRecursiveEvents" noch "NoRemoteChangeNotify" existieren in dem von Dir erwähnten Registry-Schlüssel.


    Viele Grüße Dirk
    Wednesday, August 04, 2010 11:00 AM
  • Hallo Dirk,

    evtl. könnte dieser Thread weiterhelfen.

    Gruß,
    Andrei

    Thursday, August 19, 2010 8:26 AM
    Moderator
  • Hi Andrei,

    ich habe die in Deinem Link erwähnten Einstellungen vorgenommen, ich muss aber mit einem Ergebnis warten, bis der User aus dem Urlaub zurück ist...


    Viele Grüße Dirk
    Monday, August 23, 2010 2:24 PM
  • Hi Andrei,

    leider hat es nicht geholfen, manchmal sind die neu erstellten Ordner sichbar, manchmal erst nach einem Refresh. Andere W7 Clients (davon 1 exakt baugleicher) haben keinerlei Probleme.


    Viele Grüße Dirk
    Tuesday, September 07, 2010 7:57 AM
  • Hallo,

    hat jemand mittlerweile eine Lösung zu dieser Thematik gefunden? Ich habe genau das gleiche Problem mit Windows 7 und 64 bit.

    Grüße

    Rafal

    Thursday, August 18, 2011 5:15 PM
  • Hi Rafal,

    ich habe zZ einen aktiven Call deswegen bei MSFT laufen. 2 PC's sind bei mir betroffen, 7 weitere baugleiche nicht.

    Wir haben bisher herausgefunden, dass es nur auftritt, wenn man über einen Link auf einen Ordner im Share zugreift. Dieser Link muss unter XP erstellt worden und dann nach W7 kopiert worden sein. Erstelle ich einen neuen Link zum selben Ziel direkt unter W7, so ist der neue Ordner im Fenster des neuen Links sofort sichtbar, in dem des XP-Links erst nach F5 - gleiches Ziel wohlgemerkt.

    Hangelt man sich "zu Fuss" zu Ziel (Computer->Laufwerksbuchstabe->...-> Ziel) tritt es nicht auf.

    Kannst Du das so bestätigen?

    MSFT wertet zZ noch die Netzwerktraces und ProcMon-Logs aus.


    Viele Grüße Dirk
    Thursday, August 18, 2011 5:24 PM
  • Hallo Dirk,

    > Dieser Link muss unter XP erstellt worden und dann nach W7 kopiert worden sein.

    Sauber, genau das ist das Problem obwohl die Links per Editor inspiziert nichts auffälliges aufzeigten, oder ich war blind.

    Hat eine Weile gedauert bis der Umstand aufgefallen ist, aber aus der Praxis gesehen kann ich das bestätigen:
    nutzen der "alten Links / Verknüpfungen" von XP und das Problem ist vorhanden, aber nicht bei neuen Verknüpfungen.

     


    mfg Michael | www.mbormann.de
    Thursday, August 18, 2011 11:30 PM
  • Hi Michael,

    danke für Deine Bestätigung - man fühlt sich jetzt nicht mehr so alleine :-)

    Es scheint, als wäre ein Bug im Explorer gefunden. Fairnisshalber muss ich aber sagen, dass ich auch Rechner unter W7 habe, bei denen alte Links aus XP-Zeiten funktionieren.

    Mal sehen, was die Traceauswertung ergibt.

     

    Ergänzung: Es tritt nur bei "neuer Ordner" auf - "neues Texdokument" zum Beispiel zeigt das Verhalten nicht.


    Viele Grüße Dirk

    Friday, August 19, 2011 6:47 AM
  • MSFT kann das Verhalten auf den Testsystemen nicht nachstellen. Ich habe es an 2 PC's und MVP Michael auch an mind. einem.

    MSFT vermutet, es hat etwas mit der OEM-Version von W7 oder XP zu tun. Da sie es nicht nachtellen konnten, macht es keinen Sinn, weiter nach der Ursache zu suchen, zumal die Supportzusage für XP (und daher kommt wohl das Problem) abgelaufen ist. Wir haben einvernehmlich den Call geschlossen.

     

    Workaround: Alle Verknüpfungen, die ursprünglich unter XP erstellt wurden, durch neue Verknüpfungen unter Windows 7 ersetzen.


    Viele Grüße Dirk
    • Marked as answer by -Dirk- Tuesday, August 30, 2011 1:00 PM
    Tuesday, August 30, 2011 12:59 PM
  • > Ich habe es an 2 PC's ..........

    Nachvollziehbar ist / war das einfach nicht, aber auch sicher nicht im Nachhinein die Zeit investiert.

    Danke für die Rückmeldung


    mfg Michael | www.mbormann.de
    Tuesday, August 30, 2011 2:28 PM