locked
Issue with Document library template

    Question

  • Hi,

     

      I have created template from Document library. That document Library has Versioning not Enabled.But I have enabled "Require content approval for submitted items? " Now I am creating new doc library from that temaplate. When I upload  any document on it, I dont see document in that lib. Then I go to version settings for doc library and disale "content approval for submitted items" and then enable it. I can see all document.

    Do you know why I need to follow above procedure (Disable - Enable Version) for each newly created doc lib?

     

    Thanx in advance.


    Tuesday, June 28, 2011 2:32 PM

Answers

  • solution was to create a library from the document library template. keep the OOTB settings. Add my custom views. then save library as template.

    create a PowerShell script that adds libraries to my site using the above template.

    Use PowerShell commands to update the advanced settings and versioning settings on the library.

    this worked satisfactorily.

    However that the OOTB functionality did not work is dissappointing.

    Regards,

    Counie

     

     


    SharePoint Farmer in training
    • Marked as answer by Mike Walsh FIN Thursday, February 16, 2012 9:48 AM
    Friday, October 07, 2011 10:30 AM

All replies

  • Hi,

    To give you a little bit of my understanding of you query.

    You are unable to see the document uploaded whenever you have enabled Content Approval in the Versioning Setting.

    Answer

    When you have enabled Content Approval, if you are not the user who has uploaded the document, the document has to be approved before it can be seen by others.  You will see an Approval menu on each list item when the Require Content Approval is enabled.

    Hope this helps.

    Regards

    Ranga


    Regards Ranga www.sharepointfrontier.com
    Thursday, June 30, 2011 8:18 AM
  • Thanks,

     

    But no body is able to see document.

     

     

    Thursday, June 30, 2011 6:21 PM
  • Hi,

    What permissions you have in document library?

    Thanks,

    Rahul Rashu

    Saturday, July 09, 2011 8:35 PM
  • Hi,

    I just want to ask why do you have to enable "Require content approval for submitted items" in the first place? is it really needed? 

    Ranga's answer is correct and you have to check the permissions of those who views the document library.  


    pItZy
    Thursday, August 11, 2011 11:02 AM
  • I too am noticing this.

    however I haven't enabled "content approval" - instead I have enabled "require check out before edit" ( the last setting in the versioning settings panel ).

    I have noticed that the document doesn't display in the browser.

    However if I go to Explorer View I see that the documents have been added.

    I can open the documents from within explorer view and then check them out from there.

    when I close out of the office client that I have opened the document in and go back to the browser , low and behold the document is now Visible.

    Another way to fix it is to disable "require check out" on the library and then re-enable it!

    however it defeats the purpose of being able to create a library template if one can't template the versioning settings for these libraries ?

    e.g. I want to create 1,000's of libraries using this template. Do I have to go into each individual library and modify the settings before allowing users to access it ?

    please advise.

    regards,

    Counie

     

     

    Wednesday, August 24, 2011 5:09 PM
  • Hi,

    The version setting is available in the listtemplate schema.

    http://msdn.microsoft.com/en-us/library/ms462947.aspx

    You should be able to set it through that. Or if you have already created the libraries, you can run a Powershell to set the settings you require. Let us know if you need any help on that.

    Regards

    Ranga


    Regards Ranga www.sharepointfrontier.com
    Thursday, August 25, 2011 9:41 AM
  • thanks for the reply Ranga.

    Unfortunately I am dependent on what is possible via the browser.

    The solution is to open the versioning settings GUI in each of the libraries and simply to click ok.

    Content is then visible in this library via the browser.

    Until I actually perform the above step , users will not be able to see any content ( via the browser ) in any library created from a library template.

    rgds,

    Counie


    SharePoint Farmer in training
    • Edited by Counie Friday, September 30, 2011 1:10 PM
    Wednesday, September 28, 2011 4:13 PM
  • solution was to create a library from the document library template. keep the OOTB settings. Add my custom views. then save library as template.

    create a PowerShell script that adds libraries to my site using the above template.

    Use PowerShell commands to update the advanced settings and versioning settings on the library.

    this worked satisfactorily.

    However that the OOTB functionality did not work is dissappointing.

    Regards,

    Counie

     

     


    SharePoint Farmer in training
    • Marked as answer by Mike Walsh FIN Thursday, February 16, 2012 9:48 AM
    Friday, October 07, 2011 10:30 AM
  • The library that you used to create the temple from may have had different permissions for content approval. If you don't have permissions for content approval in the library from which you created the template from, in the new library, you will not see documents until they have been approved. This is why when you disable content approval, you are able to see documents. 

    What I suggest you do is to create this library from the scratch and not from the template. Be sure you have correct permissions. Usually library inherits permissions from the site, so you need to make sure you have appropriate permissions for the site where this library is going to be. After you verified permissions, create a new library, enable content approval, and see what happens.

    Wednesday, February 15, 2012 8:24 PM