none
Cant see Exchange Server from internal network using tablets or smartphones

    Question

  • Hi guys

    I have a seemingly small problem. We are running 2 servers, both on Win Server 2012. One server is the AD, DHCP and DNS and the second server is running Exchange 2010 SP3. All servers r fully updated etc.

    Problem here is that when I setup an Exchange account for a user on their tablet or smartphone while the device is connected via the company's WiFi, the setup fails cause it can't see the mail server. For example, the mail server public name would be: mail.me.co.za. For some reason, these devices can't resolve that name from within the internal network. When u do the setup using their 3G connection, it works well. But as soon as they connect to the internal WiFi in the office, they can't get emails, cos its not connected to the Exchange server.

    Please help.

    Saturday, September 21, 2013 7:27 PM

Answers

  • That's not quite right, but I see what's wrong. You've created the record within your existing me.local domain, but you need to create a completely new domain instead.

    You've got two options really. 1) create a new zone for me.co.za, then within that create the records for mail. pointing to the local Exchange record. However the issue would be that unless you re-create all of your public records locally, for instance records for your website, you'll find your other users won't be able to reach your website or anything else that would normally be found via your public dns records.

    2) probably the better option is to create a new zone for mail.me.co.za, so lookups for that subdomain are handled locally while lookups for anything on the rest of me.ca.za are handled via the normal external dns. On Forward Lookup Zones right click and select New Zone, accept the defaults and set the Zone name to be mail.me.co.za. Check the zone and ensure that is has SOA and NS records created (by default they will be unless the DNS server config has been changed). Now add an A record with an empty name and the IP address of the local exchange server.

    Sunday, September 22, 2013 2:15 PM

All replies

  • Are those devices definitely using the internal DNS server for lookups when connected to the wireless connection? Eg, are they able to resolve local addresses, for instance either of the servers by their local DNS names?

    Assume that's the case, on your local DNS server, do you have records configured for mail.me.co.za which point to the Exchange server using its local address? If not I suspect the issue is that they're doing the lookup and one of two things is happening. 1) me.co.za is configured locally, but mail. isn't, so they're unable to resolve it, or 2) the me.co.za isn't configured locally so they're doing an internet DNS lookup, getting your public IP returned, and then since they're connected via the local network rather than over the internet they're unable to connect to the public IP address.

    You need to ensure that on your local DNS server you have an A record for mail.me.co.za configured which points to your Exchange server on the local network, for instance 192.168.0.x, which they can then connect to. That way when using the local network they'll be directed to the local address, but when connected externally via 3G, at which point they'll be using an external DNS source, they'll be directed to your public IP and able to connect to that as they do now.

    Sunday, September 22, 2013 12:10 PM
  • Hi Keith

    I think your answer is quite correct... I'm however not sure if I'm implementing it rite. I went to DNS settings, under my Forward Lookup Zone, I created an A record. When I do that thou, the FQDN defaults to: mail.me.co.za.me.local, me.local being my local domain name. me.local is already typed in the FQDN box and I can't remove it. I'm not therefore not sure if this is correct... I cant test yet, as I'm doing this remotely.

    Sunday, September 22, 2013 1:36 PM
  • That's not quite right, but I see what's wrong. You've created the record within your existing me.local domain, but you need to create a completely new domain instead.

    You've got two options really. 1) create a new zone for me.co.za, then within that create the records for mail. pointing to the local Exchange record. However the issue would be that unless you re-create all of your public records locally, for instance records for your website, you'll find your other users won't be able to reach your website or anything else that would normally be found via your public dns records.

    2) probably the better option is to create a new zone for mail.me.co.za, so lookups for that subdomain are handled locally while lookups for anything on the rest of me.ca.za are handled via the normal external dns. On Forward Lookup Zones right click and select New Zone, accept the defaults and set the Zone name to be mail.me.co.za. Check the zone and ensure that is has SOA and NS records created (by default they will be unless the DNS server config has been changed). Now add an A record with an empty name and the IP address of the local exchange server.

    Sunday, September 22, 2013 2:15 PM
  • Hi,

    I would like to check if you need further assistance.

    Thanks.


    Best Regards
    Jeremy Wu

    Wednesday, September 25, 2013 3:07 AM
    Moderator