none
Problema en entorno VDI

    Question

  • Buenas.

    He montado un entorno VDI en mi empresa para que los comerciales de las oficinas externas puedan trabajar directamente sobre nuestros servidores.
    La colección de escritorios virtuales está en modo "agrupado", es decir, se han creado a partir de una máquina virtual windows 8 enterprise (a la que apliqué un sysprep /generalize /oobe /mode:vm /shutdown) y cada usuario tiene su propia configuración guardada con un máximo de 30Gb por usuario. De esta forma, cada vez que un usuario inicia sesión, se restaura una máquina virtual al azar (a partir de una instantanea que se creó en el momento en que se hizo la colección) a la que automáticamente se le conecta un *.vhdx que contiene su configuración, perfil, etc. Cuento esto para el que no sepa como funciona este sistema.

    Mi problema es que hay programas como el Adobe Acrobat XI, o uno que usamos de gestión (hecho a medida) que no funcionan en la sesion de escritorio remoto. Sí lo hacen en la máquina virtual que usé como Master. Los usuarios están metidos dentro del grupo local Administradores mediante una GPO. Pueden hacer, deshacer, instalar y desinstalar sin problemas cualquier programa, y sin embargo el Acrobat lo tengo que arrancar en modo compatibilidad, pero solo dentro de la sesión de escritorio remoto. Como digo, en la plantilla me funciona todo bien.

    Mi programa de gestión hace algo raro también. En la plantilla saca los informes perfectamente y sin embargo, en la sesión de escritorio remoto, los campos de las tablas, en los informes, aparecen vacíos.

    Estos hechos me llevan a pensar que puede ser algo relacionado con el idioma regional del sistema, y que estos programas usan sistemas unicode distintos, ya que todas las máquinas de escritorio remoto arrancan con el idioma regional del sistema en inglés de US y no hay forma de cambiarlo, ya que para hacerlo hay que reiniciar el equipo, y esto no tiene sentido en este entorno VDI porque una vez cerrada la sesión, el host, automáticamente, restaura la instantanea y devuelve al equipo a su estado original, justo como la deja el sysprep.

    A alguien más le ha pasado algo así o se ha percatado de esto? Conocéis alguna forma de evitar que el sysprep elimine la información de la configuración regional del sistema?

    Un saludo.


    ** Si crees que esta respuesta te ha sido de utilidad, por favor, márcala como respuesta para ayudar a otros usuarios de la comunidad a encontrarla más facilmente ** ** If you think about the right utility of this answer, please, check as answer to help other users to find it easily **

    Friday, February 15, 2013 4:39 PM

Answers

  • Me respondo a mi mismo.

    Con un archivo de respuesta creado con Windows Assessment and Deployment Kit (ADK) y una imagen de Windows 8.

    Me he bajado el programa de aquí Windows ADK y usando el archivo install.wim de la carpeta Resources del DVD de Windows 8, he conseguido crear un archivo de respuesta *.xml con los datos de configuración de la instalación desatendida.

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>es-ES</InputLocale>
                <SystemLocale>es-ES</SystemLocale>
                <UILanguage>es-ES</UILanguage>
                <UILanguageFallback>es-ES</UILanguageFallback>
                <UserLocale>es-ES</UserLocale>
            </component>
            <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>MIDOMINIO.LOCAL</Domain>
                        <Password>CONTRASEÑA_ADMIN</Password>
                        <Username>USUARIO_ADMIN</Username>
                    </Credentials>
                    <JoinDomain>MIDOMINIO.LOCAL</JoinDomain>
                </Identification>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>es-ES</InputLocale>
                <SystemLocale>es-ES</SystemLocale>
                <UILanguage>es-ES</UILanguage>
                <UILanguageFallback>es-ES</UILanguageFallback>
                <UserLocale>es-ES</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <SkipMachineOOBE>false</SkipMachineOOBE>
                    <SkipUserOOBE>false</SkipUserOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>CONTRASEÑA_DE_ADMIN_LOCAL</Value>
                        <PlainText>true</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>CONTRASEÑA_DE_ADMIN_LOCAL</Value>
                                <PlainText>true</PlainText>
                            </Password>
                            <Name>USUARIO_ADMIN_LOCAL</Name>
                            <Group>Administrators</Group>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <RegisteredOrganization>MI_EMPRESA</RegisteredOrganization>
                <RegisteredOwner>MI_EMPRESA</RegisteredOwner>
                <TimeZone>Romance Standard Time</TimeZone>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:d:/windows%208%20wim/install.wim#Windows 8 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    Os pongo en negrita las variables para que las cambieis por lo que enecesiteis. Hay que guardarlo con la extensión xml.

    Para que funcione el "invento" tuve que sysprepear las máquinas otra vez con el comando sysprep.exe /generalize /oobe /shurdown /mode:vm /unattend:c:\spanish.xml habiendo copiado el archivo xml previamente en la unidad c: de la máquina virtual.

    Una vez apagada el proceso es el mismo. Se crea la nueva colección de escritorios, pero en la pregunta de si se desea usar el archivo de respuesta del sysprep o uno específico, seleccionamos también el que hemos creado. Una vez replicados los escritorios ya arrancaban con el idioma español como idioma del sistema. :D
    También he probado a volver a crear todos los escritorios virtuales sin borrar la colección, y también me funciona pero las máquinas se quedan en la ventana de configuración de Windows, dónde pregunta por la configuración rápida o personalizada, por lo que tuve que pulsar en cada una de ellas sobre el botón "configuración rápida". Igualmente también estaba en Español.

    Espero que le sirva a alguien más.

    Un saludo.


    ** Si crees que esta respuesta te ha sido de utilidad, por favor, márcala como respuesta para ayudar a otros usuarios de la comunidad a encontrarla más facilmente ** ** If you think about the right utility of this answer, please, check as answer to help other users to find it easily **

    Tuesday, February 19, 2013 8:52 AM