none
SCM v.3.0 - "Invalid data" exporting GPO backup - Domain changes to "contoso.com"

    Question

  • Hi,

    I've found that I've been unable to import on AD GPM console certain policies exported from SCM.

    Scenario is as follows: 

    * Correctly imported GPO on SCM from GPO backup

    * Modifications are made on this imported GPO on SCM and later exported to a new GPO backup

    When I try to import that backup on a newly created policy on AD GPM, the process stops giving the following error "Data is Invalid".

    Looking a bit deeper on Event Viewer I've found that this is caused because the domain of the imported policy does not match.

    ------------------------------------------

                         

    Import of backup failed. Error [The data is invalid.]. 
     Details - 
         Backup
             Directory: The data is invalid.

             Instance : C:\Policy\xxxxxx
             Comment  : {c35daadf-8944-401b-bcfe-xxxxxxxxx}

             Source GPO:
                 DisplayName: Modified_GPO
                 ID: Common Baseline
                 Domain: {96BB1CBE-E589-4397-B3B8-XXXXXXXXXXX}


    Destination GPO:
                 DisplayName: contoso.com
                 ID: New_Policy_Import
                 Domain: {8F01D014-F3F0-4267-9186-BC3E259902BA}

    Having a look on the backup.xml file I see some more contoso.com entries: </NetBIOSDomainName><DnsDomainName><![CDATA[contoso.com]]></DnsDomainName><UPN><![CDATA[Enterprise Admins@contoso.com]]

    Why is the destination GPO stamped with domain "contoso.com" instead of it's original domain name?

    Is there any way to force the source GPO Domain name?

    Thanks.



    • Edited by rllamas Wednesday, September 18, 2013 3:18 PM
    Wednesday, September 18, 2013 3:15 PM

All replies

  • Hi,

    I've the same issue because I've imported "regionalized" settings.

    In settings, I've special characters like accents (for example the group "Invités"). If I import this value, even with success, it's not possible to export/backup.

    We are waiting for correction?

    Cheers


    Jean-Luc CHANDEZON [MCT]

    Friday, September 20, 2013 10:30 PM
  • Hi Jean-Luc,

    You're right, our policies have also "regionalized" settings (in my case Spanish).

    Please, is there any expected date for this bug correction?

    SCM is a great product, but this nasty bug makes is useless.

    Regards

    Monday, September 23, 2013 8:59 PM
  • Bump. Still waiting for a bugfix from Microsoft.

    Finally we discarded the use of SCM.

    Tuesday, July 15, 2014 6:48 AM
  • hi,
    which alternative did you find,

    Regards


    Jean-Luc CHANDEZON [MCT]

    Tuesday, July 15, 2014 9:57 AM