none
Windows 8.1 Standard with Microsoft Account does not work with WSE 2012

    Question

  • I have a WSE 2012 machine with 3 users & 3 devices setup.

    My Windows 8 (Standard) Laptop with Local User connects fine.
    My Windows 8.1 (Standard) Nettop with Local User connects fine.

    But my Windows 8.1 (Standard) Laptop with a Microsoft Account does not automatically login to the Server. It worked fine when it was running Windows 8 with a Local User but unfortunately in 8.1, MS decided to force a Microsoft Account login on us if I want to continue to use Sky Drive! That would be fine, but now it wont login to their own server product...

    • I've tried adding a Windows Credential (set at Enterprise level) to the Credentials manager but it just gets forgotten on reboot.
    • If I log into the LaunchPad (which creates a temporary credential) then it works fine HOWEVER the "remember me" tick box is being ignored and the next time I restart the PC the LaunchPad is signed out again!
    • I've re-installed the connector.
    • I've removed the PC from WSE, un-installed the connector and then re-joined. (Done this twice, once as a local user and then converted to MS Account, and once as an MS Account.)

    Basically, I just don't think WSE2012 with non-Pro versions of 8.1 on a MS Account have been tested and MS need to either fix it or document it. If someone could just get the LaunchPad to remember my local login and automatically start on next reboot then it wouldn't be a problem. OR stop launch pad from deleting the manual credentials I added everytime I reboot. At the moment it's the worst of both worlds.

    Any ideas?

    Wednesday, November 13, 2013 12:20 PM

Answers

  • You are right, I figure out autologon will happen if the local account's user name and password match a domain account.

    You can try change the local account's password , and then auto logon would not work.

    Here the problem is,  launchpad doesn't use Windows Credential stored , it happens to work when your local account matchs domain account, it's not launchpad intend to do.  

    Friday, November 15, 2013 11:15 AM
  • Yes, so basically I'm stuck.

    Launchpad wont auto login because the name no longer matches the domain user AND I can't use windows credentials because LaunchPad removes them on reboot!

    Thanks Microsoft. :(

    Friday, November 15, 2013 2:16 PM

All replies

  • You can unlink the account from the microsoft account by going into the metro user settings.

    Unfortunately TechNet isn't coming back, sorry folks :-(

    Thursday, November 14, 2013 1:20 AM
  • Hi Susan,

    Thanks very much for replying, but if you re-read my post you'll see that I already know how to do that and also that I don't want to change back to a local account because I need Skydrive access. 

    Essentially as it stands, I can use Windows 8.1 with WSE but lose SkyDrive (and any other MS Account benefits) or I can use an MS Account with Windows 8.1 but lose permanent access to my server shares and client backups...

    Reading around it seems that it's perfectly possible to have an MS Account and then do one of the following:

    1. Use a Windows Credential stored for the local user to give access to the Server.
    2. Set the LaunchPad to automatically log in at start-up.
    3. If on a Domain, go into settings and Link the MS Account to your Domain Account.

    Unfortunately none of these options are working for me (3 isn't even possible with 8.1 Std).

    Thursday, November 14, 2013 10:28 AM
  • Hi Vic,

    One thing that I didn't understand is "It worked fine when it was running Windows 8", could you tell me whether that machine is standard or pro ?

    I think on a standard win8, launchpad won't try to automatically logon no matter you are using a MS account or a local account.

    Thanks

    Friday, November 15, 2013 8:37 AM
  • Autologin 100% works with Standard Editions. I have three Windows 8 Standard machines that all logged in automatically to launch pad with no problems. One of them was upgraded to 8.1 Standard and left with a local account and it still automatically logs into LaunchPad.

    The one that doesn't is the one that I upgraded to 8.1 AND switched to an MS Account. If I switch it back to a local account then Launchpad starts to autologin again.

    It's really frustrating. 

    Friday, November 15, 2013 10:08 AM
  • You are right, I figure out autologon will happen if the local account's user name and password match a domain account.

    You can try change the local account's password , and then auto logon would not work.

    Here the problem is,  launchpad doesn't use Windows Credential stored , it happens to work when your local account matchs domain account, it's not launchpad intend to do.  

    Friday, November 15, 2013 11:15 AM
  • Yes, so basically I'm stuck.

    Launchpad wont auto login because the name no longer matches the domain user AND I can't use windows credentials because LaunchPad removes them on reboot!

    Thanks Microsoft. :(

    Friday, November 15, 2013 2:16 PM
  • Hi Vic

    Have you found a solution to this? It's so annoying.

    Regards

    Paul

    Sunday, March 23, 2014 4:26 AM
  • Unfortunately not. What annoys me is that MS don't seem to have any information on this at all...

    Windows 8 Standard requires a local account to connect to WSE2012.

    Windows 8.1 stopped the support of things like Skydrive with a local account.

    Madness!

    I've stopped using MS services like Skydrive so it's their loss.

    Sunday, March 23, 2014 11:00 AM
  • I wonder if there's any way to stop lauchpad from changing the credential from Enterprise to Session. I had this issue a while back but gave up and went back to local accounts. I just bought a Vaio Pro 11 ultrabook. I'd really like to run this Windows 8.1 "Native". At the moment I've disabled the Launchpad on this device and it's working OK using a live/passport/Microsoft account.

    It is possible to get skydrive folder access on 8.1 using a local account with a little hack:

    http://www.ghacks.net/2013/11/09/access-skydrive-windows-8-1-using-local-accounts/

    Sunday, March 23, 2014 11:33 PM
  • Even more annoying. On my other PCs, where I sign in with a local account due to this issue, todays 8.1.1 update reset all the modern UI apps.  I had to enter my credentials again for each one, Mail, Music, Video etc. Syncing all the email for all my email accounts etc.

    I am really happy to use a Microsoft account but please Microsoft, stop launchpad overwriting Enterprise credentials. That's all that is required.

     
    Wednesday, April 09, 2014 4:43 AM