none
Lync - Skype Federation

    Question

  • I have enabled Lync - Skype connectivity using the Provisioning Guide for Lync -Skype Connectivity document but I am still having issues.  I can send an IM to a Skype user but they cannot reply back or initiate a message.  On the Skype side it just says messaging is unavailable beside the Lync user.  One thing that I did notice in the topology was that only Federation(5061) is enabled.  XMPP Federation is not enabled.  Does it need to be enabled?

    Carlos

    Wednesday, July 10, 2013 8:41 PM

Answers

  • It is working now. It ended up being the firewall rule for port 5061 inbound was not enabled.  Since we turned on federation after the initial install, that rule was never setup.  Everything is working well now.  Thanks for all the help and suggestions
    • Marked as answer by Carlos Adam Friday, July 12, 2013 5:00 PM
    Friday, July 12, 2013 5:00 PM

All replies

  • Hi,Carlos,

    Did you execute the following command to add Skype as a federated provider?

    New-CsPublicProvider -Identity Skype -ProxyFqdn federation.messenger.msn.com -IconUrl “https://images.edge.messenger.live.com/Messenger_16x16.png” -VerificationLevel 2 -Enabled 1

    Regards,

    Sharon


    ××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××× Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Thursday, July 11, 2013 10:02 AM
  • Hi,

    you do not need to enable the XMPP federation. use the below official provision guide. Please not that Skype users have to login to Skype using MSN ID for communication to take place. Else, Skype users will not going to be able to search for the Lync user. and even if you send an add request to a skype user, you need to send it to the MSN address. Skype users will not see that add request until they login using the MSN ID

    http://www.microsoft.com/en-us/download/details.aspx?id=39071
    Thursday, July 11, 2013 10:43 AM
  • Hi Sharon,

    I did run that when I followed the guide, and I ran a Get-CsPublicProvider just to make sure as shown.

    Get-CsPublicProvider

    Identity             : Skype
    Name                 : Skype
    ProxyFqdn            : federation.messenger.msn.com
    IconUrl              : https://images.edge.messenger.live.com/Messenger_16x16.png
    NameDecorationDomain :
    VerificationLevel    : UseSourceVerification
    Enabled              : True

    Thursday, July 11, 2013 12:58 PM
  • Yah. all looks good. did you go to pic.lync.com and specify your details for Microsoft to enable federation? it'll take usually 30 days to active.

    Thursday, July 11, 2013 1:11 PM
  • Hi Thamara,

    Thanks for the link, but I did follow that guide.  I created a test user Microsoft Account using and @outlook.com email address.  I can add this Skype user from Lync, but it just shows as "updating..." beside the user, even though I can send it messages.  From the Skype test user, I can add my Lync user email address and it says "send contact request" but I never get the message.  Both sides show offline.

    Thursday, July 11, 2013 1:12 PM
  • Yes, I did that and got an email reply telling me that the provisioning request had been completed successfully.

    Thursday, July 11, 2013 1:16 PM
  • back to the basics, have you check from control panel that the federation is enabled first and it's enabled for public providers. and when you add the skype user using @hotmail.com (@outlook.com), do you see that client shows the contact as federated external user (you'll see a small globe icon next to the user name). if not, there's some component missing in your configuration.

    • Proposed as answer by slebbon Wednesday, December 18, 2013 9:46 PM
    • Unproposed as answer by slebbon Wednesday, December 18, 2013 9:46 PM
    Thursday, July 11, 2013 11:13 PM
  • Yes, in the control panel, under Access Edge Configuration, I have enabled "Enable federation and public IM connectivity" and "Enable partner domain discovery".  Under the SIP Federated Providers the Skype Provider and Edge Server federation.messenger.msn.com is enabled.  For the Global policy, I have also enabled "Enable communications with federated users".  When I add the skypeuser@outlook.com, the client has the same icon that the internal Lync users have with no picture and it says "Updating..." below the username.

    Friday, July 12, 2013 1:39 PM
  • It is working now. It ended up being the firewall rule for port 5061 inbound was not enabled.  Since we turned on federation after the initial install, that rule was never setup.  Everything is working well now.  Thanks for all the help and suggestions
    • Marked as answer by Carlos Adam Friday, July 12, 2013 5:00 PM
    Friday, July 12, 2013 5:00 PM
  • It is working now. It ended up being the firewall rule for port 5061 inbound was not enabled.  Since we turned on federation after the initial install, that rule was never setup.  Everything is working well now.  Thanks for all the help and suggestions
    Where did you open port 5061 to?  I am having a similar issue, but turned off windows firewall on the edge servers and confirmed i can telnet to port 5061 on our public access edge name.
    Thursday, November 14, 2013 7:10 PM
  • It was between the external firewall and the edge server that we had to open port 5061.

    Monday, November 25, 2013 3:27 PM