none
Excel Web Services error attempted request on an invalid state. Unable to perform the operation

    Question

  • Hi All,

    I Have create page on sharepoint services 2010. the page contain several web part. the web part connect to performance point Services, parameter on performance point services and excel web services. i have connect the parameter to webpart PPS and the parameter was link, but i found error when i connect the parameter to excel services. the message error is

    "Attempted request on an invalid state. Unable to perform the operation"

    before i have succed to connect it on the other VM and i was drop it, below the image

     

     

    • Moved by Agnes SannieModerator Tuesday, November 29, 2011 7:04 AM Sharepoint related thread (Dari:Office Development)
    Friday, November 25, 2011 11:30 AM

Answers

  •  

    Hi Gaby,

    We did some research and the issue may be caused by the following issue:

    Warn on Refresh is enabled on the Excel Services trusted file location

    Please try to cleared the "Refresh warning enabled" check box on the trusted file location in the excel Service.

    Afterwards, please share your result in this thread.


    Agnes Sannie [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, February 23, 2012 7:42 AM
  • Halo Yudhi.Hermawan,

    Menurut error message yang anda berikan, tampaknya hal ini disebabkan oleh Excel service. Untuk mencari  penyebab dari masalah ini, silakan coba langkah di bawah ini:

     1. Publikasikan Excel yang baru ke SharePoint anda, dan periksa apakah ini bekerja atau tidak;

     2. Cobalah untuk merestart Layanan Excel anda pada server.

     

    Bila anda masih mengalami kendala, silahkan memposting kembali dalam thread ini.


    Agnes Sannie [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, December 01, 2011 9:30 AM

All replies

  • Halo Yudhi.Hermawan,

    Menurut error message yang anda berikan, tampaknya hal ini disebabkan oleh Excel service. Untuk mencari  penyebab dari masalah ini, silakan coba langkah di bawah ini:

     1. Publikasikan Excel yang baru ke SharePoint anda, dan periksa apakah ini bekerja atau tidak;

     2. Cobalah untuk merestart Layanan Excel anda pada server.

     

    Bila anda masih mengalami kendala, silahkan memposting kembali dalam thread ini.


    Agnes Sannie [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, December 01, 2011 9:30 AM
  • Hello, i have the same issue "Attempted request on an invalid state. Unable to perform this operation." doing the exact same things explained in the original post. I already tried both steps but no luck. Do you have any other option i can try?

    Thanks,

    Gaby

    Monday, February 13, 2012 9:15 PM
  •  

    Hi Gaby,

    We did some research and the issue may be caused by the following issue:

    Warn on Refresh is enabled on the Excel Services trusted file location

    Please try to cleared the "Refresh warning enabled" check box on the trusted file location in the excel Service.

    Afterwards, please share your result in this thread.


    Agnes Sannie [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, February 23, 2012 7:42 AM
  • Worked perfectly! Thanks Agnes!

    For references this is what was changed:

    Thursday, February 23, 2012 4:23 PM
  • Hi Gabriela,

    This didnt work for me. Any other thoughts ?

    I published Chart , Table , Parameter for excel sheet. Could see all are selected in Publish Options. I could see them visible as Items on top right next to View menu.

    I created a Web part page , inserted Excel Web Access , Filter webpart ( Text , Analysis services ) . Connected them to send multiple parameters but didnt work at all.

    Any other thoughts to fix this ? I really would like to fix this.

    Thanks,

    Aqueel

    Thursday, June 28, 2012 1:29 PM