none
SBS2011 RWA / unable open or download files with "+" (plus) sign

    Question

  • If there is a "+" (plus) sign is in the file name, it can't be opened or downloaded. Only a error message comes, that the specified path doses not exist.

    See? Path, not file. example: test+test.txt

    Except this, the RWA is working just fine.

    (Clients WinXP, Win7, IE8, IE9)


    SelfMan


    • Edited by SelfMan Tuesday, April 17, 2012 8:49 PM
    Tuesday, April 17, 2012 8:47 PM

Answers

  • Hi,

    I found another javascript function that might work for +!?, quote:

    • The <tt>encodeURIComponent</tt> function is an extension of encodeURI, the difference being that it also escapes the following characters: , / ? : @ & = + $

    Should work for plus(+) signs.

     

    Regards

    • Marked as answer by SelfMan Tuesday, June 26, 2012 8:43 PM
    Monday, June 25, 2012 12:03 PM

All replies

  • Tuesday, April 17, 2012 9:33 PM
  • Big thanks Susan,

    I've applied the parameter change and did a iisreset <server> /restart but the problem persists. I don't want to restart the server at the moment, but the iisreset should do the trick but does not.

    Any other suggestion?


    SelfMan

    Tuesday, April 17, 2012 9:57 PM
  • Hi SelfMan, I have tried to reproduce the issue via "Shared Folders" and "Internal Web Site - Shared Documents" on RWA, however, the file "test+test.txt" works fine on my test machine. Where did you put the plus sign file?

    Sean Zhu

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Sean Zhu

    TechNet Community Support

    Wednesday, April 18, 2012 6:16 AM
  • The file is in C:\users\public but it does not matter. I tried it in other shared folders too and the result was the same. I did the test on a different SBS2011 server with the same result. Here a screenshot of the error:
    SBS2011 RWA file download error

    I have a suspicion that it has something to do with the regional settings which are set to Slovak. At the moment I don't have a test server to play with and I don't want to mess up the production servers.

     

    SelfMan


    • Edited by SelfMan Friday, April 20, 2012 12:18 AM
    Friday, April 20, 2012 12:16 AM
  • I have changed regional and language settings to Slovak and still cannot reproduce the issue. Does the file name appear on the Shared Folder with "test␣test.txt"? (Space instead of plus)

    Sean Zhu

    TechNet Community Support

    Friday, April 20, 2012 9:20 AM
  • The file in the list appears with the + sign, but now you mentioned it I see that the error displays it as a space character. FYI It does not matter if I just click the file or check the checkbox and click download. The behavior is the same.

    I've also tried Chrome if it makes any difference. The error was the same.

    I've tried to create yet another file "test test.txt" with a space in it. Both files are displayed ok, but none will download properly (in IE). AND the IE download behavior changes. Now when I click on any of the files i get a IE download dialog with the file specifies as:
    test+test_txt&id=itnkijkleruiweohdkslmno&mode=0&dontshow=0&storagecheck=1&currentpath=%5C%5Cserver%5CPublic

    The only differences in the link between the files is the file name and the unique file id.
    The filenames are offered with _txt and not .txt. The IE cache got so broken, that even a pdf can't be downloaded.

    Chrome now downloads the "test test.txt" while clicking on "test+test.txt".

    IE is unable to save or save as, but it does open the txt file. And it does it the same way like Chrome the download.
    (opens "test test.txt instead "test+test.txt" which has been clicked on)


    SelfMan


    • Edited by SelfMan Friday, April 20, 2012 5:16 PM additional info abou opening the file
    Friday, April 20, 2012 5:08 PM
  • I've checked the solutions, but they are already applied. (its the same setting as Susan suggested.)

    Just to be recise, my clients are not using Sharepoint, its the RWA (Remote Web Access)


    SelfMan

    Tuesday, April 24, 2012 2:06 AM
  • I have also tried to reprocude the issue in an English system, but this issue doesn't occur.

    So could you please help to collect the following information:
    1. What's your SBS server system version, standard or essential?
    2. What's the region and language for your system, both the server and client?


    Thanks
    Zero

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, April 25, 2012 8:07 AM
  • Ok, so the specs are:

    1. SBS 2011 Standard English
    2. Regional Settings set to Slovak same on client computers
    3. HP ProLiant DL360G7 E5506 with 20GB RAM and HP ML110G6 X3430 with 16GB RAM
    4. Sharepoint is not used
    5. All available service packs, patches and rollups (as offered by Microsoft update) are installed
    6. MS Office is not installed on any of the systems
    7. problem is not browser related (tested IE8/9, chrome)
    8. Machine 1 - installed via migration, Machine 2 - clean new install
    9. Remote Web Access is working properly except the case of a plus character in the filename

    The reason why this happens is that the plus character is not properly urlencoded in to %2B and therefore misinterpreted as a space %20 character.


    SelfMan

    Wednesday, April 25, 2012 9:45 AM
  • For a test is it possible to change one client Regional Settings set to English U.S and check if that works?
    Wednesday, April 25, 2012 12:11 PM
  • So far, regional settings has nothing to do with it. I did the test today and the result is the same.


    SelfMan

    Wednesday, April 25, 2012 12:32 PM
  • Just curious, why you added "+" in the file name?

    Thanks
    Zero

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, April 25, 2012 12:36 PM
  • It wasn't me who added the + character. My clients use it. Mostly to identify documents in multiple languages i.e. "new proposal sk+en.docx".

    I already told the client not to use it if possible, but this is not a solution. I can't freely change thousands of file names because of references. It would be too much effort. They normally work over the network and just time to time go over RWA.

    If they need the file, it is possible to rename it (remotely) which unexpectedly works back and forth. After that then can download the file for review.


    SelfMan

    Wednesday, April 25, 2012 12:51 PM
  • I suggest that you can submit a new post to the Sharepoint forum, since this issue may be related with the Sharepoint.

    I know that you may think you haven't used Sharepoint at all, but you should know that RWA is using that, so we should troubleshoot this from Sharepoint side, since all things work well on SBS, except the file names with "+".

    Thanks.


    Thanks
    Zero

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, April 26, 2012 5:47 AM
  • Hi.

    You can find a solution here: http://social.technet.microsoft.com/Forums/en-US/smallbusinessserver/thread/b003ee44-9b07-4b22-b3a2-8caa96ded254

    Regards

    Monday, June 18, 2012 11:15 AM
  • Thanks for the hint, but I am following the thread (as you might noticed), but the suggested solution is not working with the + sign. I tried it.


    SelfMan

    Wednesday, June 20, 2012 4:01 PM
  • Hi,

    I found another javascript function that might work for +!?, quote:

    • The <tt>encodeURIComponent</tt> function is an extension of encodeURI, the difference being that it also escapes the following characters: , / ? : @ & = + $

    Should work for plus(+) signs.

     

    Regards

    • Marked as answer by SelfMan Tuesday, June 26, 2012 8:43 PM
    Monday, June 25, 2012 12:03 PM
  • Thanks to BenTjur, the problem is fixed.

    SelfMan

    Tuesday, June 26, 2012 8:43 PM