none
Remote Desktop Suddenly Stopped Scaling in Windows 7

    Question

  • Hi there,

    I've been connecting via RDP to numerous Microsoft workstations and servers using Windows 7 32 & 64-bit clients for a couple years now.

    Then yesterday I installed the latest Windows 7 64-bit updates (which included IE11) on to my workstation.

    Since I've done that suddenly and for no apparent reason none of my 'pinned' remote desktop sessions 'smart size' anymore when I connect to them and I get scroll bars whereas that never was happening before.

    I added thesmart sizing:i:1to a saved .RDP session and that solved the problem.  But now that means I'll have to do that for each and every existing as well as any new sessions and I never had to do that before.

    Also according to some help pages on the Internet people are advising if I 'right-click' onto the title bar of the remote session I will see a 'smart size' option in the resulting context menu.  Well I see 'full screen' in that menu but nothing about smart sizing or scaling.

    Again - the ONLY change has been the most recent round of Windows 7 64-bit updates.  I'm trying to use the same 'pinned' remote desktop session as before but now they're not scaling anymore.

    Please advise.

    Friday, November 15, 2013 2:11 PM

Answers

  • Hi Sam,

    Based on your latest reply it seems the issue you are experiencing is not related to smart sizing.  For that reason I would recommend you remove the smart sizing line from your Default.rdp.

    As a test, please remove the winposstr line from your Default.rdp file, save it, and then see if you are able to make a 1280x800 connection on your 1280x1024 monitor without seeing scroll bars.

    Thanks.

    -TP

    Sunday, November 17, 2013 5:34 PM
    Moderator
  • Hi TP,

    That didn't put things back either but you were completely on the right track.  I found this article about tweaking the RDP file:

    http://www.ohmancorp.com/RefRdp-RDPFile.asp

    Before attempting your latest suggestion to remove the winposstr these were the relevant values:

    desktopwidth:i:1280
    desktopheight:i:800
    winposstr:s:2,3,441,0,867,855

    After reading following the explanations in the RDP tweaking instructions this is what I now have:

    desktopwidth:i:1274
    desktopheight:i:777
    winposstr:s:0,3,0,0,1280,800

    And the issue is now correctly resolved.  The remote sessions show up as 1280x800 without scaling.

    I don't know what it was about the updates that changed how it was but as long as everyone knows they can make these changes in order to truly resolve the issue I suppose it doesn't matter at this point.

    Thanks again for the help on this it's much appreciated!


    Sam


    • Edited by HN_Support Monday, November 18, 2013 2:08 PM fixed URL link
    • Marked as answer by HN_Support Monday, November 18, 2013 2:09 PM
    Monday, November 18, 2013 2:07 PM

All replies

  • Hi,

    In your Default.rdp file (located in your Documents folder), if you add smart sizing:i:1 it will be enabled for all connections where a specific .rdp file is not used.  Smart sizing is not enabled by default.  Under Windows 8/8.1 you can enable it on the fly using the menu option.

    -TP

    • Marked as answer by HN_Support Friday, November 15, 2013 2:46 PM
    • Unmarked as answer by HN_Support Sunday, November 17, 2013 1:58 PM
    Friday, November 15, 2013 2:39 PM
    Moderator
  • Thanks you for your reply that was very helpful and worked.

    I don't know why it suddenly became necessary to make that change but the solution is acceptable enough I can let go of wondering what happened and move on.

    So thanks again for that.


    Sam

    Friday, November 15, 2013 2:45 PM
  • I had the same sudden problem since the Windows Updates this week.

    Adding smart sizing:i:1 to the .rdp solved it and restored original behaviour.

    Thanks.

    Sunday, November 17, 2013 9:40 AM
  • Actually TP you know what I'm going to have to take that back that really isn't the solution and I'll tell you why.

    Up until this change happened all my saved .RDP sessions were running on one of two 1280x1024 LCD monitors at 1280x800 resolution without any scroll bars.  So previously they fit perfectly across the horizontal axis and would fill the vertical axis about 4/5th of the way from top to bottom.

    Then this latest round of updates came along from Microsoft and - with no other apparent changes having been made - suddenly I'm having to scroll a bit in both axis to see the entire .RDP remote screens.

    Now it is true that in attempting to resolve the issue I did run into the smart sizing:i:1 function and you showed me how to use it properly so that now all .RDP sessions once again no longer have scroll bars.

    But that isn't the solution to whatever caused the problem.  It's only a workaround and I'll tell you why:

    Because BEFORE this happened that setting wasn't needed and there were no scroll bars for 1280x800 resolution .RDP client sessions on my 1280x1024 monitors.  And suddenly now not only do I need that setting to get rid of the scroll bars with the same configurations of both the remote and screen resolutions but now you can TELL they're scaled because the quality is noticeably degraded.  The fonts of the text are inconsistent in their brightness and not as clear as they used to be.  If you want to get an idea of what it's like it's looking now like if you were to run 1024x768 resolution on a 1280x1024 monitor.

    So that means it's scaling now, all right.  And that's getting rid of the scroll bars.  But it wasn't a lack of scaling that created the scroll bars in the first place.  And I know that because before the quality was just as good as all the fonts on the client computer (or an .RDP client session that is configured to 1024x768 on my 1280x1024 screens and therefore doesn't instantiate the scaling function) So this is, at best, a workaround. (And running remote sessions at 1024x768 so the quality returns is ALSO a workaround when you consider I could previously run 1280x800 resolution client sessions without scaling OR scroll bars)

    Now it's Sunday and I don't have access to my office machine but I suppose what I'll have to do this week is remove that scaling directive out of the my documents default.rdp and then roll back those recent Microsoft updates one by one until I can (hopefully) determine which one it is that causes the actual problem then I'll post it back here for your comment.  So this is just an FYI because if you yourself haven't seen the issue I see no reason you can trust me that this is a problem caused by an update unless you see the problem for yourself and obviously you haven't otherwise you'd have realized by now that your workaround is just that and it is not a solution.

    But I still appreciate your help thus far.

    So thanks,
    Sam


    Sam


    • Edited by HN_Support Sunday, November 17, 2013 2:22 PM addendum re: scroll bars
    Sunday, November 17, 2013 2:17 PM
  • But did it really restore the original behaviour?  Have you noticed any degradation of image quality in the fonts due to having to add this scaling function?  Please see my latest response to MS support in the forum where I explain that I took away marking the workaround as a solution and explaining why.

    But I'm curious if it is the same thing for you?

    Thanks,
    Sam


    Sam


    • Edited by HN_Support Sunday, November 17, 2013 2:21 PM
    Sunday, November 17, 2013 2:21 PM
  • Hi Sam,

    Based on your latest reply it seems the issue you are experiencing is not related to smart sizing.  For that reason I would recommend you remove the smart sizing line from your Default.rdp.

    As a test, please remove the winposstr line from your Default.rdp file, save it, and then see if you are able to make a 1280x800 connection on your 1280x1024 monitor without seeing scroll bars.

    Thanks.

    -TP

    Sunday, November 17, 2013 5:34 PM
    Moderator
  • Hi TP,

    That didn't put things back either but you were completely on the right track.  I found this article about tweaking the RDP file:

    http://www.ohmancorp.com/RefRdp-RDPFile.asp

    Before attempting your latest suggestion to remove the winposstr these were the relevant values:

    desktopwidth:i:1280
    desktopheight:i:800
    winposstr:s:2,3,441,0,867,855

    After reading following the explanations in the RDP tweaking instructions this is what I now have:

    desktopwidth:i:1274
    desktopheight:i:777
    winposstr:s:0,3,0,0,1280,800

    And the issue is now correctly resolved.  The remote sessions show up as 1280x800 without scaling.

    I don't know what it was about the updates that changed how it was but as long as everyone knows they can make these changes in order to truly resolve the issue I suppose it doesn't matter at this point.

    Thanks again for the help on this it's much appreciated!


    Sam


    • Edited by HN_Support Monday, November 18, 2013 2:08 PM fixed URL link
    • Marked as answer by HN_Support Monday, November 18, 2013 2:09 PM
    Monday, November 18, 2013 2:07 PM