none
Low (8 bit) color quality on Remote Desktop connection to Windows Server 2003

All replies

  • Give a try to VMware support forum. This may be VMware specific problém/setting.

    HTH

    Milos

    Saturday, October 05, 2013 8:26 PM
  • Hi,

    Which version of RDP are you using in you environment? Update to latest version.

    There are Remote Desktop Protocol setting available for Default.RDP file, you can save as the .RDP file and then try to connect with that RDP file. Refer KB 885187 for more details.

    1.  Ensure that TS box is excepting 24-bit connections.

         -  Start > Run > tscc.msc > Connections
         -  Right click “Rdp-Tcp” > properties > Client Settings
         -  Ensure that “Limit Maximum Color Depth” is set to 24-bit

    2.  Restart the Server.

    Also refer to this TechNet thread for more information.

    Hope This Helps!
    Thanks.

    Monday, October 07, 2013 6:02 AM
  • Which version of RDP are you using in you environment? Update to latest version.
    Server 2003 > tscc.msc > Connections > Type: Microsoft RDP 5.2

    There are Remote Desktop Protocol setting available for Default.RDP file, you can save as the .RDP file and then try to connect with that RDP file. Refer KB 885187 for more details.

    I've checked the client settings. Lower resolutions or connecting to 2008 R2 with the same settings give more colors.

    1.  Ensure that TS box is excepting 24-bit connections.

         -  Start > Run > tscc.msc > Connections
         -  Right click “Rdp-Tcp” > properties > Client Settings
         -  Ensure that “Limit Maximum Color Depth” is set to 24-bit

    2.  Restart the Server.

    "Limit Maximum Color Depth" is greyed out but the value seems to be 24-bit. I think that this is not the issue because with lower resolutions the colors are ok.

    Also refer to this TechNet thread for more information.

    I've read through that thread earlier and tried for example the group policy settings but the issue wasn't resolved in my case (or thread originator's case... they ended up to use lower resolution).

    Hope This Helps!
    Thanks.

    Thanks for helping!
    Monday, October 07, 2013 6:32 AM
  • Hi,

    Please upgrade your RDP Version to at least 6.0 or higher for better result. For your convenient you can download RDP 6.0 from here. Because it’s possible that due to lower RDP version it will create some issue in color quality.


    Also as stated earlier by “Milos” in his comment, might be there is issue with VMware side also. So please also try to contact VMware for further help.

    Thanks.

    Wednesday, October 09, 2013 9:40 AM
  • 8bit is default resolution for Windows 2003 terminal server. Here is knowledge base article that describes how to increase the resolution http://support.microsoft.com/kb/323353

    Hope this help you resolve the problém.

    Regards

    Milos

    Friday, October 11, 2013 12:14 PM
  • Please upgrade your RDP Version to at least 6.0 or higher for better result. For your convenient you can download RDP 6.0 from here Because it’s possible that due to lower RDP version it will create some issue in color quality.
    "RDP 6.0 from here" seems to upgrade the terminal services client but not the server and tscc.msc > Connections > Type is still "Microsoft RDP 5.2".
    Friday, October 11, 2013 12:24 PM
  • http://support.microsoft.com/kb/323353

    I've set the color depth at the client side and also checked the group policy settings at the server side... unfortunately with no results.

    I'll let you know if VMware support can resolve the issue.

    Friday, October 11, 2013 12:31 PM
  • I have read carefuly the hotfix article and found the following sentence:

    After you apply the following hotfix, the color depth of a terminal-server session that has a high resolution can be up to 16-bits.

    This may explain why you are trying 24bit level in vain.

    Regards

    Milos


    Friday, October 11, 2013 3:32 PM
  • After you apply the following hotfix, the color depth of a terminal-server session that has a high resolution can be up to 16-bits.

    This may explain why you are trying 24bit level in vain.

    I've installed the hotfix earlier but nothing changed. I also tried to choose 16-bit connection (instead of 24/32-bit) in the remote desktop client but still the resolution of 2560x1600 gives only 8-bit color depth.

    With lower resolutions I've got all the time better color depths. For example 1280x1024 gives 24-bit colors and 1920x1200 gives 16-bit colors.

    Friday, October 11, 2013 4:04 PM
  • Hi,

    Here you can try to manually create default.rdp file by using mstsc.exe. Refer this thread to maintain the height and weight parameters.

    Thanks.

    Monday, October 14, 2013 10:01 AM
  • Here you can try to manually create default.rdp file by using mstsc.exe. Refer this thread  to maintain the height and weight parameters.
    I created Default.RDP (2560x1600, 16-bit) and opened the connection with it but the issue remains. I'm pretty sure that the problem is at the server end because 2008 R2 show more colors with the same resolution and 2003 with lower resolutions.
    Monday, October 14, 2013 10:36 AM
  • Hi Haba,

    Do you experience the same issue on normal VM(2003) without VMWare ESXi5 installed?

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003735

    Hope this helpful.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. 

    Friday, October 18, 2013 10:28 AM
  • Do you experience the same issue on normal VM(2003) without VMWare ESXi5 installed?
    I have access only to Windows 2003 servers running on VMWare or Citrix. Both them seem to have the same problem.
    Sunday, October 20, 2013 9:32 AM