none
Infopath: No rule on the right panel under rule inspector...

    Question

  • Hi,

    I used to use the Rule Inspector to find out all the rules setup for different fields. My infopath is getting really huge with lots and lots of rule. When I open the Rule Inspector, most of them are empty on the right panel now. Sometimes, some fields have rule displayed on the right, but I don't think it includes everything.

    Any idea? Is it because I have too many rules? And what is the easiest way to get them all back.

    Thanks in advance. Your help would be greatly appreciated!

    Tuesday, December 17, 2013 7:51 PM

Answers

  • Hi,

    According to your description, my understanding is that the rules in the InfoPath form were not displayed in the Rule Inspector.

    As far as I know, Validation, Calculated Default Values, Actions and Programming can display in Rule Inspector, and formatting rules will not display here, so it is normal that we can't see rules in Rule Inspector if we created some formatting rules.

    http://office.microsoft.com/en-sg/infopath-help/introduction-to-rules-HA010381865.aspx#_Toc265825741

    I recommend to check if the rules which are not displayed in the Rule Inspector are formatting rules.

    For test, I recommend to create a new form and add rules to the form to see if the rules can be displayed in the Rule Inspector.

    Best regards.

    Thanks

    Victoria Xia
    TechNet Community Support

    Friday, December 27, 2013 7:56 AM

All replies

  • I've found that sometimes if you use the "Add Rule" button on the ribbon to setup a rule on fields (like people picker fields, which you can't do through the rules pane), they won't be visible in the rules pane, but will show up in the manifest.xsf.


    What that means is you can setup rules on some things that you couldn't normally, but you can't edit them once there unless you do it without using the UI (by editing the manifest.xsf directly then republishing).

    So if you were using the "Add Rule" button on the ribbon maybe that is why they aren't showing? To see if they really are there you can look in manifest.xsf, which is available by going File>Publish>Export Source Files.

    The rules are toward the bottom of the manifest.xsf file, you can open it with a text editor like notepad.

    Tuesday, December 17, 2013 8:04 PM
  • Hi,

    I didn't use the "Add Rule" in the ribbon, but I use "Manage Rules", then add the rules in the Rules panel (e.g. New Actions...). Does it has the same effect as "Add Rules"? 

    If it has the same effect, where should I add my rules so that it will show up in the UI.

    If not, any idea why that would happen?

    Thanks in advance.


    • Edited by wkpli Tuesday, December 17, 2013 8:48 PM
    Tuesday, December 17, 2013 8:41 PM
  • I've never had that behavior from using the "New" button in the "Manage Rules" pane, if you feel that you are still missing rules you may have to check the manifest.xsf for them specifically.
    Tuesday, December 17, 2013 9:00 PM
  • It is strange, I just found that out recently. As I am adding more rules more, I wonder if that was the reason.

    Thanks anyway.

    Tuesday, December 17, 2013 9:02 PM
  • My current project has about 120 rules in it (various formatting, validation or action rules) and I haven't experienced any disappearing, but I've seen other weird behavior like one whole view becoming "weird" with whole sections becoming optional no matter how many times I change them back, disappearing etc. I ended up rebuilding that view to deal with that.

    Just seems like InfoPath is subject to potential corruption because of the xml architecture, I am by no means expert enough to look at the xml and make sense of most of it.

    Tuesday, December 17, 2013 9:12 PM
  • Hi,

    According to your description, my understanding is that the rules in the InfoPath form were not displayed in the Rule Inspector.

    As far as I know, Validation, Calculated Default Values, Actions and Programming can display in Rule Inspector, and formatting rules will not display here, so it is normal that we can't see rules in Rule Inspector if we created some formatting rules.

    http://office.microsoft.com/en-sg/infopath-help/introduction-to-rules-HA010381865.aspx#_Toc265825741

    I recommend to check if the rules which are not displayed in the Rule Inspector are formatting rules.

    For test, I recommend to create a new form and add rules to the form to see if the rules can be displayed in the Rule Inspector.

    Best regards.

    Thanks

    Victoria Xia
    TechNet Community Support

    Friday, December 27, 2013 7:56 AM