none
MDT Linked Share won't replicate

    Question

  • I'm trying to created a linked deployment share to expand on a deployment server that is already in production.

    When I replicate content from the GUI I get:

    Starting MDT Linked Deployment Share Update.
    Opened the linked deployment share.
    Cannot find path 'LINKED001:\Selection Profiles\Everything' because it does not exist.

    System.Management.Automation.CmdletInvocationException: Object reference not set to an instance of an object. ---> System.NullReferenceException: Object reference not set to an instance of an object.
       at Microsoft.BDD.PSSnapIn.Utility.GetFoldersForSelectionProfile(MDTObject profile, Boolean enabledFoldersOnly)
       at Microsoft.BDD.PSSnapIn.ReplicateMDTContent.ProcessRecord()
       at System.Management.Automation.CommandProcessor.ProcessRecord()
       --- End of inner exception stack trace ---
       at System.Management.Automation.Runspaces.PipelineBase.Invoke(IEnumerable input)
       at Microsoft.BDD.Wizards.ReplicateProgress.WizardProcessing()
       at Microsoft.BDD.Wizards.WizardProgress.InitiateWizardProcessing()

    I do in fact have a Everything profile, so something is strange.  If I open the share on the remote server I have a Everything selection profile there as well.

    From powershell I get this response:

    VERBOSE: Starting MDT Linked Deployment Share Update.
    VERBOSE: Opened the linked deployment share.
    Update-MDTLinkedDS : Object reference not set to an instance of an object.
    At line:1 char:1
    + Update-MDTLinkedDS -path "DS001:\Linked Deployment Shares\LINKED001" -Verbose
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Update-MDTLinkedDS], NullReferenceException
        + FullyQualifiedErrorId : System.NullReferenceException,Microsoft.BDD.PSSnapIn.ReplicateMDTContent

    To verify it does in fact exist:

    PS C:\Users\administrator.MURPHY> dir "DS001:\Selection Profiles"

    Name
    ----
    9482-AEU
    All Drivers
    All Drivers and Packages
    All Packages
    Deployments
    Everything
    Nothing
    NUC D34010WYK
    Sample
    USB Boot

    Anyone got any ideas about what's going on?

    Monday, May 12, 2014 5:38 PM

Answers

  • Well its strange, but here's how I got it to work:

    Instead of creating the remote share with:

    \\remote\deploymentshare$\

    I used:

    \\remote\e$\deploymentshare\

    Sounds like a permissions issue, the share "DeploymentShare$" was set to allow Everyone r/w access.

    I have the permissions set to full control for Everyone on the e:\deploymentshare directory.

    Somehow the e$ UNC path works, but the hidden deploymentshare$ does not.

    • Marked as answer by KevinDTech Thursday, May 15, 2014 8:21 PM
    Thursday, May 15, 2014 8:20 PM