none
Exchange 2010 Automatically Marks Emails as Read

    Question

  • Hello.

    I have a very strange problem with emails being marked as read automatically. I checked the following:

    • Automatic mark as read settings on each client - settings are off
    • Disabled POP3 and IMAP access and restarted clients - because I knew that POP marks emails as read automatically
    • Reset the password for the mailbox - to ensure that any new clients do not connect and to invalidate current client setup
    • Tested other mailboxes - to see if the problem is Exchange wide

    None of the above showed me any clues to the problem at hand. The problem only affects one mailbox on the Exchange 2010 server. Using OWA as the client, I can see the email come in as unread but after a second it changes to read (email sent from an external web account).

    This email is used by multiple people and by some services using IMAP (I try to stay away from POP3 connections). So I will admit that diagnosing the problem is tricky and this kind of setup is hard to manage. Nevertheless I need to use this setup for this particular company.

    Can anyone give me any other suggestions that I might be able to try? Maybe there was a setting changed in Exchange that I don't know about? Any help would be appreciated.

    I am using Exchange Server 2010 and Windows Server 2008 R2 with Windows Small Business Server 2011.

    Tuesday, August 20, 2013 6:31 PM

Answers

  • Hello,

    It seems like my problem had to due with one of the IMAP clients that was in use. The way the client is setup and because the mailbox is a general use mailbox I had to setup several alias' for the login. Temporarily removing those alias' and waiting for the clients to disconnect seems to have fixed the issue (I guess even though I had disabled POP3 and IMAP the client was still authenticated and thus marking emails as read). I believe I have resolved this now.

    Thank you for the information everyone. I did not think about the PreviewMarkAsRead parameters that Mavis pointed out. There shouldn't be any mobile device accessing this mailbox, but thank you for that suggestion as well.



    Wednesday, August 21, 2013 3:12 PM

All replies

  • Have you looked in the mailbox rules table?

    get-mailbox <MAILBOX NAME> | get-inboxrule

    it does not sound like a transport rule as you said it enters the mailbox as unread, so you are definitely looking at something client related if it is not a rule

    Tuesday, August 20, 2013 6:36 PM
  • There are no rules for marking emails as read just some move rules.

    Is there any non-client specific setting I could check?

    Tuesday, August 20, 2013 7:15 PM
  • I cannot think of a setting which would set a mail as read after it is delivered from exchange other than a server side inbox rule. It could also be a client side rule on one of the outlook 

    Best way to be sure would be to turn on audit logging on the mailbox then you will be able to see who or what is changing the item to read

    http://technet.microsoft.com/en-us/library/ff459237(v=exchg.141).aspx#RTT

    http://technet.microsoft.com/en-us/library/ff522360(v=exchg.141).aspx

    Tuesday, August 20, 2013 8:20 PM
  • What about mobile devices? Does turning off ActiveSync on the mailbox help?


    --- Rich Matheisen MCSE&I, Exchange MVP

    Wednesday, August 21, 2013 2:45 AM
  • Hi,
    According to your description, I found a point “Using OWA as the client, I can see the email come in as unread but after a second it changes to read.”

    It seems like you have set the MailboxMessageConfiguration with the “PreviewMarkAsReadDelaytime” parameter.
     

    Please try to run get-mailboxmessageconfiguration cmd on EMS to verify whether the function has been set.
    And also focus on the “PreviewMarkAsReadBehavior” parameter’s value.
     

    If it is the case, please run set-mailboxmessageconfiguration cmd with “PreviewMarkAsReadBehavior” parameter as “never” value.
     

    More details in the following articles:
    Get-MailboxMessageConfiguration
    http://technet.microsoft.com/en-us/library/ee332347(v=exchg.150).aspx
    Set-MailboxMessageConfiguration
    http://technet.microsoft.com/en-us/library/dd638117(v=exchg.150).aspx
     

    Sometimes, a corrupted hidden rule also can lead this.
    If it is the case, please try to delete it with MFCMAPI Tool.
     

    BTW, do you have delegat? And did you grant permissions to another people?
     

    Hope it is helpful
     

    Thanks
    Mavis

     
    Wednesday, August 21, 2013 7:12 AM
  • Hello,

    It seems like my problem had to due with one of the IMAP clients that was in use. The way the client is setup and because the mailbox is a general use mailbox I had to setup several alias' for the login. Temporarily removing those alias' and waiting for the clients to disconnect seems to have fixed the issue (I guess even though I had disabled POP3 and IMAP the client was still authenticated and thus marking emails as read). I believe I have resolved this now.

    Thank you for the information everyone. I did not think about the PreviewMarkAsRead parameters that Mavis pointed out. There shouldn't be any mobile device accessing this mailbox, but thank you for that suggestion as well.



    Wednesday, August 21, 2013 3:12 PM