none
Remote desktop opens and then closes almost immediately

    Question

  • I am trying to remote desktop from a Windows 8 computer to another Windows 8 computer.  As soon as the RDP session starts, I can see the background image of the destination computer, but it will suddenly close with no error on screen. 

    I think a big clue is what I see in Event Viewer on the client.  There are a number of informational message and the following warning: RDPClient_SSL: An error was encountered when transitioning from TsSslStateHandshakeInProgress to TsSslStateDisconnecting in response to 8 (error code 0x80004005).

    The messages look like this:

    • Info: RDP ClientActiveX is trying to connect to the server (Cybertron)
    • Info: Server supports SSL = supported
    • Info: Base64(SHA1(UserName)) is = -
    • Warning: RDPClient_SSL: An error was encountered when transitioning from TsSslStateHandshakeInProgress to TsSslStateDisconnecting in response to 8 (error code 0x80004005).
    • The multi-transport connection has been disconnected.
    • RDP ClientActiveX has been disconnected (Reason= 263)

    Since I see the background (briefly), I think it’s safe to assume it’s not a network issue or simple misconfiguration.  I configured the client machine so I know its history.  I inherited the one I am trying to RDP into, but it was pretty close to vanilla when I got it and I’ve fully patched it.  There were a number of RDP alternatives like Logmein and PUTTY installed, so my only guess is the previous owner had the same problem as me and couldn’t fix it. 

    Neither machine is on a domain (if it matters) and I’m just using local accounts.

    There doesn’t seem to be any useful posts for the warning, so I’m just working my way through troubleshooting guides, but hoping somebody can speed up my process.

     

    Monday, June 23, 2014 4:34 PM

Answers

  • So I finally figured out my issue and have a workaround.  It’s not ideal, but it will do for now.  I found this message “The connection is not using advanced RemoteFX RemoteApp graphics” on the server side in the event viewer under RemoteDesktopServices-RdpCoreTS.  I missed it at first because the level was Information.  All I did was change the display setting on the .rdp file down to the lowest settings and it connected.  Eventually I dialed it up to 1280x1024, which seems to be the maximum the video card can take.  It actually makes a lot of sense now since the client machine is running 2560 x 1440 and the video card in the host machine isn’t even fully supported under Windows 8.  I really wish I could go full screen, but since the machine is not much more than a file server that I need to administer, this is good enough and maybe one day I’ll buy a better video card.
    • Marked as answer by Randar Puust Wednesday, June 25, 2014 2:42 AM
    Wednesday, June 25, 2014 2:42 AM

All replies

  • just working my way through troubleshooting guides, but hoping somebody can speed up my process. 

    Is that the Remote Desktop app or Remote Desktop Connection (aka mstsc.exe)?  Also, you could try TeamViewer in case it has the same problem but better diagnostics. 

    FWIW as a personal preference I would be running ProcMon to help find, correlate and supplement whatever diagnostics are being generated.  E.g. I find filtering with Operation Is WriteFile is often helpful on that tack.  But in your case even using it for its Network events might be useful too.

    Good luck



    Robert Aldwinckle
    ---

    Tuesday, June 24, 2014 3:53 AM
  • So I finally figured out my issue and have a workaround.  It’s not ideal, but it will do for now.  I found this message “The connection is not using advanced RemoteFX RemoteApp graphics” on the server side in the event viewer under RemoteDesktopServices-RdpCoreTS.  I missed it at first because the level was Information.  All I did was change the display setting on the .rdp file down to the lowest settings and it connected.  Eventually I dialed it up to 1280x1024, which seems to be the maximum the video card can take.  It actually makes a lot of sense now since the client machine is running 2560 x 1440 and the video card in the host machine isn’t even fully supported under Windows 8.  I really wish I could go full screen, but since the machine is not much more than a file server that I need to administer, this is good enough and maybe one day I’ll buy a better video card.
    • Marked as answer by Randar Puust Wednesday, June 25, 2014 2:42 AM
    Wednesday, June 25, 2014 2:42 AM
  • Hi,

    Thank you for your sharing and update.

    Best regards


    Michael Shao
    TechNet Community Support

    Wednesday, June 25, 2014 6:59 AM