none
unable to create the login

    Question

  • Hi Team,

    i have sysadmin permission on one production server,on that server i am unable to create new login, and unable to drop the logins...

    bellow picture for your references...

     

    Monday, September 16, 2013 9:00 AM

Answers

  • What worked for me is;

    Logged in under windows authentication
    1) Went to Database\Security -> Right clicked on my role -> Selected all the necessary  permissions
    2) Went to \Security ->Right clicked on my role -> Selected all the necessary permissions
    3) Restart SQL
    4) Log in using SQL authentication
    5) Repeat steps (1) & (2)


    Thanks

    Tuesday, September 17, 2013 3:14 PM

All replies

  • Well.. According to that error you don't have permission. Please make sure you have correct permission on the server or not

    vt


    Please mark answered if I've answered your question and vote for it as helpful to help other user's find a solution quicker

    Monday, September 16, 2013 9:05 AM
  • i am the owner on this server
    Monday, September 16, 2013 9:06 AM
  • The error message tells a different story ...

    Are you using the correct login?


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Monday, September 16, 2013 9:10 AM
  • Hello Olaf,

    i am the owner on this server and login is correct.

    Monday, September 16, 2013 9:16 AM
  • Hello Olaf,

    i am the owner on this server and login is correct.

    You might be the Owner of the database but not a sysadmin to create login , database owner and system admin role are completely two different things..

    vt


    Please mark answered if I've answered your question and vote for it as helpful to help other user's find a solution quicker



    Monday, September 16, 2013 9:28 AM
  • Agreed with VT, please execute this following query and confirm you have "Alter any login" or "Alter Login" permission is there. More information http://technet.microsoft.com/en-us/library/aa337562.aspx#SSMSProcedure

    SELECT * FROM fn_my_permissions(NULL, 'SERVER')ORDER BY permission_name



    Thanks ;lt;br/;gt; Manish ;lt;br/&gt; <br/> Please use <font color="#009933">Marked as Answer</font> if my post solved your problem and use <font color="#009933">Vote As Helpful </font>if a post was useful

    Monday, September 16, 2013 9:46 AM
  • i know man database owner and sysadmin is different, but here i am the sys admin and i have windows authentication account... 
    Monday, September 16, 2013 2:07 PM
  • Hi,

    Just to check that you are talking about the 'sysadmin' fixed server role in SQL Server?  Not a member of the server's local administrator group.  Any permissions you have on the server have next to no meaning in SQL Server.


    Thanks, Andrew

    Monday, September 16, 2013 3:28 PM
  • Try the below steps:

    1) Make sure that your login is SYSADMIN

    select loginname,sysadmin from sys.syslogins where name = SYSTEM_USER
    go

    Sample output

    loginname sysadmin
    ---------------------------------
    sa 1

    2) If you are using  Vista based Operating systems[Vista/Win7/Win8/Win Server 2008/R2 / Win2012] please open the management studio with ADMINISTRATOR Privilege:

    RIGHT click on the SQL Server Management Studio & select "Run as Administrator" option.

    Hope this helps. 


    Tuesday, September 17, 2013 11:49 AM
  • Try launching SSMS using "Run as Administrator".


    Dan Guzman, SQL Server MVP, http://www.dbdelta.com

    Tuesday, September 17, 2013 11:54 AM
  • Error says that you permission issues, That means u have no sysadmin...

    if u have sysadmin then there might be permission issue on windows level,i guess like u'r account must be in administrative group.


    Srikanth

    Tuesday, September 17, 2013 2:32 PM
  • What worked for me is;

    Logged in under windows authentication
    1) Went to Database\Security -> Right clicked on my role -> Selected all the necessary  permissions
    2) Went to \Security ->Right clicked on my role -> Selected all the necessary permissions
    3) Restart SQL
    4) Log in using SQL authentication
    5) Repeat steps (1) & (2)


    Thanks

    Tuesday, September 17, 2013 3:14 PM