none
Suppressing reboots in SCCM 2012

    Question

  • Need some help with suppressing reboots in SCCM 2012, when updating Acrobat. I need the user to not get a forced reboot.      Right now what is happening is the user get a 90min window to reboot, the last 15mins the nag message stays up but then a force reboot occurs. I need no reboot to occur. In my deployment/user experience i have all hide in software center and all notifications. 

    i have this for the install msiexec /p "AcrobatUpd954_all_incr.msp" /q  REBOOT=ReallySuppress Reinstallmode=omus reinstall=all

    Tuesday, February 26, 2013 6:04 PM

All replies

  • I don't really have the answer to your question, but I also push acrobat updates out and do not have a rebooting issue.  My install string looks like this.

    msiexec /p AcrobatUpd1015.msp REINSTALL=ALL REINSTALLMODE=omus /quiet

    Tuesday, February 26, 2013 6:17 PM
  • So, are you having a specific issue or are you just trying to verify the command-line that you have in your post?

    Jason | http://blog.configmgrftw.com

    Tuesday, February 26, 2013 7:13 PM
  • It is forcing a reboot after install users getting 90min windows to reboot but not allowed to force reboot machines.

    Tuesday, February 26, 2013 7:19 PM
  • OK, assuming that that is unwanted behavior, you need to reconfigure the program (if using a package/program) or the deployment type (if using an application) so that ConfigMgr does not initiate the reboot.

    Jason | http://blog.configmgrftw.com

    Tuesday, February 26, 2013 9:20 PM
  • Hi, I assume this is a similar issue to mine:

    Don't want to stop ConfigMgr initiating the reboot, just want the reboot to be more user-centric  - i.e. rather than a countdown which then results in an automatic reboot when expired, is there a way to offer a reboot now / later option - similar to the native windows update functionality.  One reason cited for this is a scenario whereby a user logs in, a software deployment or update starts running, the user then locks their machine to attend a meeting and comes back a couple of hours later to find their machine has been rebooted and all of their work lost.

    Obviously we could try and mitigate these risks by increasing the timeouts in the Computer Restart client settings, but there will always be someone in the estate somewhere that leaves a batch job running overnight for example only to find it was interupted part-way through by an SCCM reboot.

    Wednesday, February 27, 2013 2:13 PM
  • No, there is no specific way to delay ad-infinitum. User training is the best way to handle this. If you suppress restarts completely though, users will still be "nagged" to reboot if I remember correctly. Ultimately, if the system doesn't get restarted, the updates that require a restart are not applied and you may as well not even applied the updates. Another way to handle this is to enable all notifications of update deployments so that users have the ability to initiate the update install whenever is convenient for them and then reboot before the deadline. If they wait until the deadline, well, that's their own fault for waiting.

    Jason | http://blog.configmgrftw.com

    Wednesday, February 27, 2013 2:38 PM