none
Sp2007 Server not recovering from nightly IIS recycle

    Question

  • I have a SP2007 server SP2, WFE role, that for the past few nights has been going "down" after the time of the daily IIS app pool recycle.  The only way to recover is to reboot the server. IISreset does not work, its unable to start, says the server did not respond in time.  There have been no recent changes, other then standard MS OS patches being installed 2 weeks ago.

    In the eventlog I see lots of ASP.net errors, starting shortly after the nightly recycle, and then the SCOM alerts to up...

    I don't have access to the log right now, I can post it later, but its a pretty generic ASP.net exception error.

    I don't have any "scheduled" processing that I know of...

    One thing to note,

    Search indexes run overnight, and yesterday I found that all the content sources were in that "run away" status.  I had to stop them, reboot the index server, and they seemed to normalize.


    Joshua Fuente

    Wednesday, November 13, 2013 6:54 AM

All replies

  • Hi SharePointProgram,

    From the description, the issue is related to the search index server, I haven't seen the content source with status 'run away', I will involve someone familar with this topic to further look at it.

    Thanks,
    Qiao
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Qiao Wei
    TechNet Community Support

    Thursday, November 14, 2013 7:46 AM
    Moderator
  • Hi,

    It seems that there are some performance issues on the server. When the problem occurs, is the CPU/memory high?

    Please try this,

    Enlarge the paged pool.

    1. Click Start, click Run, type regedit in the Open box, and then click OK. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management.

    On the Edit menu, point to New, and then click DWORD Value. Type PoolUsageMaximum as the entry name, and then press ENTER.  Right-click PoolUsageMaximum, and then click Modify. Click Decimal. In the Value data box, type 60, and then click OK.

    Setting the value at 60 informs the Memory Manager to start the trimming process at 60 percent of PagedPoolMax rather than the default setting of 80 percent. If a threshold of 60 percent is not enough to handle spikes in activity, reduce this setting to 50 percent or 40 percent.

    2. Click Start, click Run, type regedit in the Open box, and then click OK. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management. On the Edit menu, point to New, and then click DWORD Value. Type PagedPoolSize as the entry name, and then press ENTER. Right-click PagedPoolSize, and then click Modify. Click Hexadecimal. In the Value data box, type a value of FFFFFFFF, and then click OK. Setting PagedPoolSize to 0xFFFFFFFF allocates the maximum paged pool in lieu of other resources to the computer.

    3. Quit Registry Editor.

    4. Restart the server for the changes to take effect. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, November 15, 2013 12:26 PM