none
HTTPS Port 443 Not Connected

    Question

  • Dear

    I have new server 2008 R2, I want to telnet localhost 443 which is HTTPS port but it said not connected even I enable HTTPS in IIS service and firewall off but still I can't connect, please any advice?

    Thanks

    Sunday, September 15, 2013 12:03 PM

Answers

  • In which case you need to configure a website (or use the default site) and as Mr X said go into Bindings and add an https connection in there. You have to assign an SSL certificate to it, but for the purposes of simply telneting to 443 it can simply be a local self-signed one.

    Until you have an HTTPS enabled website configured, (not just the feature enabled in IIS) IIS won't actually be listening on 443 so you won't have anything to connect to.

    An easy way to check is to open a cmd prompt on the server, and run "netstat -a". Look through the output and see if among the list of ports being listened to you see an entry containing :443. If there's no entry (for instance when there's no site with https configured in bindings) then the server isn't listening for those connections. If there is an entry then you should be able to telnet to the server on that port using that address.

    Monday, September 16, 2013 6:12 AM

All replies