none
Automating driver selection in MDT 2013

    Question

  • I have been working with MDT for a couple of months now, and I am really getting stucked on a problem. I wish to automate wich drivers to install for a spesific model. 

    we have  mostly HP machines, but also Lenovo. I have tried to set drivergroup and %make%\%model%, but cant make it right. Is there something in the CS.ini? I have no clue anymore...

    All help will be appreciated

    Monday, January 13, 2014 2:23 PM

Answers

All replies

  • Hi Espen,

    An alternative is to use selection profiles which will target drivers with the selection profile based on the result of WMI query.

    Please see the following link, which will tell you exactly what to do.

    http://adminnexus.blogspot.nl/2012/08/yet-another-approach-to-driver.html

    This is will work for sure, since it uses the result of a WMI query to pass or skip the "Inject Drivers" step. So if the following query, matches the result it will execute the injection of the drivers of this particular step:

    SELECT * FROM Win32_ComputerSystem WHERE Model LIKE "%Probook 6560b%"

    So on every machine, you need to execute the following query in a command prompt: 
    "wmic computersystem get model" the result of this query can be used as input for the WMI - Model.

    Good luck!


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Monday, January 13, 2014 7:30 PM
  • If you would like to continue the easy route and Johan Arvidmarks "total control" driver management then look here http://www.deployvista.com/Default.aspx?tabid=78&EntryID=132.

    However the solution posted by Rens is even better when computer models differ for the same model (when serial or part number is included with computer model). 

    Tuesday, January 14, 2014 7:39 AM
  • It worked perfectly, thanks a lot!
    Tuesday, January 14, 2014 9:21 AM
  • I have been working with MDT for a couple of months now, and I am really getting stucked on a problem. I wish to automate wich drivers to install for a spesific model. 

    we have  mostly HP machines, but also Lenovo. I have tried to set drivergroup and %make%\%model%, but cant make it right. Is there something in the CS.ini? I have no clue anymore...

    All help will be appreciated

    Not sure if this helps, but I had a similar issue with Dell Laptops.
    I ended up and just making %Model% folders instead, eg. "Latitude 6420" or "OptiPlex 790".

    I later realized, via "WMIC ComputerSystem Get Manufacturer" that it was named "Dell Inc.", and not just "Dell".
    I didn't test this out in my environment, but I'm pretty sure it would have worked.

    Maybe this can be relevant for others?


    Wednesday, February 12, 2014 9:12 AM