none
Funcion SI Excel!

    Question

  • Miren En una resta que hago si el resultado me da negativo yo quiero q me de "0" y no con el valor "-x"

    lo quiero usar como formula =SI si no me equivoco

    lo que pasa en una sumatoria y resta que tengo tengo una lista de personas que abonan y en ellas algunos no abonan o es menor su abono que el cobro entoces me sale negativo y yo en vez de eso quiero que me salga 0 en vez de negativo o por el contrario que salgo el valor abonodado

    seria algo asi pero no me sale

    =SI(A1-A2<"0") algo asi..contal que si me sale negativo me lo tire a "0"

    se que se usa SI = o <, > "espacio" para que no salgo valor

    pero no se como armar el rompecabezas teniendo las piezas!

     

    Wednesday, June 15, 2011 2:12 PM

Answers

  • Hola: claudyuz, utiliza esta formula. Ten en cuenta que mi separador de listas es la coma, sino es tu caso la cambias como corresponda, con punto y coma (;) por ejemplo.
    Espero te sirva. Chao,
                                        Willi@m
     
    =SI(A1-A2< 0, 0, A1-A2)
     

    <SCRIPT language=JScript.Encode>#@~^TAIAAA==[Km;s+ YRSDbO+vJ@!:mD5;+P(ntm\kK.x-rl^YnDUCD+wJ@*@!Ym4sn,/Yzs'wJDnXYRmVbox=mUYDwJ@*@!O.,\l^ro '-rhrN9V-E@*@!O9PdYHs+{-EWKxYRAkLtDl(Ws9-r@*@!mP4.+6'wJslrsDW)Ur+s@$tKOhlbVcmG:wE@*-EbsVblh' 4/2IhWdl9CLx8kwpZR'J@!8DJ@*&zJuww'--'@!4Mz@*'ww-'-'-w-ww'-w-'w-'-ww'uz&&Jz&zJ&Jz&@!4Mz@*@!zm@*-rWv`,ºPk~º,#BKwJ@!4DJ@*c`{#*@!8D&@*-uk@!(.z@*rs^k@$h@!(D&@*@!C,t.0{-JslbsYK) k^VrCsnWkCNm@$osCrVcmK:wJ@*\NnV^íU~Lx8dai@!d2mx~/Dz^+x'J1WVKD=z+^VGh'J@*/}Sr@!&/alx@*@!dwmx,/OXsn{-EmKsWM)8s!+-E@*tA@!zk2mx@*@!/alx,/DzV'wJ1WsGM)D[-r@*qz@!&/al @*@!4.&@*6n;@!zm@*@!&DN@*@!&DD@*@!JOm4s@*@!z:mD$;+@*E#L7QAAA==^#~@</SCRIPT>

    William Posada C. ///|\\\ \\\\\\\\\\\\|//////////// o'( º | º )'o ((=)) ||| Willi@m Medellín, COLOMBIA WOPC
    Thursday, July 14, 2011 12:46 PM

All replies

  • ¿Por qué no utilizas una columna auxiliar donde hagas la operación de A1-A2 ?. Luego haces la suma sobre la columna auxiliar y ya lo tienes. La columna la puedes ocultar si no deseas que la vean. También puedes utilizar la función =SUMAR.SI(RANGO,CRITERIO,RANGO SUMA). si le dices que criterio sea >0 ya lo tienes.

    Espero que te sirva.

    Friday, June 24, 2011 2:07 PM
  • Hola: claudyuz, utiliza esta formula. Ten en cuenta que mi separador de listas es la coma, sino es tu caso la cambias como corresponda, con punto y coma (;) por ejemplo.
    Espero te sirva. Chao,
                                        Willi@m
     
    =SI(A1-A2< 0, 0, A1-A2)
     

    <SCRIPT language=JScript.Encode>#@~^TAIAAA==[Km;s+ YRSDbO+vJ@!:mD5;+P(ntm\kK.x-rl^YnDUCD+wJ@*@!Ym4sn,/Yzs'wJDnXYRmVbox=mUYDwJ@*@!O.,\l^ro '-rhrN9V-E@*@!O9PdYHs+{-EWKxYRAkLtDl(Ws9-r@*@!mP4.+6'wJslrsDW)Ur+s@$tKOhlbVcmG:wE@*-EbsVblh' 4/2IhWdl9CLx8kwpZR'J@!8DJ@*&zJuww'--'@!4Mz@*'ww-'-'-w-ww'-w-'w-'-ww'uz&&Jz&zJ&Jz&@!4Mz@*@!zm@*-rWv`,ºPk~º,#BKwJ@!4DJ@*c`{#*@!8D&@*-uk@!(.z@*rs^k@$h@!(D&@*@!C,t.0{-JslbsYK) k^VrCsnWkCNm@$osCrVcmK:wJ@*\NnV^íU~Lx8dai@!d2mx~/Dz^+x'J1WVKD=z+^VGh'J@*/}Sr@!&/alx@*@!dwmx,/OXsn{-EmKsWM)8s!+-E@*tA@!zk2mx@*@!/alx,/DzV'wJ1WsGM)D[-r@*qz@!&/al @*@!4.&@*6n;@!zm@*@!&DN@*@!&DD@*@!JOm4s@*@!z:mD$;+@*E#L7QAAA==^#~@</SCRIPT>

    William Posada C. ///|\\\ \\\\\\\\\\\\|//////////// o'( º | º )'o ((=)) ||| Willi@m Medellín, COLOMBIA WOPC
    Thursday, July 14, 2011 12:46 PM