none
Old AD RMS template still displayed in OWA which were already deleted

    Question

  • Hi,

    Currently, I'm having a problem where a deleted template still can be view & select when trying to apply RMS protection. I have checked the template distribution folder & run the Get-RMSTemplate to see whether the template is presented or not (which is not) 

    

    As you can see from the picture above. I have already disabled the rms, still we can see the template. Some of the template listed above have been already deleted & some just come pop in out of no where. Please, i really need some help here. Thanks in advance

    Tuesday, April 03, 2012 9:52 AM

Answers

All replies

  • Hi there,

    Can anyone help me with this problem. I been trying to find the source of the problem but still i can't find it. 

    Thanks

    Sunday, April 08, 2012 3:28 PM
  • Hi there,

    Seems like a server side fault with the Exchange boxes which might be caching the rms templates.

    Can you double check the exchange servers DRM cache directory and possibly restart the transport service.


    Blog: http://OutOfScope.info | @ Twitter: @darthsydd | ADRMS Wiki Portal: Technet Wiki

    Saturday, April 14, 2012 7:14 AM
  • Hi there,

    Sorry for late posting as i was really busy. My question is, where can i locate the DRM cache directory? I have tried restarting the server but still unable to remove it from the list


    Wednesday, May 09, 2012 9:20 AM
  • Hi

    sorry for the late reply.

    Should be under %LocalAppData%MicrosoftDRMTemplates folder


    Blog: http://OutOfScope.info | @ Twitter: @darthsydd | ADRMS Wiki Portal: Technet Wiki

    Monday, May 14, 2012 8:09 AM
  • Did you manage to clear the cache? i have the exact issue and cannot figure out where its coming from
    Monday, March 10, 2014 5:02 PM

  • Resolved

    Get-MessageClassification

    >Set-MessageClassification -Identity "Default\ExACPrivileged" -PermissionMenuVisible $false
    • Proposed as answer by SanTal1900 Wednesday, April 02, 2014 3:32 PM
    Monday, March 10, 2014 5:46 PM
  • Depending on what version of Exchange this is, you might be able to use:

    Set-IrmConfiguraton -RefreshServerCertificates
    It sounds like this will refresh the templates as well:

    The RefreshServerCertificates switch clears all
      Rights Account Certificates (RACs), Computer Licensor Certificates (CLCs),
      and cached AD RMS templates from all Microsoft Exchange Server 2010 or
      Exchange Server 2013 servers in the organization. Clearing RACs, CLCs, and
      cached templates may be required during troubleshooting or in the event of a
      change of keys on the AD RMS cluster in your organization.

    I would be careful about actually deleting templates.  Preferably you should archive them.  If messages actually were protected with those templates and they are deleted, they will be inaccessible.

    Monday, March 10, 2014 6:36 PM
  • its not related to templates, but to classifications

    i was able to resolve it by turning off the classifications

    >Set-MessageClassification -Identity "Default\ExACPrivileged" -PermissionMenuVisible $false

    Wednesday, April 02, 2014 3:33 PM
  • Hi,

    Just been looking into the same issue myself. Turns out these are not RMS templates but 'MessageClassifications' which are there by default. They can only be seen in OWA unless you deploy it out to your Outlook clients.

    In a PS windows run >get-messageclassification and you will get the list of the default messageclassifications.

    You can hide them by running (for example):

    set-MessageClassification -Identity default\exacprivileged -PermissionMenuVisible $false

    This will hide the A/C Privileged entry, there are 5 others by default:

     DisplayName
     -----------
     A/C Privileged
     Attachment Removed
     Company Confidential
     Company Internal
     Originator Requested Alternate Recipient
     Partner Mail

    Cheers,

    Ken

    Thursday, June 19, 2014 1:35 PM