none
Getting bits Error when installing SCCM 2012 SP1 Client on Windows XP 32x running SP3

    Question

  • I have not been able to find an answer to this issue anywhere. I have seen the question asked but to no avail the question did not get answered.

    I have some XP 32x SP3 machines in our environmet where some of them that will not install the Client no matter what I do. Here is the end of the Ccmsetup.log. when trying to upgrade the bits downloaded from microsoft it will not install because the version on the system is newer.

    thanks! :-)

    Does anyone know the resolve to this?

    <![LOG[Failed to query BITS 2.5 interface with error 0x80004002]LOG]!><time="17:28:42.177+240" date="06-18-2013" component="ccmsetup" context="" type="3" thread="2488" file="util.cpp:1177">
    <![LOG[This operating system does not contain the correct version of BITS. BITS 2.5 or later is required.]LOG]!><time="17:28:42.380+240" date="06-18-2013" component="ccmsetup" context="" type="3" thread="2488" file="ccmsetup.cpp:1934">
    <![LOG[A Fallback Status Point has not been specified.  Message with STATEID='321' will not be sent.]LOG]!><time="17:28:42.380+240" date="06-18-2013" component="ccmsetup" context="" type="1" thread="2488" file="ccmsetup.cpp:9428">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\ccmsetup.exe.download]LOG]!><time="17:28:42.380+240" date="06-18-2013" component="ccmsetup" context="" type="1" thread="2488" file="ccmsetup.cpp:9156">
    <![LOG[CcmSetup failed with error code 0x80004002]LOG]!><time="17:28:42.380+240" date="06-18-2013" component="ccmsetup" context="" type="1" thread="2488" file="ccmsetup.cpp:10544">

    Tuesday, June 18, 2013 10:05 PM

All replies

  • Did you do a slipstream installation of SP3? What's the file version of %WINDIR%\system32\qmgr.dll? It should be 6.7.2600.5512 or newer.

    You can also try running:

    regsvr32.exe %WINDIR%\system32\qmgr.dll

    regsvr32.exe %WINDIR%\system32\qmgrprxy.dll

    To see if that helps any.


    Check out my Configuration Manager blog at http://aka.ms/ameltzer

    Tuesday, June 18, 2013 11:34 PM
  • The Machine is at another location and I do not know if it was slipstreamed. The machines qmgr.dll was version 6.6.2600.2180 in desperation I copied another qmgrprxy.dll/qmgr.dll that had the version 6.7.2600.5512 over to that machine and registered those dll's. But to no avail. Should I copy the qmgrprxy.dll over too then and register it? How about installing SP3 again? What is your suguestion on where to go from here.

    Registering those Dll's did not work.

    Thank you so much. :-)


    • Edited by DanielJ777 Wednesday, June 19, 2013 5:15 PM update
    Wednesday, June 19, 2013 3:23 PM
  • Anyone have any other Ideas on this issue?

    Thanks

    Wednesday, June 19, 2013 5:25 PM
  • 6.6.2600.2180 is the version associated with BITS 2.0. It's very curious that you have an XP SP3 installation with an old version of BITS. I would guess this may be due an incomplete slipstreaming XP SP3 on top of SP2.

    I'm afraid I don't have any good ideas for workarounds for this other than to reinstall SP3 if possible. 

     


    Check out my Configuration Manager blog at http://aka.ms/ameltzer

    Wednesday, June 19, 2013 11:34 PM
  • Ok. Well I appricaite your thoghts Adam. Will just have to reimage this PC to Win 7.

    Thanks,

    Daniel.

    Thursday, June 20, 2013 5:27 PM