none
Exchange 2010 on SBS 2011

    Question

  • Hi

    I have a brand new instal of SBS 2011 std (which we have had to reinstall due to many config issues on 1st attempt!!)

    my problems seems to lie with Exchange configuration-

    basically i've installed office 2010 on a pc joined to this domain and it can recieve emails ok BUT it can't send them out.

    with Internall mail it just sits in the q on exchange and with external mail - i have no idea where it goes but it doesnt even bounce back with an error

    ---

    now we have this configured to use a smart host but i think our recievers may be messed up as when i run the fix my network wizard it throws up errors about smtp connectors exchange issues which it can't repair.

    btw when i try to reinstall the "default" the "FIX" wizard removes it

    Friday, June 15, 2012 8:29 AM

Answers

  • This error also need to be corrected

    "The SMTP address template 'SMTP:%m@domain.co.uk' is invalid because it references a domain that isn't configured as an accepted domain for your organization"

    If you have created the default connector manually then ensure

    Under "Permission Groups" in the properties of the "Default Connector", you have "Exchange Servers" unchecked.
    By default these three settings should be selected under "Permission Groups": Anonymous Users, Exchange Users, Exchange Servers.

    Friday, June 15, 2012 1:42 PM
  • Can you run this command on your server, in the Exchange Shell?

    Get-AcceptedDomain

    This will show you what domains are configured as accepted.

    You can also run this command to add a send connector. You should replace 'remote.company.com' with your remote FQDN.

    This will add a Connector that routes via DNS (ie NO smart host) If you then wish to add a smart host, you can do so using the SBS Console.

    $EXServer = $env:computername
    
    
    New-SendConnector -Name "Windows SBS Internet Send $EXServer" -FQDN remote.company.com -AddressSpaces "smtp:*;1" -DNSRoutingEnabled $true -SourceTransportServers $EXServer 
    

    Can you also run..

    Get-EmailAddressPolicy

    Please post results.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 2:35 PM
    Moderator
  • Hi,

    Based on the current situation, I think you need to run the Exchange Best Practice Analyzer under the toolbox in the EMC to verify the configurations of Exchange server.

    Then towards the mail flow issue, you could run the following command in the EMS:

    Test-Mailflow <Your_Exchange_Server_FQDN> -TargetEmailAddress <The_Test_Email_Address> -Verbose

    Just like the figure below:

     

    At the same time, towards the Internet Mail flow testing, you could use the Microsoft Remote Connectivity Analyzer to verify the issue.

    Regards,
    James


    James Xiong

    TechNet Community Support

    Monday, June 18, 2012 5:58 AM
    Moderator
  • thx guys it is all working, it seems it was a firewall issue after all that!!!!!!!!!

    only thing is we can't email hotmail address, delivery report shows as delivered but it is not getting though :( !!!

    Tuesday, June 19, 2012 10:27 AM

All replies

  • Wow, sounds like you are having a lot of fun.

    Can i ask how you added the connectors?

    Did you do this manually, or did you use the wizards in the SBS Dashboard?


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 8:43 AM
    Moderator
  • i originally added thru wizards - never worked fully so i modified, still no joy, ran "FIX" it broke them, i deleted them, then manually recreated them.

    btw i am trying to re run the connect to internet wizard and it says it can't complete and i couldn't configure my email!!!!!!!!!!!!!!!!!!

    Friday, June 15, 2012 8:46 AM
  • i've now deleted ALL Receivors and senders!

    i recreated the default as per micro$oft instructions and the connect to internet wizard completed ok, i then re ran the"set up your internet address" wizard and it failed on the exchange email  !!!!!!   :( :( :(

    Friday, June 15, 2012 9:04 AM
  • i've rerun the "fix" and it's removed my default again
    Friday, June 15, 2012 10:15 AM
  • What do you mean, removed your default?

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 12:13 PM
    Moderator
  • Please upload the dpcw.log from c:\Program Files\Windows Small Business Server\logs to skydrive.
    Friday, June 15, 2012 12:51 PM
  • done  -never used it before so hoep this link works

    https://skydrive.live.com/#cid=3295FE7E2D2D005B&id=3295FE7E2D2D005B!105

    Friday, June 15, 2012 1:02 PM
  • Looks like you are doing some manual configuration in exchange?

    Have you actually got the server into a working state before you did your customisations?


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 1:32 PM
    Moderator
  • no and at the moment it won't send any mail out - we are ditching the idea of smart host and are not 100% sure the best way forward
    Friday, June 15, 2012 1:36 PM
  • A smart host will work, not using smart host means you will use DNS.

    You need a Send Connector in any case.

    Your send connector by default, would be named:

    Windows SBS Internet Send <Server Name>


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 1:41 PM
    Moderator
  • This error also need to be corrected

    "The SMTP address template 'SMTP:%m@domain.co.uk' is invalid because it references a domain that isn't configured as an accepted domain for your organization"

    If you have created the default connector manually then ensure

    Under "Permission Groups" in the properties of the "Default Connector", you have "Exchange Servers" unchecked.
    By default these three settings should be selected under "Permission Groups": Anonymous Users, Exchange Users, Exchange Servers.

    Friday, June 15, 2012 1:42 PM
  • thx, any idea how to configure send connector - as i keep reading conflicting advice

    "The SMTP address template 'SMTP:%m@domain.co.uk' is invalid because it references a domain that isn't configured as an accepted domain for your organization"  -  you've lost me there!!!!!

    Friday, June 15, 2012 1:46 PM
  • Can you run this command on your server, in the Exchange Shell?

    Get-AcceptedDomain

    This will show you what domains are configured as accepted.

    You can also run this command to add a send connector. You should replace 'remote.company.com' with your remote FQDN.

    This will add a Connector that routes via DNS (ie NO smart host) If you then wish to add a smart host, you can do so using the SBS Console.

    $EXServer = $env:computername
    
    
    New-SendConnector -Name "Windows SBS Internet Send $EXServer" -FQDN remote.company.com -AddressSpaces "smtp:*;1" -DNSRoutingEnabled $true -SourceTransportServers $EXServer 
    

    Can you also run..

    Get-EmailAddressPolicy

    Please post results.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 2:35 PM
    Moderator
  • having trouble with this throwing up errors,  should we be using "remote.domain.com" or "servername.domain.com" as there is already a send connector that uses "remote.domain.com"

    thx - i will look at answers on monday, have a nice weekend all :)

    Friday, June 15, 2012 2:57 PM
  • I dont currently have any idea what connectors you have, so i dont know the answer to that question.

    Perhaps you can just run:

    Get-SendConnector and tell us the results.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, June 15, 2012 3:06 PM
    Moderator
  • Hi,

    Based on the current situation, I think you need to run the Exchange Best Practice Analyzer under the toolbox in the EMC to verify the configurations of Exchange server.

    Then towards the mail flow issue, you could run the following command in the EMS:

    Test-Mailflow <Your_Exchange_Server_FQDN> -TargetEmailAddress <The_Test_Email_Address> -Verbose

    Just like the figure below:

     

    At the same time, towards the Internet Mail flow testing, you could use the Microsoft Remote Connectivity Analyzer to verify the issue.

    Regards,
    James


    James Xiong

    TechNet Community Support

    Monday, June 18, 2012 5:58 AM
    Moderator
  • thx guys it is all working, it seems it was a firewall issue after all that!!!!!!!!!

    only thing is we can't email hotmail address, delivery report shows as delivered but it is not getting though :( !!!

    Tuesday, June 19, 2012 10:27 AM
  • try using SMTPDIAG free download from microsoft.

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Tuesday, June 19, 2012 2:20 PM
    Moderator