none
MDT 2012 Regional Settings not applied

    Question

  • I carnt seem to get UK settings to apply on windows 7.

    Customsettings:

    KeyboardLocale=0809:00000809
    UserLocale=en-GB
    InputLocale=en-GB
    UILanguage=en-GB
    SystemLocale=en-GB

    Unattend.xml has been set to:

    <InputLocale>en-GB</InputLocale>
    < SystemLocaleen-GB</SystemLocale>
    < UILanguageen-GB</UILanguage>
    < UserLocale>en-GB</UserLocale>

    All three amd64_Microsoft-Windows-International-Core_neutral components with Windwos System image Manager.

    And i still carnt get UK settings to apply...

    As far as im aware unattend.xml is the most granular control. Customsettings should over write unattend.xml on install. and MDT role based deployments have the highest priority.

    I has a simular problem with MDT 2008 and XP:

    http://social.technet.microsoft.com/Forums/en-US/mdt/thread/134abc94-db52-4be9-bd0b-4fd836924795

    This was due to sysprep.inf having US settings and not been overwriten on install. But not sure what the issue is with windows 7.

    Monday, February 18, 2013 6:13 PM

Answers

  • Keep the same DS, Try creating a new TS as that will generate a clean unattend.xml. If that doesn't apply the regional settings right then it means that there is a database assignment applying.

    Let me know if a new TS works for now.


    Blog: http://scriptimus.wordpress.com

    Tuesday, February 19, 2013 7:53 PM
  • The machine had a DB entry. Even though no setting were present, it must have been setting defaults which are en-US.

    Thanks for your help Andrew.


    Wednesday, February 20, 2013 4:18 PM

All replies

  • Before i start with the regisrty hack and nastyness can anyone shed some light on the matter?

    Ive also tried the following post:
    http://msdn.microsoft.com/en-ie/goglobal/bb964650%28en-us%29.aspx

    with the following xml file:

    <gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend"> 

    <!--User List-->

        <gs:UserList>
        <gs:User UserID="Current"/> 
        </gs:UserList> 

    <!--User Locale-->

        <gs:UserLocale> 
        <gs:Locale Name="en-GB" SetAsCurrent="true"/> 
        </gs:UserLocale>


    <!--System locale-->

        <gs:SystemLocale>
        <gs:SystemLocale Name="en-GB"/>
        </gs:SystemLocale>

    </gs:GlobalizationServices>

    which doesnt apply any settings...

    Monday, February 18, 2013 6:55 PM
  • I don't know what the difference is between us and uk but does no of the above apply? Is it time, keyboard and the language that is still US?
    Monday, February 18, 2013 9:54 PM
  • You should remove all the changes from the unattend.xml file.

    Also remove Inputlocale and systemlocale as they are both for XP/2003.

    I've written a post for this(the settings are still the same): MDT 2010: UK Regional Settings (Windows 7/Vista)

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Tuesday, February 19, 2013 1:18 AM
  • Hi Andrew,

    I have reead your post and applied the changes. But im still not reciving the right settings.

    The problem seems be to the customsettings.ini file isnt been read. Even though when the machine boots it reads both bootstap.ini and customsettings.ini. If i change the customsettings.ini wizard screens to skip or be present and save the file i.e SkipLocaleSelection=NO. When i launch the wizard im not been prented with this screen. Or any other changes I make. Ive run DISKPART and cleaned the disk but it hasnt make a differance.


    Tuesday, February 19, 2013 1:36 PM
  • Hmm. Do you have multiple deployment shares? Are you editing the correct one?

    can you post your customsettings.ini file?

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Tuesday, February 19, 2013 1:43 PM
  • Only one deployment share. custsettings resides in conrol folder.

    cs.ini:

    [Settings]
    Priority=CSettings, CRoles, RSettings, RApps, Default
    Properties=TargetOU,WSUSGroup,DenyPolicyGroup,

    [Default]
    OSInstall=Y

    _SMSTSOrgName=company.com
    OrgName=company.com
    FullName=company.com


    KeyboardLocale=0809:00000809
    UserLocale=en-GB
    UILanguage=en-GB
    TimeZoneName=GMT Standard Time
    TimeZone=085

    WSUSServer=http://server.domain.com
    WUMU_ExcludeID001 = 50db9656-93f2-4faa-9ec4-14d8603a060d
    WUMU_ExcludeID002 = f1b1a591-bb75-4b1c-9fbd-03eedb00cc9d
    WUMU_ExcludeID003 = b1a67047-2bb9-41d6-99d0-9a8bae71af08
    WMMU_ExcludeID004 = 7a25c7ec-3798-4413-a493-57a259d18959
    WMMU_ExcludeID005 = 217f7094-edd9-4298-8cd7-bee3186e2a29

    DoNotCreateExtraPartition=YES


    DeploymentType=NEWCOMPUTER


    SkipAppsOnUpgrade=YES
    SkipApplications=NO
    SkipBitLocker=YES
    SkipCapture=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=NO
    SkipComputerName=NO
    SkipDeploymentType=NO
    SkipDomainMembership=NO
    SkipUserData=YES
    SkipLocaleSelection=NO
    SkipTimeZone=YES

    StagingOU=OU=tills,DC=domain,DC=com
    JoinDomain=domain.COM
    DomainAdmin=useranme
    DomainAdminPassword=password
    DomainAdminDomain=domain.COM
    DomainOUs1=OU=Tills,  DC=domain, DC=com
    DomainOUs2=OU=Sports World, OU=Workstations, OU=Clients, OU=SWI, DC=domain, DC=com
    DomainOUs3=OU=Sports World, OU=Store PC, OU=Clients, OU=SWI, DC=domain, DC=com
    DomainOUs4=OU=Windows 7 Laptops,OU=Clients,OU=SWI,DC=domain,DC=com
    DomainOUs5=OU=Servers, OU=SWI, DC=domain, DC=com
    DomainOUs6=OU=Windows 2008 R2 Store TS Servers, OU=Citrix, OU=SWI, DC=domain, DC=com
    DomainOUs7=OU=Test Branch Computer OU, OU=TESTOU, DC=domain, DC=com
    DomainOUs8=OU=StorePC, DC=domain, DC=com
    DomainOUs9=OU=OU=Kiosk PCs,OU=Store pc,OU=Clients,OU=SWI,DC=domain,DC=com

    SLShareDynamicLogging=\\server.domain.com\MDTLogs$\%OSDComputerName%
    DriverSelectionProfile=%MAKE%-%MODEL%-%ARCHITECTURE%
    EventService=http://server.domain.com:9800

    [MoveComputerToOU]
    WebService=http://server.domain.com/mdtwebservice/ad.asmx/MoveComputerToOU
    Parameters=OSDComputerName,TargetOU
    OSDComputerName=ComputerName
    TargetOU=OUPath

    [AddtoWSUS]
    WebService=http://server.domain.com/mdtwebservice/ad.asmx/AddComputerToGroup
    Parameters=WSUSGroup,OSDComputerName
    OSDComputerName=ComputerName
    WSUSGroup=Groupname

    [AddtoDenyPolicyGroup]
    WebService=http://server.domain.com/mdtwebservice/ad.asmx/AddComputerToGroup
    Parameters=DenyPolicyGroup,OSDComputerName
    OSDComputerName=ComputerName
    DenyPolicyGroup=Groupname

    [RemoveFromDenyPolicyGroup]
    WebService=http://server.domain.com/mdtwebservice/ad.asmx/RemoveComputerFromGroup
    Parameters=DenyPolicyGroup,OSDComputerName
    OSDComputerName=ComputerName
    DenyPolicyGroup=Groupname

    [CSettings]
    SQLServer=server.domain.com
    Database=CompanyMDT
    Netlib=DBMSSOCN
    SQLShare=REMINST
    Table=ComputerSettings
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [CRoles]
    SQLServer=server
    Database=companyMDT
    Netlib=DBMSSOCN
    SQLShare=REMINST
    Table=ComputerRoles
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [RSettings]
    SQLServer=server
    Database=companyMDT
    Netlib=DBMSSOCN
    SQLShare=REMINST
    Table=RoleSettings
    Parameters=Role

    [RApps]
    SQLServer=server
    Database=companyMDT
    Netlib=DBMSSOCN
    SQLShare=REMINST
    Table=RoleApplications
    Parameters=Role
    Order=Sequence

    Tuesday, February 19, 2013 2:12 PM
  • Looks like you have the Deployment Database configured also. There must be some settings in the DB that are interfering with your settings being applied. I suggest you go in the database and clear the troublesome assignments out.

    Incidently, did you wish to use the database also?


    Blog: http://scriptimus.wordpress.com

    Tuesday, February 19, 2013 3:39 PM
  • Hi Andrew

    Yes all our
    client OS deployment are installed automatically by populating the DB with
    roles these are XP. We then have designers who are on windows 7 and then
    servers which are 2008R2.<o:p></o:p>

    What im
    struggling with is Server 2008R2 and Windows 7. Because Ive edited my
    sysprep.inf on Xp machines and captured the target machine get deployed with
    the correct settings and captured with UK setting.<o:p></o:p>

    Know i have
    tried the same with 2008R2 with the unattend.txt with no such look. When i run
    a capture TS the setting are incorrect.

    I do have another deployment share but it’s in a complete different environment.
    I have setup another MDT deployment in the DMZ with the same customsettings.ini
    file and the same install.wim (which was copied from this deployment share)
    which work fine...



    Tuesday, February 19, 2013 4:10 PM
  • Keep the same DS, Try creating a new TS as that will generate a clean unattend.xml. If that doesn't apply the regional settings right then it means that there is a database assignment applying.

    Let me know if a new TS works for now.


    Blog: http://scriptimus.wordpress.com

    Tuesday, February 19, 2013 7:53 PM
  • The machine had a DB entry. Even though no setting were present, it must have been setting defaults which are en-US.

    Thanks for your help Andrew.


    Wednesday, February 20, 2013 4:18 PM