none
SBS 2003 - Clients Cannot connect to or see the Server

    Question

  • Hi

    Is there anyone who can help me get to grips with this.  I'm in no way a technical expert and have tried to research the problem through the internet.

    I'm running SBS 2003 (native 2000) and windows 7 professional.  It has a 1 LAN and a 1 WAN card.  A Netgear Wireless 3G Router is connected to the WAN with a 3 Mobile Dongle 15Gb capacity.  There are 2 clients running Windows 7 Professional, plugged in to a switch box with the server.  

    ISA Server Management 2004 is running.

    DHCP is enabled on SBS and disabled on the Router. Router IP address is the same as the default gateway

    Clients are obtaining IP's automatically.  SBS set a static IP.  See the following IPconfig report; 

     

    Microsoft Windows [Version 5.2.3790]

    (C) Copyright 1985-2003 Microsoft Corp.

     

    C:\Documents and Settings\CG8Admin>ipconfig /all

     

    Windows IP Configuration

     

       Host Name . . . . . . . . . . . . : SBS2003

       Primary Dns Suffix  . . . . . . . : CareerG8.local

       Node Type . . . . . . . . . . . . : Unknown

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : Yes

       DNS Suffix Search List. . . . . . : CareerG8.local

     

    Ethernet adapter LAN:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : HP NC105i PCIe Gigabit Server Adapter

       Physical Address. . . . . . . . . : 00-1E-0B-DC-06-90

       DHCP Enabled. . . . . . . . . . . : No

       IP Address. . . . . . . . . . . . : 192.168.8.2

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . :

       DNS Servers . . . . . . . . . . . : 192.168.8.2

       Primary WINS Server . . . . . . . : 192.168.8.2

     

    Ethernet adapter WAN:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet

    NIC

       Physical Address. . . . . . . . . : 00-50-BA-B7-91-0E

       DHCP Enabled. . . . . . . . . . . : No

       IP Address. . . . . . . . . . . . : 192.168.8.254

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.8.1

       DNS Servers . . . . . . . . . . . : 192.168.8.2

     

     

    THE PROBLEM

    The client computers:

    1. Cannot see the server in Network Places
    2. Cannot access the server in any way
    3. Time out when trying to ping DNS server
    4. "Destination Host Unreachable" when pinging 198.162.8.254
    5. Suggests "The default gateway is not available" after running Network Diagnostics
    6. Cannot access the internet at all

     

    The Server

    1. Can access the internet through the router
    2. Does have the Client computers set up
    3. Does issue address leases (Viewed in DHCP tree)
    4. Does have NetBios over TCP/IP enabled

     

    Other Diagnostic Information

     

     

    Microsoft Windows [Version 5.2.3790]

    (C) Copyright 1985-2003 Microsoft Corp.

     

    C:\Documents and Settings\CG8Admin>nbtstat -n

     

    LAN:

    Node IpAddress: [192.168.8.2] Scope Id: []

     

                    NetBIOS Local Name Table

     

           Name               Type         Status

        ---------------------------------------------

        SBS2003        <00>  UNIQUE      Registered

        CAREERG8       <1C>  GROUP       Registered

        CAREERG8       <00>  GROUP       Registered

        SBS2003        <20>  UNIQUE      Registered

        CAREERG8       <1B>  UNIQUE      Registered

        CAREERG8       <1E>  GROUP       Registered

        CAREERG8       <1D>  UNIQUE      Registered

        ..__MSBROWSE__.<01>  GROUP       Registered

     

    WAN:

    Node IpAddress: [192.168.8.254] Scope Id: []

     

                    NetBIOS Local Name Table

     

           Name               Type         Status

        ---------------------------------------------

        SBS2003        <00>  UNIQUE      Registered

        CAREERG8       <1C>  GROUP       Registered

        CAREERG8       <00>  GROUP       Registered

        CAREERG8       <1B>  UNIQUE      Registered

        CAREERG8       <1E>  GROUP       Registered

     

    Can you help me solve the problem?  I'd appreciate any guidance anyone has to offer.  Not sure what other information might be required from me.

     

     

    Many thanks

     

    Steve


    Steve
    Monday, September 05, 2011 3:27 PM

Answers

  • From your description it looks like you have two network ports on the server.  For SBS with ISA I think you need to use different subnets on each one.  I would probably change the router IP address to something like 192.168.9.254, then change the WAN network card to 192.168.9.2, then re-run the internet connection wizard.
    Alan Moseley
    Monday, September 05, 2011 3:56 PM
  • As both SuperGumby and Alan have mentioned. The subnets for you networks needs to be different.

    Can you also share the IP configuration of the client machine that cannot see the server?

    Monday, September 05, 2011 4:01 PM
  • NIC connecting to router using 9.254 is fine (but a bit unusual). Router address becomes default gateway.

    Subnet mask does not change.

    I only suggest the 254 is unusual because more commonly people put the router at either the bottom (.1) or top (.254) of the address space. This is just 'convention' though, you can theoretically put it anywhere you like (in the subnet).


    NOTE: I'd probably do

    Router .9.1

    SBS External .9.2 (WAN)

    Monday, September 05, 2011 4:43 PM
  • if that's a client IPconfig DHCP is giving the wrong DG. CEICW should fix it.
    Monday, September 05, 2011 4:53 PM
  • yep, change the router (to 9.whatever), ensure cable from WAN NIC goes to router, cable from LAN NIC goes to switch, run CEICW. I don't _think_ you need to make any manual changes to the NICs on SBS, wiz should do em all.

    post the ipconfig from the server after running CEICW.(so we can check)

    Monday, September 05, 2011 5:03 PM
  • NOTE: With the change in config, if there are still problems accessing the web, it may relate to ISA.

    If you run the CEICW and take the choice to 'Disable firewall' ISA is left in place but put into a very simple mode. One would then run the CEICW again, selecting 'Enable Firewall', and 'normal mode' will be re-instated.

    IF necessary. 

    Monday, September 05, 2011 5:38 PM
  • Your 'internal' and 'external' networks are in the same subnet. They should not be.

    Change the router to 192.168.x.1 where 'x' is anything but '8'.

    Change your 'external' side of SBS to 192.168.x.2, and ensure that only the SBS external NIC connects to the router.

    A separate network switch is used to connect the SBS internal side to client PC's.

    Can't find the article I was looking for, this one is a start http://technet.microsoft.com/en-us/library/cc672064(WS.10).aspx

    New setup?


    EDIT: and then you'll need to run the CEICW ('Connect to internet' task, SBS Console) mainly to adjust the ISA config.
    Monday, September 05, 2011 3:54 PM

All replies

  • Your 'internal' and 'external' networks are in the same subnet. They should not be.

    Change the router to 192.168.x.1 where 'x' is anything but '8'.

    Change your 'external' side of SBS to 192.168.x.2, and ensure that only the SBS external NIC connects to the router.

    A separate network switch is used to connect the SBS internal side to client PC's.

    Can't find the article I was looking for, this one is a start http://technet.microsoft.com/en-us/library/cc672064(WS.10).aspx

    New setup?


    EDIT: and then you'll need to run the CEICW ('Connect to internet' task, SBS Console) mainly to adjust the ISA config.
    Monday, September 05, 2011 3:54 PM
  • From your description it looks like you have two network ports on the server.  For SBS with ISA I think you need to use different subnets on each one.  I would probably change the router IP address to something like 192.168.9.254, then change the WAN network card to 192.168.9.2, then re-run the internet connection wizard.
    Alan Moseley
    Monday, September 05, 2011 3:56 PM
  • As both SuperGumby and Alan have mentioned. The subnets for you networks needs to be different.

    Can you also share the IP configuration of the client machine that cannot see the server?

    Monday, September 05, 2011 4:01 PM
  • As both SuperGumby and Alan have mentioned. The subnets for you networks needs to be different.

    Can you also share the IP configuration of the client machine that cannot see the server?

    Hi Folks

     

    Thanks for your replies.  I think I understood what you have all said.  Just to be clear;

     

     

    Ethernet adapter WAN:

       Connection-specific DNS Suffix  . :

     

         Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet 

    NIC

       Physical Address. . . . . . . . . : 00-50-BA-B7-91-0E

       DHCP Enabled. . . . . . . . . . . : No

       IP Address. . . . . . . . . . . . : 192.168.8.254 CHANGE THIS TO say 192.168.9.254 FOR EXAMPLE 

       Subnet Mask . . . . . . . . . . . : 255.255.255.0 Presumably this will change automatically?

       Default Gateway . . . . . . . . . : 192.168.8.1 DO I CHANGE THIS?

       DNS Servers . . . . . . . . . . . : 192.168.8.2

     

    • AND CHANGE THE ROUTER ADDRESS TO 192.168.9.2
    • and then run CEICW again.

     

    Forgive me for being a nuisance if I've got this wrong.  I haven't quite cemented this technology in my head.

     

    Thanks all of you for your input.

     

    Steve

     


    Steve
    Monday, September 05, 2011 4:29 PM
  • NIC connecting to router using 9.254 is fine (but a bit unusual). Router address becomes default gateway.

    Subnet mask does not change.

    I only suggest the 254 is unusual because more commonly people put the router at either the bottom (.1) or top (.254) of the address space. This is just 'convention' though, you can theoretically put it anywhere you like (in the subnet).


    NOTE: I'd probably do

    Router .9.1

    SBS External .9.2 (WAN)

    Monday, September 05, 2011 4:43 PM
  • Hi Vibha

    In short, under the LAN configuration the;

    IPv4 address is 192.168.8.17(preferred). (This is issued by DHCP on SBS)

    Subnet Mask 255.255.255.0

    Default Gateway 192.168.8.1

    DHCP Server 192.168.8.2

    DNS Servers 192.168.8.2

    Primary WINS server 192.168.8.2

    NetBios over TCP/IP enabled 

     

    Tunnel Adapter isatap.CareerG8.local

     

    Media State; disconnected

    DHCP Enabled; No

    Autoconfiguration Enabled; YES

     

    Hope this helps

     

    Thank you again

     

    Steve


    Steve
    Monday, September 05, 2011 4:45 PM
  • if that's a client IPconfig DHCP is giving the wrong DG. CEICW should fix it.
    Monday, September 05, 2011 4:53 PM
  • Yup!

    The DG for your client machines should be:   192.168.8.2;

    So two changes :

    1. Place your external network in a different subnet; (Will require changes to be made to your Router configuration as well)

    2. Change the DHCP options.

    And as SuperGumby pointed correctly, most of these changes, except for the router ofcourse will be fixed by running CEICW.

    Monday, September 05, 2011 4:57 PM
  • yep, change the router (to 9.whatever), ensure cable from WAN NIC goes to router, cable from LAN NIC goes to switch, run CEICW. I don't _think_ you need to make any manual changes to the NICs on SBS, wiz should do em all.

    post the ipconfig from the server after running CEICW.(so we can check)

    Monday, September 05, 2011 5:03 PM
  • Ok Folks...

     

    Microsoft Windows [Version 5.2.3790]

    (C) Copyright 1985-2003 Microsoft Corp.

     

    C:\Documents and Settings\CG8Admin>ipconfig /all

     

    Windows IP Configuration

     

       Host Name . . . . . . . . . . . . : SBS2003

       Primary Dns Suffix  . . . . . . . : CareerG8.local

       Node Type . . . . . . . . . . . . : Unknown

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : Yes

       DNS Suffix Search List. . . . . . : CareerG8.local

     

    Ethernet adapter LAN:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : HP NC105i PCIe Gigabit Server Adapter

       Physical Address. . . . . . . . . : 00-1E-0B-DC-06-90

       DHCP Enabled. . . . . . . . . . . : No

       IP Address. . . . . . . . . . . . : 192.168.8.2

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . :

       DNS Servers . . . . . . . . . . . : 192.168.8.2

       Primary WINS Server . . . . . . . : 192.168.8.2

     

    Ethernet adapter WAN:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet

    NIC

       Physical Address. . . . . . . . . : 00-50-BA-B7-91-0E

       DHCP Enabled. . . . . . . . . . . : No

       IP Address. . . . . . . . . . . . : 192.168.9.2

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.9.1

       DNS Servers . . . . . . . . . . . : 192.168.8.2

       NetBIOS over Tcpip. . . . . . . . : Disabled

     

    Hope I've done this correctly Teachers...

    I've also run CEICW successfully.

    I'm now going to uninstall the Network card on the client and reboot it to see if it picks up the new IP's and can see the server in Network places.

    Ooops... before I do that.... bingo! Client can see the server...

    Thanks

     

    Steve

     


    Steve
    Monday, September 05, 2011 5:21 PM
  • Great Scott!! Good to hear!
    Monday, September 05, 2011 5:26 PM
  • yep, server IPConfig looks good. With the client NIC already set to DHCP uninstalling the NIC (or even changing its config) should not have been necessary, as you confirm.

    With ISA in the mix you may not yet have internet access from the clients. The 'ISA firewall client' should be installed on the PCs, it's in a share on the server \\sbs\mspclient (the msp is a hangove from the dreaded MS Poxy).

    For good measure you could fire through the client IPConfig, but it doesn't sound like we need to check it.

    Happy SBSing.

    Still curious if this is a new install. SBS03 is getting a bit tired, due for 'end of life' shortly, and should you move to a more recent version of SBS you will need to change to single NIC config.

    Monday, September 05, 2011 5:27 PM
  • Yes Scott is truly great.... who ever he is... Vibha, Alan, Supergumby... lol

     

    Only thing left is for the client to be able to view web pages, which it can't do at the moment.

     

    The server can still get out to the net... not the clients

     

    You guys are the best! I admire you and your knowledge.

     

    Thank you.


    Steve
    Monday, September 05, 2011 5:29 PM
  • Only thing left is for the client to be able to view web pages, which it can't do at the moment.


    Steve


    for web pages only you don't need the ISA Firewall Client (FWC), you can manually set the proxy in the browser.

    ISA on SBS defaults to the web proxy being available on server_name:8080

    The FWC will allow other programs access through ISA.

    Monday, September 05, 2011 5:35 PM
  • NOTE: With the change in config, if there are still problems accessing the web, it may relate to ISA.

    If you run the CEICW and take the choice to 'Disable firewall' ISA is left in place but put into a very simple mode. One would then run the CEICW again, selecting 'Enable Firewall', and 'normal mode' will be re-instated.

    IF necessary. 

    Monday, September 05, 2011 5:38 PM
  • Yes I recently bought the server.

    I didn't uninstall the client NIC in the end.

    I'll set up Firewall client and hopefully this will fix that issue.

    When I've done that I'll post the result.

    Once again, thank you. 

     


    Steve
    Monday, September 05, 2011 5:51 PM
  • Hi SuperGumby

    I ran that routine and it also worked.  However, I've decided to allow windows firewall on the clients.

     

    Once again many thanks for your expertise.

    Steve


    Steve
    Monday, September 05, 2011 6:22 PM