none
Possible DNS issue setting up web app and first site collection

    Question

  • I'm setting up SP 2013 server on a home network with two window servers 2k12.   One runs AD and DNS, the other one is for SharePoint.    I'm reading a book on SP 2k13 administration (most of my experience is with 07 and 10) and i'm trying to set up a web app for mysites and one for a regular teamsites.       I'm following the steps in the book, but it's not working because I think the book assumes i'm a DNS expert.  (i'm not)   

    Here's what I have:    MySites web app created on port 80 with host header my.serversp1      On the Manage Web Apps page it lists  name = SharePoint - Mysites     URL = http://my.serversp1/    and port = 80

    In IIS on the SP server under Site Bindings  IP Address is All Unassigned    Port = 80   and Host Name is  my.serversp1

    And on the AD server under the DNS settings     Serverad1 is the server.    Forward Lookup Zones   Anne.local is the domain  (the sp server and my desktop are both members of the domain)     There is a folder called SERVERSP1 which I believe is a Zone that I created.    Inside the folder there is an item (same as parent folder) that is a Host (A) and it points to 192.168.1.24 which is the sharepoint server.    There is also an item  *  that is also an A record with the same IP address.

    When I try to navigate to  http://my.serversp1/    I get:   Oops! Internet Explorer could not find my.serversp1     When I turn on Fiddler, I get this:  The requested name is valid, but no data of the requested type was not found     

    One more thing, the book suggested I add a line to the host file.    127.0.0.1  my.serversp1

    AAM are as follows     Internal URL = http://my.serversp1    Zone = Default     PUblic URL for Zone = http://my.serversp1

    Any idea what i'm missing?    I've been playing with this for hours and i'm no where closer to figuring it out.

    Thanks for any help.

    Thursday, September 26, 2013 2:58 PM

Answers

All replies

  • Use the FQDN of your local domain in the AAM and in the host header in IIS.
    Thursday, September 26, 2013 3:29 PM
  • Thanks for the quick reply.    I changed the AAM to  http://my.serversp1.anne.local      and the same thing with the host header binding in IIS.     However, when I go to  http://my.serversp1.anne.local/default.aspx     I get an error message:  Sorry, something went wrong  Could not load user profile.  

    Is there a way to get this to work without adding the "anne.local" part to the URL?    The address for CA is  http://serversp1:33333/default.aspx     and works fine without any changes in AAM, IIS  or DNS settings.     I'd like the URL http://my.serversp1   to work.   

    Any idea how to set this up?

    Thursday, September 26, 2013 4:05 PM
  • Hi Fisk,

    You should be able to access the http://my.serversp1 directly on your SharePoint server.

    On you DNS, you need to add another (A) Host with the URL as my.serversp1.

    Now you will be able to access the url from another machine.

    You might have to flush the DNS on your local machine with ipconfig /flushdns.


    Daniel Christian (MCTS)

    Thursday, September 26, 2013 5:05 PM
  • Dan, thanks for the reply, but I've already got that and it's still not working.    Here is a screen shot of the DNS manager.    Anne.local is the domain.  


    • Edited by fisk Thursday, September 26, 2013 5:19 PM
    Thursday, September 26, 2013 5:13 PM
  • So DNS works in a recursive fashion and its kinda fun to read about

    http://www.windowsnetworking.com/articles-tutorials/netgeneral/Understanding-DNS-Recursion.html

    but the quick answer is that having an AD DNS server on the domain anne.local affecting DNS queries for http://my.serversp1 is tough, by default the AD DNS server only wants to field requests for *.anne.local.

    The error page that you are receiving at http://my.serversp1.anne.local/default.aspx is probably good news, you're having problems with your user profile service while loading the SharePoint page. Can you recreate the error and then run to the ULS logs and see what the real problem is?


    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    Thursday, September 26, 2013 5:14 PM
  • Try setting it up under the Anne.Local folder and for the name type in my.serversp1.

    Daniel Christian (MCTS)

    Thursday, September 26, 2013 5:21 PM
  • I set up a New Host (A) by right clicking on the Anne.Local folder.    I added  my.serversp1 as the name and that was how the folder named SERVERSP1 was created.   inside that folder is the item "My" that points to the sp server IP address.  

    That's what's so frustrating about this.   From what little I know about networking and DNS, this should work.  

    I think the problem is partially solved.   When I go to   http://my.serversp1.anne.local/default.aspx      That's when I get the error message: Sorry, something went wrong  Could not load user profile.     This message I believe comes from SharePoint so it looks like it's resolving.    However, i'd like to have this work without anne.local in the URL.   

     

    Thursday, September 26, 2013 5:35 PM
  • DNS looks fine from the screenshot, make sure the IIS bindings and AAM match the url you posted above. If you want to use it without the FQDN, your setup should work. post the screenshot of IIS and the AAM if you're still in a bind. 
    Thursday, September 26, 2013 6:22 PM
  • Thursday, September 26, 2013 6:52 PM
  • We're you able to resolve the MySites via FQDN, with the settings above?
    Thursday, September 26, 2013 6:59 PM
  • I created a second web app called Portal and set it up the same way    portal.spserver1.anne.local  and used the teamsites template.   It's working now.   That means I have two issues now:

    1.   my.serversp1.anne.local still doesn't work.   I'm getting the link appears to be broken message.    Which is really disappointing since I was getting a different message an hour ago.    I don't know what changed, but i'll try to find it.

    2.  I would still like to find a way to set this up so that I don't need the "Anne.local" in the URL.     It has to be a setting somewhere......

    Thanks for any ideas....

    Thursday, September 26, 2013 7:49 PM
  • Ok, I've got both of them working now as long as I include "Anne.local" in the URL.     Any thoughts on how to change that?   
    Thursday, September 26, 2013 8:17 PM
  • https://skydrive.live.com/?cid=8BBD36B397051333&id=8BBD36B397051333%21171#cid=8BBD36B397051333&id=8BBD36B397051333%21227&v=3

    In this video I show you how to configure DNS to have any host name you want ping to whatever you want.


    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    Thursday, September 26, 2013 10:37 PM