none
unable to launch reportbuilder application from .net app

    Question

  • Hi

    we are having this weird problem launching reportbuilder application from our .net app. 

    error is  "cannot download the application. The application is missing required files. contact application vendor for support"

    its on windows server 2012 and sql server 2008 r2.

    interestingly i can open RB from IE with no problems but opening with webbrowser control in .net app (.net 3.5) results in error below..

    BTW i found another similar thread but none of the solutions worked. AND i logged in as administrator when error occured so cant be security issue.

    WebBrowser wb = new WebBrowser();
    wb.Navigate("http://myserver/reportserver/reportbuilder/reportbuilder.application");

    Thanks for the advise.

    PLATFORM VERSION INFO
                    Windows                                             : 6.2.9200.0 (Win32NT)
                    Common Language Runtime       : 4.0.30319.18046
                    System.Deployment.dll                                : 4.0.30319.17929 built by: FX45RTMREL
                    clr.dll                                     : 4.0.30319.18046 built by: FX45RTMGDR
                    dfdll.dll                                                 : 4.0.30319.17929 built by: FX45RTMREL
                    dfshim.dll                                            : 4.0.41209.0 (Main.041209-0000)
    
    SOURCES
                    Deployment url                                                : file:///C:/Users/administrator.MEDISN/AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files/Content.IE5/EON90CFN/reportbuilder%5B1%5D.application
    
    IDENTITIES
                    Deployment Identity                      : ReportBuilder.application, Version=10.50.4000.0, Culture=neutral, PublicKeyToken=c3bce3770c238a49, processorArchitecture=msil
    
    APPLICATION SUMMARY
                    * Online only application.
                    * Trust url parameter is set.
    ERROR SUMMARY
                    Below is a summary of the errors, details of these errors are listed later in the log.
                    * Activation of C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\reportbuilder[1].application resulted in exception. Following failure messages were detected:
                                    + Downloading file:///C:/Users/administrator.MEDISN/AppData/Local/Microsoft/Windows/Temporary Internet Files/Content.IE5/EON90CFN/ReportBuilder.exe.manifest did not succeed.
                                    + Could not find file 'C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\ReportBuilder.exe.manifest'.
                                    + Could not find file 'C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\ReportBuilder.exe.manifest'.
                                    + Could not find file 'C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\ReportBuilder.exe.manifest'.
    
    COMPONENT STORE TRANSACTION FAILURE SUMMARY
                    No transaction error was detected.
    
    WARNINGS
                    There were no warnings during this operation.
    
    OPERATION PROGRESS STATUS
                    * [9/07/2013 11:31:12 AM] : Activation of C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\reportbuilder[1].application has started.
                    * [9/07/2013 11:31:12 AM] : Processing of deployment manifest has successfully completed.
                    * [9/07/2013 11:31:12 AM] : Installation of the application has started.
    
    ERROR DETAILS
                    Following errors were detected during this operation.
                    * [9/07/2013 11:31:12 AM] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
                                    - Downloading file:///C:/Users/administrator.MEDISN/AppData/Local/Microsoft/Windows/Temporary Internet Files/Content.IE5/EON90CFN/ReportBuilder.exe.manifest did not succeed.
                                    - Source: System.Deployment
                                    - Stack trace:
                                                    at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
                                                    at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
                                                    at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
                                                    at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
                                                    at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
                                                    at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, Uri& appSourceUri, String& appManifestPath)
                                                    at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
                                                    at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
                                                    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
                                                    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
                                    --- Inner Exception ---
                                    System.Net.WebException
                                    - Could not find file 'C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\ReportBuilder.exe.manifest'.
                                    - Source: System
                                    - Stack trace:
                                                    at System.Net.FileWebRequest.EndGetResponse(IAsyncResult asyncResult)
                                                    at System.Net.FileWebRequest.GetResponse()
                                                    at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
                                    --- Inner Exception ---
                                    System.Net.WebException
                                    - Could not find file 'C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\ReportBuilder.exe.manifest'.
                                    - Source: System
                                    - Stack trace:
                                                    at System.Net.FileWebResponse..ctor(FileWebRequest request, Uri uri, FileAccess access, Boolean asyncHint)
                                                    at System.Net.FileWebRequest.GetResponseCallback(Object state)
                                    --- Inner Exception ---
                                    System.IO.FileNotFoundException
                                    - Could not find file 'C:\Users\administrator.MEDISN\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\EON90CFN\ReportBuilder.exe.manifest'.
                                    - Source: mscorlib
                                    - Stack trace:
                                                    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
                                                    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
                                                    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
                                                    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean useAsync)
                                                    at System.Net.FileWebStream..ctor(FileWebRequest request, String path, FileMode mode, FileAccess access, FileShare sharing, Int32 length, Boolean async)
                                                    at System.Net.FileWebResponse..ctor(FileWebRequest request, Uri uri, FileAccess access, Boolean asyncHint)
    
    COMPONENT STORE TRANSACTION DETAILS
                    No transaction information is available.


    prk


    • Edited by prk Wednesday, July 10, 2013 12:06 AM more details added
    Tuesday, July 09, 2013 9:09 PM

Answers

  • surprise ! after I am testing more on this ,following resolved the issue !!! which i don't understand , do you ?

    see the 2nd parameter (opens new window)

    WebBrowser wb = new WebBrowser();
    wb.Navigate("http://myserver/reportserver/reportbuilder/reportbuilder.application",true);

    we've same code (my code from OP) on many servers with no issues why windows server 2012 any different !!!?


    prk

    Wednesday, July 10, 2013 11:25 PM

All replies

  • Hi Prk,

    The issue might be a proxy authentication issue. Please check the <system.net> section of the web.config file of your custom Web application as well as your IE proxy settings. If your Internet Explore use proxy (assuming http://192.168.1.10:8080), then you can modify the <system.net> section of the Web.config file as follows:

    <system.net>
        <defaultProxy>
          <proxy
            usesystemdefault="true"
            proxyaddress="http://192.168.1.10:8080"
            bypassonlocal="true"
          />
        </defaultProxy>
    </system.net>

    If your IE doesn’t use proxy, you can modify the <system.net> section of the Web.config file as follows:

    <system.net>
        <defaultProxy>
          <proxy usesystemdefault="true"/>
        </defaultProxy>
    </system.net>

    Hope this helps.

    Regards,
    Mike Yin

    If you have any feedback on our support, please click here


    Mike Yin
    TechNet Community Support

    Wednesday, July 10, 2013 8:32 AM
    Moderator
  • Hello Mike

    This site does not use any proxy. I tried your 2nd suggestion but no joy. still exactly same error as before. any other suggestions ?

    we tried one another server (same windows server 2012) and exactly same issue !

    Please note every time we tried we logged in as administrator .

    Note, ours is windows application ( .net framework 3.5)


    prk

    Wednesday, July 10, 2013 10:01 PM
  • surprise ! after I am testing more on this ,following resolved the issue !!! which i don't understand , do you ?

    see the 2nd parameter (opens new window)

    WebBrowser wb = new WebBrowser();
    wb.Navigate("http://myserver/reportserver/reportbuilder/reportbuilder.application",true);

    we've same code (my code from OP) on many servers with no issues why windows server 2012 any different !!!?


    prk

    Wednesday, July 10, 2013 11:25 PM
  • Hi Prk,

    Thanks for your posting.

    Glad to hear that you have resolved the issue by yourself. Regarding the solution, I am not clear why adding True parameter resolves the issue.

    Regards,
    Mike Yin

    If you have any feedback on our support, please click here


    Mike Yin
    TechNet Community Support

    Thursday, July 11, 2013 7:38 AM
    Moderator