none
The 'CC' filed in the Feedback Process Workflow is not sending mails

    Question

  • Hi,

    I have created a workflow in Sharepoint Designer 2010 and used the action 'Start Feedback Process'. When i run the workflow and put some email ID's in the cc field and start the workflow and later i observe that the mail is not being sent to people in the 'CC' field but it is being sent to email id's in 'To' field. How to overcome this trouble?

    Regards,

    Krishna


    Regards, Krishna

    Wednesday, April 04, 2012 6:36 AM

Answers

  • Hi krishna,

    Please see the following image, I add user1 in participants field and user2 in CC field.

    By default, the Feedback workflow will send 2 emails.

    1. Send Tasks - Please review a list item email. (To: user1, CC: no one)
    2. Collect Feedback started on a list item email. (To: user who started the workflow, CC: user2)

    So as you descripted, if user2 started the workflow, he/she will receive the second email which both To and CC is user2.

    If above can't solve your problem, please click the Feedback task to edit the task > Change the behavior of the overall task process link.

    Then kindly check if it is Task Process:CC Users in CC option.

    Best regards,
    Emir


    Emir Liu

    TechNet Community Support

    Thursday, April 05, 2012 8:08 AM
  • Hi Krishna,

    Please go to overall task process, and edit the email notification, replace Task Process:CC User with Parameter:CC follow this step:

    Note: Please select the "Display Name" as the field return type in step 6.

    Best regards,
    Emir


    Emir Liu

    TechNet Community Support


    Friday, April 06, 2012 6:57 AM

All replies

  • Hi krishna,

    Please see the following image, I add user1 in participants field and user2 in CC field.

    By default, the Feedback workflow will send 2 emails.

    1. Send Tasks - Please review a list item email. (To: user1, CC: no one)
    2. Collect Feedback started on a list item email. (To: user who started the workflow, CC: user2)

    So as you descripted, if user2 started the workflow, he/she will receive the second email which both To and CC is user2.

    If above can't solve your problem, please click the Feedback task to edit the task > Change the behavior of the overall task process link.

    Then kindly check if it is Task Process:CC Users in CC option.

    Best regards,
    Emir


    Emir Liu

    TechNet Community Support

    Thursday, April 05, 2012 8:08 AM
  • Hi Emir,

    I added the 'Start Feedback Process' action

    When i click on the "Parameter: To" we get the below screen.

    I am using 'To' and 'CC' as Initiation form parameters in my workflow.

    The email ID's entered in the CC filed are not sending mails.

    Regards,

    Krishna


    Regards, Krishna

    Thursday, April 05, 2012 3:08 PM
  • Hi Krishna,

    Please go to overall task process, and edit the email notification, replace Task Process:CC User with Parameter:CC follow this step:

    Note: Please select the "Display Name" as the field return type in step 6.

    Best regards,
    Emir


    Emir Liu

    TechNet Community Support


    Friday, April 06, 2012 6:57 AM
  • Emir Liu,

    I appreciate your hard work in giving replies with screenshots and markings, will apply the solutions suggested by you and get back.

    Regards,

    Krishna


    Regards, Krishna

    Friday, April 06, 2012 7:42 AM
  • Thanks,

    It worked.


    Regards, Krishna

    Monday, April 16, 2012 4:05 AM
  • For anyone else who has a similar problem. I tried Emirs answer which did not work in my circumstance

    What fixed it was when i changed the "Display Name Field"to Email Address

    Thursday, October 17, 2013 1:21 AM