none
Problema para ver archivos ocultos

    Question

  • Buenas,

    Tengo un problema desde hace tiempo un tanto extraño con los archivos ocultos. Yo tengo habilitada la opción para poder ver los archivos ocultos y de sistema, pero no puedo verlos desde el explorador. Tengo windows XP home edition con kasperksy internet security 7 actualizado. Le he pasado el antivirus y no tengo ningún virus. He hecho una limpieza de temporales y de registro con el ccleaner y no ha solucionado nada.

    Buscando información por internet encontré esto:

    1. Para ser mas exacto, dentro de HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Explorer\Advanced\Folder\Hidden\SHOWALL hay una entrada que se llama CheckedValue, la cual por defecto es una entrada tipo DWORD, y el virus la elimina y crea una de nombre identico, de tipo alfanumerica, lo que debes de hacer, es eliminarla, y crear una tipo DWORD con valor 1, al menos es lo que se.
      No se si el virus mueva otras cosas, ni cuenta me di bien, pero ya puedo ver archivos ocultos, si aun no ves nada, checa tambien que (al menos en mi maquina) DefaultValue tenga valor de 2.
    2. Tambien dentro de HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Explorer\Advanced\Folder\Hidden\NOHIDDE N
      busca las mismas entradas, y como digo, en mi maquina las 2 entradas mencionadas las tengo con valor 2.
    3. Si no me equivoco, para ver los archivos 'protegidos' del sistema, t vas a HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Explorer\Advanced\Folder\SuperHidden y miras las mismas, yo las tengo en 0 por defecto las 2.

    He aplicado lo que viene en esa posible solución pero no funciona. La única manera de acceder a ellos es por ejemplo a traves del nero. ¿Podríais darme una solución? ¿Se os ocurre algo?

    Un saludo y gracias por adelantado.

    Thursday, March 26, 2009 8:09 PM

Answers

  • Una lectura rápida me hace pensar que las etiquetas de texto están intercambiadas. Esto podría ser otra artimaña del virus, malware, etc. que posiblemente haya infectado en algún momento ese sistema.

    ¿Has probado a seleccionar No mostrar archivos ni carpetas ocultos para ver si así se muestran los archivos ocultos?

    Abre Inicio, Ejecutar, escribe regsvr32 /i shell32.dll y pulsa Aceptar.

    Si fuese necesario hacer manualmente el cambio en el Registro, coméntamelo y te daré instrucciones detalladas.
    Microsoft MVP Windows Desktop Experience
    Thursday, March 26, 2009 11:37 PM
  • Cierra todas las instancias de Explorador de Windows. Abre Bloc de notas y copia y pega este texto:

    Windows Registry Editor Version 5.00  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]  
    "Text"="@shell32.dll,-30499"  
    "Type"="group"  
    "Bitmap"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\  
      00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,\  
      48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,34,00,00,\  
      00  
    "HelpID"="shell.hlp#51131"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\NOHIDDEN]  
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"  
    "Text"="@shell32.dll,-30501"  
    "Type"="radio"  
    "CheckedValue"=dword:00000002  
    "ValueName"="Hidden"  
    "DefaultValue"=dword:00000002  
    "HKeyRoot"=dword:80000001  
    "HelpID"="shell.hlp#51104"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL]  
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"  
    "Text"="@shell32.dll,-30500"  
    "Type"="radio"  
    "CheckedValue"=dword:00000001  
    "ValueName"="Hidden"  
    "DefaultValue"=dword:00000002  
    "HKeyRoot"=dword:80000001  
    "HelpID"="shell.hlp#51105"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]  
    "Type"="checkbox"  
    "Text"="@shell32.dll,-30508"  
    "WarningIfNotDefault"="@shell32.dll,-28964"  
    "HKeyRoot"=dword:80000001  
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"  
    "ValueName"="ShowSuperHidden"  
    "CheckedValue"=dword:00000000  
    "UncheckedValue"=dword:00000001  
    "DefaultValue"=dword:00000000  
    "HelpID"="shell.hlp#51103"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden\Policy]  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden\Policy\DontShowSuperHidden]  
    @="" 

    Guárdalo como Fichero.reg y combínalo en el Registro haciendo un doble clic. A continuación reinicia el sistema. Abre de nuevo Explorador de Windows e intenta mostrar iconos ocultos y de sistema. Si las correspondientes casillas ya estuvieran marcadas, cámbialas, pulsa Aplicar, vuelve a marcar la casilla que quieras y pulsa Aceptar.
    Microsoft MVP Windows Desktop Experience
    Friday, March 27, 2009 9:00 PM

All replies

  • ¿Podrías exportar (Archivo, Exportar) a un archivo de texto la clave HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden y copiar y pegar por aquí su contenido?

    Repite lo mismo con la clave HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden.

    Microsoft MVP Windows Desktop Experience
    Thursday, March 26, 2009 10:03 PM
  • Claro que si, este es el contenido de hidden:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]
    "Text"="@shell32.dll,-30499"
    "Type"="group"
    "Bitmap"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\
      00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,\
      48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,34,00,00,\
      00
    "HelpID"="shell.hlp#51131"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\NOHIDDEN]
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
    "Text"="@shell32.dll,-30500"
    "Type"="radio"
    "CheckedValue"=dword:00000002
    "ValueName"="Hidden"
    "DefaultValue"=dword:00000002
    "HKeyRoot"=dword:80000001
    "HelpID"="shell.hlp#51104"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL]
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
    "Text"="@shell32.dll,-30501"
    "Type"="radio"
    "CheckedValue"=dword:00000001
    "ValueName"="Hidden"
    "DefaultValue"=dword:00000002
    "HKeyRoot"=dword:80000001
    "HelpID"="shell.hlp#51105"


    Y este el de superhidden:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]
    "Type"="checkbox"
    "Text"="@shell32.dll,-30508"
    "WarningIfNotDefault"="@shell32.dll,-28964"
    "HKeyRoot"=dword:80000001
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
    "ValueName"="ShowSuperHidden"
    "CheckedValue"=dword:00000000
    "UncheckedValue"=dword:00000002
    "DefaultValue"=dword:00000000
    "HelpID"="shell.hlp#51103"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden\Policy]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden\Policy\DontShowSuperHidden]
    @=""



    Un saludo y gracias.

    Thursday, March 26, 2009 11:18 PM
  • Una lectura rápida me hace pensar que las etiquetas de texto están intercambiadas. Esto podría ser otra artimaña del virus, malware, etc. que posiblemente haya infectado en algún momento ese sistema.

    ¿Has probado a seleccionar No mostrar archivos ni carpetas ocultos para ver si así se muestran los archivos ocultos?

    Abre Inicio, Ejecutar, escribe regsvr32 /i shell32.dll y pulsa Aceptar.

    Si fuese necesario hacer manualmente el cambio en el Registro, coméntamelo y te daré instrucciones detalladas.
    Microsoft MVP Windows Desktop Experience
    Thursday, March 26, 2009 11:37 PM
  • He probado a activar "ocultar los archivos protegidos y de sistema" y "No mostrar archivos ocultos" y no los muestra tampoco asi. Despues, sin tocar nada, he hecho el cambio del registro con Inicio-->Ejecutar y lo que ha hecho es habilitarme de nuevo  "mostrar archivos ocultos", pero sigo sin verlos. ¿Alguna solución?

    Un saludo y gracias.
    Friday, March 27, 2009 6:25 AM
  • Cierra todas las instancias de Explorador de Windows. Abre Bloc de notas y copia y pega este texto:

    Windows Registry Editor Version 5.00  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]  
    "Text"="@shell32.dll,-30499"  
    "Type"="group"  
    "Bitmap"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\  
      00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,\  
      48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,34,00,00,\  
      00  
    "HelpID"="shell.hlp#51131"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\NOHIDDEN]  
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"  
    "Text"="@shell32.dll,-30501"  
    "Type"="radio"  
    "CheckedValue"=dword:00000002  
    "ValueName"="Hidden"  
    "DefaultValue"=dword:00000002  
    "HKeyRoot"=dword:80000001  
    "HelpID"="shell.hlp#51104"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL]  
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"  
    "Text"="@shell32.dll,-30500"  
    "Type"="radio"  
    "CheckedValue"=dword:00000001  
    "ValueName"="Hidden"  
    "DefaultValue"=dword:00000002  
    "HKeyRoot"=dword:80000001  
    "HelpID"="shell.hlp#51105"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]  
    "Type"="checkbox"  
    "Text"="@shell32.dll,-30508"  
    "WarningIfNotDefault"="@shell32.dll,-28964"  
    "HKeyRoot"=dword:80000001  
    "RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"  
    "ValueName"="ShowSuperHidden"  
    "CheckedValue"=dword:00000000  
    "UncheckedValue"=dword:00000001  
    "DefaultValue"=dword:00000000  
    "HelpID"="shell.hlp#51103"  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden\Policy]  
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden\Policy\DontShowSuperHidden]  
    @="" 

    Guárdalo como Fichero.reg y combínalo en el Registro haciendo un doble clic. A continuación reinicia el sistema. Abre de nuevo Explorador de Windows e intenta mostrar iconos ocultos y de sistema. Si las correspondientes casillas ya estuvieran marcadas, cámbialas, pulsa Aplicar, vuelve a marcar la casilla que quieras y pulsa Aceptar.
    Microsoft MVP Windows Desktop Experience
    Friday, March 27, 2009 9:00 PM
  • Tenia el mismo problema, Gracias daniel martin por el consejo "Abre Inicio, Ejecutar, escribe regsvr32 /i shell32.dll y pulsa Aceptar."

    aparecieron todos los archivos ocultos y de sistema. saludos

    Tuesday, October 20, 2009 8:41 PM
  • Es verdad, yo tenía el mismo problema, y se solucionó volviendo a registrar la shell. A menudo uno intenta reparar claves a mano en el registro, y resulta que los componentes del sistema (como "shell32.dll") ya contienen los valores adecuados para esas claves.

    En mi caso, el simpático "conficker" me las había puesto patas arriba, a lo mejor a vosotros también. Encontré éste foro buscando "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden" en cierto buscador de la competencia, que empieza por g... ;-). Normalmente, huyo de los foros de debate en español, pero está claro que aquí sabéis muy bien de lo que habláis. ¡Bravo!

    Monday, February 28, 2011 7:57 AM