none
Exchange 2010 resource mailbox double booking issue..

    Question

  • Hi,

    I have moved the meeting room mailbox from exchange 2003 to 2010:

    set-Mailbox -Identity:<resourcename> -Type:Room

    but after that, the meeting room can be double booking in the same time.

    I have tried folllowing command, but it's failded.

    Set-CalendarProcessing -Identity <mailbox identity> -AllowConflicts:$false

     

    Thanks.

    Thursday, December 22, 2011 7:15 AM

Answers

  • I hear about double booking often at my customers and Exchange does not allow it by default.
    The problem has almost always been that booking has been made as an all day event. When choosing All day event in Outlook, the status (show as) is changed from busy to free and that's why the room seems to accept it.

    Choosing "All day event" will not book the room, even if an accept message is sent, cause the status is set to free. I usually change the setting of MaximumDurationInMinutes to something less than 1440 (default value) to have the room send a decline when all day event is choosen.


    Martina Miskovic - http://www.nic2012.com/
    Monday, December 26, 2011 8:08 AM

All replies

  • hi,

    when you send a booking request,do you receive a message like this

    If not,i think that's why you can double booking.Becasue you request haven't been accept.You should open the room mailbox properties and then  choose resourec general check on Enable the Resource booking attendant.And try again.hope can help you

    thanks,

    castin

     

    Friday, December 23, 2011 8:54 AM
    Moderator
  • Hi,

     

    You're right, I did not get receive thsi message. As this meeting reqeust conflicts with another one, but I can see the meeting schedule in my calendar.

    Persoanlly, I think I should get the message that tells me my booking reqeust conflicts with anther one and then fails.

     

    Thanks.

    Friday, December 23, 2011 9:08 AM
  • Hi,
    Have you configured the room to procesess meetingrequest automatically (you need to)?
    Set-CalendarProcessing RoomMailbox -AutomateProcessing AutoAccept

    If not, then the meeting request you send will only end up in the inbox of the room and is not really booked. Only configured as Tentative.

    Even if the room sends a Decline, as it should when a conflict is found, you will still see that meetingrequest in your own Calendar.

    Martina Miskovic - http://www.nic2012.com/
    Friday, December 23, 2011 9:22 AM
  • yes, I did that.

    This issue seems a bug :), because this meeting room is moved from exchange 2003.

     

    Merry Chrismas :)

    Friday, December 23, 2011 9:33 AM
  • Hi,
    Did you also remove the resourse booking setting on the calendar in the mailbox after you moved the mailbox to Exchange 2010?
    If not, then you should cause that kind of booking is not by default supported by Outlook 2010 and I have heard having both set, causes problem.

    Merry Christmas to you too!!
    Martina Miskovic - http://www.nic2012.com/
    Friday, December 23, 2011 9:40 AM
  • Hi Martina,

     

    Thanks for your reply, How can I check if I remove the resourse booking setting? and what's the setting I should remove?

     

    Thanks.

    Friday, December 23, 2011 1:24 PM
  • Hi,
    Give yourself full mailboxpermission on the mailboxes and log on to them using Outlook and make sure that they doesn't have any of settings in the below picture set.

    File | Options| Calendar


    Martina Miskovic - http://www.nic2012.com/
    Friday, December 23, 2011 1:31 PM
  • Hi,

     

    In my case, I think I should enable first two options to make this resource mailbox works normally.

    If I remove both tow, the meeting can be double booking. If not, the meeting room will reject my reqeust and let me konow another one already booked this room at the same time.

    Meanwhile, I try to create new pure resource meeting room, both two options are unchecked.

     

    Thanks.

    Monday, December 26, 2011 1:38 AM
  • hi,

    any updata

    thanks,

    castin

    Monday, December 26, 2011 7:04 AM
    Moderator
  • I install the outlook 2010 direct booking patch, now It seems ok.

     

    Thanks.

    Monday, December 26, 2011 7:20 AM
  • I install the outlook 2010 direct booking patch, now It seems ok.

     

    Thanks.


    Why?

    I would be better if you remove the Direct Booking options from the room.
    To log on to the room using Outlook, just give yourself fullmailbox access and when asked for credential, you enter your own.
    Martina Miskovic - http://www.nic2012.com/
    Monday, December 26, 2011 7:22 AM
  • I am not sure if I enable the direct booking option for this meeting room, but now when I try to book the meeting book at the conflict time, it will reject and then sends em a warning about "another one aleady booked this room at the same time"

     

    Patch: http://support.microsoft.com/kb/982774 outlook 2010 bug?

     

    Thanks.

    Monday, December 26, 2011 7:31 AM
  • I wouldn't call it a bug.
    Exchange 2007/2010 is not designed for Direct Booking as so is not Outlook 2010, so there are reason why it's not enabled. I really don't see any good reason to have it enabled.
    If you decide that you want it anyway, make sure that that you don't have both enabled (Direct booking and AutomateProcessing AutoAccept.

    If you want to allow conflicts, then you should allow it using -AllowConflicts $True instead of $false


    Martina Miskovic - http://www.nic2012.com/
    Monday, December 26, 2011 7:35 AM
  • Hi,
    Give yourself full mailboxpermission on the mailboxes and log on to them using Outlook and make sure that they doesn't have any of settings in the below picture set.

    File | Options| Calendar


    Martina Miskovic - http://www.nic2012.com/

    Log on the room, If you haven't done so already and check the setting for Direct Booking.
    Martina Miskovic - http://www.nic2012.com/
    Monday, December 26, 2011 7:39 AM
  • Hi,

    I think I enable both on this meeting room, and I do not want to allow conflict -AllowConflicts $false.

    I'll retry to disable the direct booking options again to check if It will allow double booking.

    Monday, December 26, 2011 7:56 AM
  • I hear about double booking often at my customers and Exchange does not allow it by default.
    The problem has almost always been that booking has been made as an all day event. When choosing All day event in Outlook, the status (show as) is changed from busy to free and that's why the room seems to accept it.

    Choosing "All day event" will not book the room, even if an accept message is sent, cause the status is set to free. I usually change the setting of MaximumDurationInMinutes to something less than 1440 (default value) to have the room send a decline when all day event is choosen.


    Martina Miskovic - http://www.nic2012.com/
    Monday, December 26, 2011 8:08 AM
  • We have just run into a similar issue, and are working through the Direct Booking and Double Booking issues with MS. 

    To show that the issue was persistant with new Room Mailboxes and not just those that were setup prior to migration to E2010 on E2003, we created a new Room Mailbox and applied Resource settings accordingly.  Our testing on the new mailbox showed that users could perform Direct Booking regardless of permission level on the Room Mailbox thus creating Double Booking situations.

    Stay tuned because there's likely more fallout from this.

    Wednesday, March 28, 2012 9:15 PM
  • Any updates on this? We have several meeting rooms & only one that does not decline meetings when double-booked. Configuration of mailboxes all appear identical.
    Wednesday, September 25, 2013 12:12 AM