none
RDS 2012 ntuser.dat issue

    Question

  • We have a test RDS 2012 server configured running the RD Connection Broker, RD Session Host, and RD Web Access roles.  We installed an ERP application we are currently running on TS 2008 and RDS 2008 R2 servers.

    The application is running fine so far with the exception of making a change to the users ntuser.dat file.  We are not using roaming profiles, they are local to the server. 

    On the TS 2008 and RDS 2008 R2 servers we make sure the user is logged off and run regedit and load the users hive file. (ntuser.dat) We expand Control Panel>Colors and set the GrayText option to 0 0 255. (color blue)  Makes it easier for our "older users" to see it. 

    If we do the same thing on the 2012 RDS server the change is made but when the user logs in it still shows as the default gray (109 109 109).  The profile is not temporary. We tried to update the .Default and Default profiles so when a new user logs in for the first time it will be set to 0 0 255.  This is how it is set on the 2008 and 2008R2 servers.  But the GrayText stays the default GrayText.  Has anyone else run into this?

    Monday, November 04, 2013 9:53 PM

Answers

All replies

  • Hi,

    Based on my research, GrayText only works for Menus in legacy apps when inactive in Windows 8 or Windows Server 2012. Therefore, what you have encountered seems to be normal.

    More information:

    Change Windows Background color in Windows 8

    http://social.technet.microsoft.com/Forums/windows/en-US/a5699003-9233-4ddc-96fc-e3c1e4a2a81b/change-windows-background-color-in-windows-8?forum=w8itprogeneral

    Hope this helps.


    Jeremy Wu

    TechNet Community Support

    Wednesday, November 06, 2013 6:55 PM
    Moderator
  • Hi,

    I would like to check if you need further assistance.

    Thanks.


    Jeremy Wu

    TechNet Community Support

    Monday, November 11, 2013 8:19 AM
    Moderator
  • Hi Jeremy,

    Thanks for the reply.  Inside the application the issue is gray on gray text on the screens the users look at.
    If I set the option on the HKCU>Control Panel>Colors and reboot and log into the console of the server it works.
     
    If I log out and connect via remote desktop with the same user it defaults back to gray text.  It seems like you should be able to enable this for rds clients also. 

    Monday, November 11, 2013 8:35 PM
  • Hi,

    Thanks for your reply.

    I am trying to involve someone to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.


    Jeremy Wu

    TechNet Community Support

    Tuesday, November 12, 2013 7:51 AM
    Moderator
  • Please be note that the GrayText option is not allowed to be changed since wijdows 2012 by default, even you can change the GrayText  dword value, the change will not be save any more, that is why when you logoff and connect again it defaults back to gray text.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, November 14, 2013 10:24 AM
  • Hi Jeremy,

    Sorry for the delay posting back.  We opened a call with MS and I will update with their response.

    Thanks.

    Monday, November 18, 2013 11:12 PM
  • Thanks.

    It will benefit other users a lot. 


    Jeremy Wu

    TechNet Community Support

    Friday, November 29, 2013 9:45 AM
    Moderator